cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Sketch choosing wrong solution

JonathanHodgson
11-Garnet

Sketch choosing wrong solution

So, I've sketched a revolved cut. (The part is cut into a segment for Mechanica cyclic symmetry.)

arc_solve_1.png

With the length at 9, it works. If I edit the value, it seems to have a random chance of simply stretching the geometry, or turning the arc inside out!

arc_solve_2.png

... but then works again at another value.

arc_solve_3.png

I've dimensioned plenty of sketches like this over the years, but this one started causing problems doing a Sensitivity Study in Mechanica.

Is this likely to be an accuracy thing, or something else?


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
13 REPLIES 13

I've been having all kinds of similar problems in Creo 2.0. I have a spline that changes points out of the blue when I edit a completely indepent feature. I've been playing with the accuracy in this file and nothing makes a difference. It is just unstable.

Just for giggles, what happens if you input the 10.5 value as -10.5?

arc_solve_4.pngarc_solve_5.png

Go figure...

Hi Jonathan...

I've had weird issues with sketches in the past. They're rare but they've happened to me before.

I can't say I know why you're having the problem- but I have a potential solution to fix it. Or... at least "patch" it so you can continue work.

Try changing the arc from being driven by the "R6" radial dimension. Instead, convert that arc to a perimeter dimension using the "R6" as a reference. It would look similar to below (click for a larger image)...

perim.png

This way, you can lock that perimeter dimension and sketcher can't force the arc to flip. You'll still have the same radius but the arc can't go haywire when you're attempting to use those "middle values" that flip the sketch.

Sorry I don't have a better answer but this might get you through!

Good luck!

-Brian

A colleague had the simplest 'fix': sketch that feature with a vertical step instead of the R6 arc, then add an edge-to-surf round.

Still stupid that it can't solve consistently for all values, though.

Okay no fair! You have to make it work in ONE feature using a sketch... using multiple features is cheating!

Just kidding... glad you got it to work!!

Many simple features!

Except that the first feature didn't actually get any simpler...

I've seen some weird stuff in sketcher too. I tend to use pretty complex sketches in my top-down design, especially if I'm doing any motion, and I've seen some bizarre stuff. As you saw, usually with arcs flipping. Sometimes what I'll do is simply delete the offending arcs and put them in again, using "replace" if the arc is used elsewhere.

Here's a thought I just had: Try adding a tangent construction line (as shown dotted) or arc to the end that keep flipping, and constrain that. This way the arc cannot flip without breaking a constraint elsewhere.

PROE_ARC_FLIP-01.JPG

Ah... another sharp solution, Frank. I couldn't have thought of that.

I think we're basically all trying to do the same thing- use some mechanism within sketcher to contrain the sketch such that it cannot flip. There are probably other ways to do this beyond the ones we've mentioned.

Does anyone remember the OLD sketcher having this problem? Hehe... don't answer that. I don't want to open another can of worms.

Regards,

-Brian

I wouldn't say "couldn't" there Brian. Knowing you, I'm sure you would have.

I want to see if the above would work for Jonathan, hope he tries it.

Ahh, yes, I think the pre-intent-manager sketcher (v19?) was a little more stable, but I like the new one better overall because it's faster and better most times. I DO believe the best solution would be to eliminate the "intelligent" sketcher trying to find solutions and/or dimensions, and be more like AutoCAD where all the "constraints" (not truly a constraint, but the closest analogy) are all dictated by the user alone. On complicated sketches, like logo's, I'll turn off all the automatic constraints first. Speaking of that, I wish sketcher had a mode where you could import line entities (as from A/C) as a block, being able to scale and rotate, but having it all be one entity unless you "exploded" it. And even then, not have any constraints or dimensions unless you ADDED them.

Ahh well.....

OK, hit the issue again:

rad_flip1.png

rad_flip2.png

But then I tried adding a construction line - not even an additional constraint, just something else for Sketcher to solve - and it cured it!

rad_flip3.png

This software just gets weirder...

It would probably also work if you added a dimension to the tangent point of the radius.

So, my suggestion worked for ya? Cool.

Announcements