Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

shrinkwraps disappear when geometric tolerances are erased


shrinkwraps disappear when geometric tolerances are erased

You'll have to forgive me if this has been discussed, but I don't see how to search only the forums.

Anyways, I have an assembly largely composed of shrinkwraps, used to produce a machine placement drawing for customers. Some of the parts used in the drawing rep may have geometric tolerances or datums showing up that need to be erased from the drawing views. If you elect to erase all those at one time, the shrinkwraps will also disappear. It's a known problem. So we don't do that.

However, I've been working on a drawing where I erased and deleted some geometric tolerances on a drawing view one at a time, and some of the shrinkwraps disappeared from both the assembly and drawing. I can bring them back in my assembly by going to redefine the rep, but not making any changes; just clicking ok. But on the drawing, the shrinkwraps are gone and can not be brought back. They're gone. In the past, if we elected to again show the geo tolerances, the shrinkwraps would come back. But not this time.

Our admin is going to put in something to PTC on this, but I thought I'd try to see if anyone has had this problem, and was able to resolve it. I often find Creo annoying, but this is the first time it's stopped me from doing my job.

This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.

Check the drawing tree to see if the items are listed there.

Nothing in the assembly tree disappears. If I check the rep column, the shrinkwraps show up as being master rep.

It's almost like the drawing isn't up to date, and is trying to overwrite the assembly.

Drawing tree.

There is a list of views and for each view is a list of items that have some relation to that view.

My tree shows only annotations, datums, and snap lines. Setting of some kind?

Before all else - this may be a glitch that retarting Creo will fix or it may be a stupid bug that PTC will need to deal with.

I was hoping that you'd see the annotations you'd erased and that they'd brought the shrinkwraps with them.

As far as settings, none that I know of - it's usually annotations that seem to vanish and can't be 'shown' that need to have their association to views deleted. This makes the drawing tree a first place to look.

You may have mis-selected the annotation and gotten the entire feature instead.

It may be worthwhile to start at the overall drawing layer tree if the shrinkwrap vanished from all views at the same time.

If the shrinkwrap features still exist but you can't see them, they could be hidden by layer on a per-view basis. You can look at the layer tree for the drawing and select each view they items have disappeared from using the pull-down to see what the layer status is and from there see if there are items you don't expect on the layers that aren't visible.

I'm leaning towards bug. All the stuff you suggested is good, and all was tried. Reboot, restart, unhide layers and parts, etc. Nothing worked. I finally went with showing the assemblies rather than the shrinkwraps. It's less effective and slower with graphics, but at least it works. thanks!

I don't know if this is related in algorithm or not, but I noticed something yesterday that I found odd.

When I had a part open that had a reflection analysis active over the entire part, it would not show correctly in an assembly. Highlighting the component in the assembly would show the part in the wrong orientation and a second instance assembled into the same assembly would not show up at all. The analysis was not active in the assembly, only in the open part. when I hid the saved analysis feature, the assembly worked correctly.

I have a suspicion that shrink wrap works similarly to the reflection surface used in analysis where it becomes persistent even over a wireframe display setting.

I hope you will consider submitting your issue as a support case. My issue was using Creo 2.0 M040.

Just an update on this. My Creo admin created a new drawing and transferred the dimensions from old to new. He couldn't transfer the views without the same problem happening.

If he brought up the original drawing before the copy, then the copied drawing would have the same problem.

We also found that in spite of the model tree saying the opposite, the parts missing were not in session.

It's as if the drawing was telling the assembly what to bring up, instead of vice versa.

This is being submitted to PTC by my Creo admin.

Thank you for the follow up Sean. I hope PTC can resolve this quickly for you.

Attention: Creo 7.0 Customers
Please consider upgrading
End of Life announcement here.