Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Help us improve the PTC Community by taking this short Community Survey! X

Cross-section fails to intersect part


Cross-section fails to intersect part


In my assembly I replaced a screw with another which made my cross section fail. I get the following: "WARNING: highlighted loop in cross-section B may be incomplete." And the screw is red with no hatching. I open the screw part and try to put a x-section through it and I get the following: "Cross-section fails to intersect part." I verified the screw is a solid, tried .sat and .stp imports, and tried moving the x-section so it is offset from center. So what stops pro/e from cutting a cross section thru a part?

Wildfire 4.0 Datecode m220

Windchill PDMLink 10.0 Datecode m030




Hi Eric,

In my experience, failure to cut a cross section is usually related to
accuracy settings, or to geometry producing very small edges (i.e.,
outside the accuracy limits).

Is there any fine detail on the screw?


I've seen this several times in the past.

Try the accuracy setting (already mentioned). If that doesn't work, the
only solutions I know of are less than ideal.

First solution: remodel the screw. Don't use the same file to recreate
geometry. Start a new file entirely.
Second solution: move the x-section plane off the axis of the screw by
~.005" (sometimes slightly more, sometimes slightly less)

The second one works every time. Usually the offset is small enough that
the shown dimensions still appear to go to the object lines in drawing
views, but if you use draft dimensions created at the drawing level,
they will not be accurate.




My client have the same issue but with extractors. Creo 4 M110

I move the cross section 3,5 mm and cuts. 

This value is too big. 

I don't know what to do :S

Thank you in advance
Mariana Sousa