Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Help us improve the PTC Community by taking this short Community Survey! X

Pro/E - Laptop and sleep mode


Pro/E - Laptop and sleep mode

Hi everyone,

I'm running Pro/E wildfire 4 on my laptop which is running Windows 7. I'm having the problem where if I leave Pro/E open before I put the computer to sleep, upon waking up the computer the Pro/Engineer warning message pops up saying "Unsaved data may have been lost". Everytime I put my computer to sleep and wake it up, an additional pop up appears. If I have more than 2 warning messages, I can't click ok on any of them and I have to force quit Pro/E

I attached a screen shot to this thread.

Does anyone know a solution for this?




Yes, I think it's always done this, and it drives me mad.

Please PTC fix this or somebody post a workaround.

Bump, Anyone know a solution?



I don't know what you are using for licensing. If it is a remote server, or a local license, but it has to do with Pro/E losing it's connection to the license. If it is a local license, have you tired to adjust the power settings in your Bios to not turn off the Ethernet adapter on your PC. Yes it will take more power from your battery, but you might not get those messages anymore.



Well it's been a long time and I've upgraded to Creo 5.0 student edition and I'm experiencing the same problem. My license is local and my ethernet port is always enabled. Will this ever get fixed?

24-Ruby II


if your license file contains SERVER line and DAEMON line, then your license is floating (you must install FLEXnet to manage the license). In this case ProE is checking the accessibility of license every minute. If you put the laptop in sleep mode, then ProE is unable to contact FLEXnet for more than one minute and you will receive the warning. I think you have to exit ProE before you put the laptop in sleep mode.

Martin Hanak

Martin Hanák

I just tested this assumption on Creo 2.0.

I have a session running and put the computer to sleep with the power button. I came back and it behaved the way the OP suggested. A "data may be lost" message, and a message below to retry the license. My session came back and all was well. This very much like the old inactivity time-out from much older versions where LM would "reconnect" a license.

My license is a floating license with a server and daemon.

Try using the "WIN+LEFT ARROW" or "WIN+RIGHT ARROW" to move the menus off of each other.  


"WIN+SHIFT+LEFT" or "WIN+SHIFT+RIGHT" will move this window to another screen


I have the same issue on my non-portable workstation. The computer goes to sleep: everything is fine. I wake it up, everthing is fine IF I go and click ok on that stupid warning box before it goes to sleep again. If I do not, as is the case when my PC wakes up at 4 AM to do a scheduled backup, then goes back to sleep, I end up with 2 stacked warning boxes and I have to kill pro E losing any unsaved work and the time it takes to restart and re-open all of the work I had in progress. It is beyond irony that this warning box telling me that I "may have lost data" is actually ensuring that I do lose data. If you would just give us an option to disable that non-helpful warning, we could save the planet by letting our PC go to sleep and wake up WITHOUT closing the program and restarting it. Occasionally one walks away from ones desk for a bathroom break and then gets interupted long enough that the pc goes to sleep before their return. When doing some complicated work in a large assembly with multiple windows open, its does take a while to quit the program and get back to where you were. So for the sake of mother earth and for my electric bill, please give us the option to turn off that totally useless warning message so that pro E will have the same functionality as pretty much every other windows program!!!!!

Yes, this is definately the silliest "feature" I have ever seen. You are much more likely to loose work with this.

Occasionally I catch it early where I can click a few of these boxes and get back, but most of the time there is an endless supply of them and I have to kill the program.

I usually run my laptop with a checked out license, so licensing should not be the issue.

I called tech support and they told me to use this setting, but it does not fix it.

suppress_license_loss_dialog YES

I was hoping CREO would fix it but no luck.

I think we need to try suppres_data_loss_dialog YES

I just made that up but perhaps its one of those undocumented easter eggs..

If not, maybe the developers will kindly add that opttion to suppress that totally useless dialog box that actually causes us to lose data and prevents the program from allowing normal suspend and resume events

Licenses should never hinder productivity!

I have a similar question up regarding license management issues (didn't find this post) where my license is getting locked when all seems normal and I put the computer to sleep. At the moment, it requires a reboot. This is a productivity hit when a simple "release license" batch file will solve it. This should be linked directly to the license error dialog so a user can easily get on their way. There is a simple command line for this but by default it is disabled. I know you wouldn't want to be taking other people's licenses when they are in use, but when the enterprise only has one license, and you are the only operator, an option should be available to just keep working. Doesn't FLEXLM detect system states and make reasonable assumptions about the current usage?

Does any user have an example of where this 'data may may be lost' dialog box was helpful to them in any way at all?

If the answer is no, it really seems like a no-brainer to supress it by default or just strip out the code entirely.

I had the dialog come up and seemed everything was well when suddenly the license failed and requested that I save or just exit. What the...? At least it asked... so the danger of actually loosing data has already been minimized so if they disable this useless dialog, I hope they only throw out the bathwater, and not the baby.

The actual data loss issue occurs once there are a number of these warning data may have been lost message stacked atop one another. they you cannot close them and you must ctrl alt del and kill xtop to proceed hence losing any unsaved changes and the time it takes to retrived all of yoru working files and get back to where you were. For me this occurs nightly because my machine goes to sleep and then is awakened for backup and goes back to sleep. If you awake the machine and fail to clear the warning box by checking 'ok" then you get 2 stacked boxes. I have successfully recovered with 2 stacked boxes, but never with 3. I'm not sure about why it behaves that way unless they need to be clicked in a specific and impossible to discern order.

With XP I would get a warning from Pro that would not allow me to sleep without OKing. With WIN 7 it just goes to sleep. Then when waking up on the dock (same ip?) it is OK, but when going wireless, it is not. XP was better for this, 7 just locks up pro.

Also noticed that with XP, pending Lotus notes mail caused a popup before going to sleep, not sure if that happens with WIN 7 either.

Hello Mark and welcome to the forum.

I have had serious issues with sleep mode on my Windows 7 64 bit computer. It is not completely solved but much better today.

Two things to look at:

1st, what is the order of the network adapters in your registry? This was resolved with the help of customer support. Somehow, an ID of 12 is considered "1" where an ID of 2 is second. Weird, I know, but they edited my registry to solve this 1st issue.

2nd, Tech support also downgraded the license manager. Since I have a single fixed license, it was downgraded to an earlier wildfire version. This seems to have solved all kinds of problems for my fixed license. If this is your environment as well, this too might be an option.


7 years after this thread is's still a problem. Currently using Creo 4.0 but reading the posts looks like this bug hasn't been fixed in Creo 5.0 yet.

Make it one more year. Using Creo 4 M080. At work I move between buildings pretty frequently, and put my computer to sleep at the end of each day. I'm working with extremely large and complicated assemblies, so I keep them open with Creo running to save time rather than reopening them constantly. Each time I wake up my PC, I'm greeted with 2-3 of these dialog boxes that have to be cleared before I can resume using the software.


Occasionally, the dialog boxes appear in such a way that they're stacked on top of one another and the one you need to acknowledge is hidden behind another one. I've found that in these instances, if you can mange to get the proper window in focus with ALT+tab or some other means, and then hit enter or the space bar, it'll dismiss the appropriate window because the OK button is in focus, even if you can't see it.


The only time I've run into trouble with this is if the hidden window is a "License Lost" popup. In which case I think the exit button was in focus, and this caused everything to close.


Really annoying, in any case, and it's clear PTC has no plans of fixing this. I'm surprised at how long this issue has been going on. They need to make it so this window can only be spawned once, or just do away with it entirely.

23-Emerald II

It really isn't a PTC issue, it is a Microsoft and/or FlexLM issue.


The settings for timeout of a license are causing the software to lose license connectivity to your license server. When we started suing laptops for engineering managers, we installed all laptops with individual licenses, no internet connectivity needed for the license. This allowed them to take the laptop anywhere and still have licenses to their software.


Sorry. To clarify, I wasn't talking about fixing or doing away with the licensing popup. I totally understand what that is and why it's happening in my particular case. Due to our security policies (I assume), we have to maintain connection with the licensing server and don't do individual machine licensing. 


What I find annoying and what should be fixed is the behavior of the "unsaved data may have been lost" popups. Namely, how they are spawned multiple times, and how they hide each other and other important dialog boxes.

I was fighting with the same long time. Every time I am sending my Laptop to sleep and moving on home network I get two notifications. My license get lost and the server I belog two is not available (obviously, to get an access I need to start VPN). The problem is that there is no usual way to bring the window with "License is got lost" to front. 


But finally, by click on empty area on taskbar I could select Show windows side by side. Than I could press on "retry"



I am also facing the same problem, but instead of restarting creo, I will use CASCADE WINDOWS option in taskbar, that will bring the "license window" front of the screen, in that we can give retry to resume the license, that will save the work and our Time.


Hope this will be useful,



Bhoopathy Somasundaram

23-Emerald II

I use an option in the but I am not sure it is for the same issue.

suppress_license_loss_dialog YES

Top Tags