cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - New to the community? Learn how to post a question and get help from PTC and industry experts! X

Can't find e3 package or functions under new 5.4 installation

naglists
1-Newbie

Can't find e3 package or functions under new 5.4 installation

Just WAGing: Have you edited config.xml (e3config.xml? I can't remember)?
Some "stuff" you have to enable via E3 Interactive in that config.xml file
(or copy the old one although across versions that could be risky if the
format / content model has changed).

2 REPLIES 2

The only thing that looked relevant to my problem in the e3config (although I may have missed something) was allowing the functions I wanted to use but that had been done already. I figured out a workaround to my problem by using autoload e3::string_to_array e3; lines at the beginning of my .acl file for each e3 package function I needed to use. I'm not sure why this worked when it said it couldn't find e3 but I'm glad it did, guess I need to read up on what exactly autoload does. Thanks for replying and if you have any autoload info, I'd love to hear it!

In Reply to Paul Nagai:
Just WAGing: Have you edited config.xml (e3config.xml? I can't remember)?
Some "stuff" you have to enable via E3 Interactive in that config.xml file
(or copy the old one although across versions that could be risky if the
format / content model has changed).

Got me. Might be worth raising a trouble call, though. If it's not an
e3config.xml issue, maybe something is wonky in the latest release.