cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Parser messages with FOSI file when I use Arbortext Editor 6.1

SOLVED
Highlighted
Level 8

Parser messages with FOSI file when I use Arbortext Editor 6.1

Hello,

When I Use a FOSI file with Arbortext Editor 6.1 M090, I have the following errors, but when I use Arbortext 6.0 M100, I don't have errors. Why these errors when I Use Arbortext Editor 6.1. Can you help me?

Regards,

David

ERROR: on line 3: Public literals must consist of minimum data characters; _ is not a minimum data

character. Replace with an alphanumeric character or one of the following: ( ) + - , . ' / : =

ERROR: Quantity limit ATTSPLEN exceeded. The required quantity value is 969; the currently declared

maximum value is 960. The following elements are currently open: FOOTER PAGESPEC RECTOPG

PAGESET PAGEDESC OUTSPEC . The following entities are open: C:\Program Files\PTC\Arbortext

Editor\custom\doctypes\IPD41\Schemas\ipd.fos

ERROR: Quantity limit TAGLEN exceeded. The required quantity value is 976; the currently declared

maximum value is 960. The following elements are currently open: USETEXT FOOTER PAGESPEC

RECTOPG PAGESET PAGEDESC OUTSPEC . The following entities are open: C:\Program

Files\PTC\Arbortext Editor\custom\doctypes\IPD41\Schemas\ipd.fos

...

 

1 ACCEPTED SOLUTION

Accepted Solutions
Level 8

Re: Parser messages with FOSI file when I use Arbortext Editor 6.1

Hi, I have found the solution. My problem is not related to the software version but to a recording preference (Writeaticomment). When the parameter is deactivated, the file is parsed relative to the SGML declaration at each opening. In the file, when the parameter is deactivated, the line "<! - Arbortext, Inc., 1988-2013, v.4002 ->" is missing. In fact, my FOSI File is not totally complient with the SGML declaration.

Regards, David.

1 REPLY
Level 8

Re: Parser messages with FOSI file when I use Arbortext Editor 6.1

Hi, I have found the solution. My problem is not related to the software version but to a recording preference (Writeaticomment). When the parameter is deactivated, the file is parsed relative to the SGML declaration at each opening. In the file, when the parameter is deactivated, the line "<! - Arbortext, Inc., 1988-2013, v.4002 ->" is missing. In fact, my FOSI File is not totally complient with the SGML declaration.

Regards, David.