Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to Learn more.

calendar of PlanetPTC


calendar of PlanetPTC

Those of you going to the planetPTC is there a calendar of sessions. I only
see a listing, but not in calendar form. Is there one and I am missing it?
Or should I create it.


Hi Doug-

This might be close enough to what you're looking for. It's a searchable
session database-not exactly a calendar, but you can list sessions
sorted by date/time.

There is an Agenda Grid here:

Thanks Clay:

That is what I have seen. It lists all 21 Arbortext events, but I want it in
a calendar. So, I made a public one. anyone can use it, see link below. If
anyone wants to write to it, let me know and I will add you. I will add
other items, that I am interested in, which may be more than just Arbortext
(colored purple), like RELEX. I color something else. I will be adding other
events like parties to it.


View PTC World Calendar - Arbortext Sessions


thanks. That is helpful, but I will continue to use my google calendar, so I
can carry it on my phone.


On Wed, May 18, 2011 at 9:42 AM, Michelle Stokes

> There is an Agenda Grid here:

Nice! Thanks for doing that. When is the Arbortext Social? Tuesday evening?
Be sure to add that.

When is the Arbortext Social? Tuesday evening? let me know, I will add it.


I have it on pretty good authority it will happen Tuesday, but I can't find
a public announcement of it. Specifically, I heard:

* Arbortext Reception - targeted for the 2nd night of the conference, the
Arbortext Business Unit from PTC is looking forward to hosting all Arbortext
attendees for networking, refreshments and entertainment.

Until it is publicly announced (which may not be until the conference is
underway?), I guess it is in the "Likely" with time/date/location TBA.

I am messing around trying to get our home-grown document management system to work with Arbortext 6.0. One of our old ACL files uses a function called parent_dir(). It is used to build a path to another directory.
For some reason, it appears that parent_dir() does not return anything in Arbortext 6.0. I haven't been able to find out much about this in either 5.2 or 6.0. Not much documentation on it that I can find.
Does anyone know if this has been deleted in 6.0 and if so, what replaced it?

Hey, Ed...

I'm pretty sure parent_dir() is a custom function defined elsewhere in
your ACL code.

-Brandon 🙂

That's probably why it's undocumented.

I have an ACL file with a line that reads, "response(doc_type_dir());" which, in Arbortext 5.2 produces a response dialog with the path to my doctype directory.

In Arbortext 6.0 the same ACL file produces a blank response dialog (except for the OK button).

When I type "response(doc_type_dir())" on the command line in Arbortext 6, I get a response dialog with the correct contents, but the same line in ACL produces nothing.

In the past there have been some commands, etc. that require different syntax in ACL from what they require on the command line. It seems as though doc_type_dir() has acquired this behavior in Arbortext 6.0.
Anybody got a clue?


I've just tried this in 6.0, but don't get a problem.
The response command was the only thing in my acl file; might there be something else in your acl which is causing this line to be skipped?

Adrian Jordin
Senior Consultant

Mekon Ltd.
Mekon House, 31-35 St Nicholas Way, Sutton, Surrey SM1 1JN.

Meet us @ Congility S1000D 2011 - May, UK:

I'll try that next.


It could also be a timing thing whereby, in 6.0, the information for the doc_type_dir() command doesn't have the doctype data available yet. The order in which ACL files are loaded is critical at document loading. When things settle out, you have all the data available, such as when you use the command line.

Or, as Adrian mentions, there may be something prior to the command that is not quite correct that hoses up the response.


I tried a doctype.acl file with only the response(doc_type_dir()); command and it still doesn't work. Digging deeper now.