cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you get called away in the middle of writing a post? Don't worry you can find your unfinished post later in the Drafts section of your profile page. X

"Attempt to use non-existent character (61527)"

ptc-1908075
1-Newbie

"Attempt to use non-existent character (61527)"

Does anyone know where I can find out what character this error message refers to?
Attempt to use non-existent character (61527) in font "Arial"
> - looking for slant=regular, weight=medium (500)
> - no substitute character exists in font "Arial Unicode MS"
Thanks!

Suzanne Napoleon
www.FOSIexpert.com
"WYSIWYG is last-century technology!"
15 REPLIES 15

This was what I was told by PTC support for arbortext editor.



In the error window it will tell you in brackets the number of the offending font (129,0x0081).



You will use the first number to search for the bad font. This window will also tell you where to locate the bad font. If it says something about filename.style you need to look in the style sheet. If not it should tell you show you a path to the bad file.



How this procedure works is that you give the character an atribute of "findit", then you search on that attribute. If you do not do this then you will not be able to search for the bad font asthere is nothing to search on.



Open the document or fosi in Arbortext Editor. At the Arbortext Editor Command: line enter
$FINDIT=chr(129) and hit the Enter key Now enter (find "$FINDIT") you may not need the quotes.



Bryon

Unfortunately, the error message was just what I quoted. No path, no file name. Only the five-digit number. I can't find any file that specifies characters that way.

I am not aware of the FOSI generating any special character. However, the document does include some special characters. I guess I'll check it.

Thanks!
Suzanne


Hi Suzanne--



That is a "private use" character, as shown in this Unicode Map website:

If you can search your document with a hex editor, Unicode 0xF057 would be a three byte character, ef 81 97.

This has worked for me in the past. Often these characters have been inserted by MS Word for some internal purpose and are transparent in Arbortext until you try to compose the document.

David

David S. Taylor

Project Manager, Structured Information
Production and Marketing | Building Regulations | NRC Construction
Building M-23A, Room 114 | 1200 Montreal Road | Ottawa, ON | K1A 0R6
Telephone: 613-990-2731 | Fax: 613-952-4040
David.S.Taylor@nrc-cnrc.gc.ca<">mailto:David.S.Taylor@nrc-cnrc.gc.ca>



Time to start halving the input.... 😕


Thanks for all the informative replies! Silly me, I took the error message at face value.It never occurred to me I would have to convert the number. So I'm glad I asked. Now the info is in the archives.

It turns out an off-brand PDF viewer isn't showing fi ligatures. So in the doc, which had come from Word, I tried replacing "fi" with "fi" and that seems to have worked 🙂

Thanks again!
Suzanne


Hmmm ... changing fonts made the message come back.



>----------

Unless you've disabled ligatures in Arbortext, it's probably a good idea to
ensure that you can find find in a PDF. That is, confirm you can search for
the word "find" and "flower" and words containing whatever the other
ligatures are.

fi
fl

Are the two I always remember.

Why? Because there was a time when Arbortext used the ligature in the text
of a PDF (not just in the "image"), too. When this was true, you couldn't
do a search on such words because you were looking for f-i-n-d while the
PDF contained fi-n-d. I do not know if that got fixed or not. We still
suppress ligatures entirely.


On Wed, May 15, 2013 at 10:48 AM, Suzanne Napoleon <
SuzanneNapoleon@fosiexpert.com> wrote:

> Thanks for all the informative replies! Silly me, I took the error message
> at face value. It never occurred to me I would have to convert the
> number. So I'm glad I asked. Now the info is in the archives.
>
> It turns out an off-brand PDF viewer isn't showing fi ligatures. So in the
> doc, which had come from Word, I tried replacing "fi" with "fi" and that
> seems to have worked 🙂
>
> Thanks again!
> Suzanne
>

Maybe there was more than one instance? Or maybe there are other
ligatures that you didn't replace yet, such as "fl" or "ff" or "ffi" or
...



Clay Helberg

Senior Consultant



TerraXML

1380 Forest Park Circle, Suite 100

Lafayette, CO 80027

Ooops. I lied. We stopped suppressing ligatures at some point. Brain fail.

When we did suppress it, we used this code an ACL in Editor's custom/init
folder:
$ENV["APTLIGATURESENABLED"]="no"

OR in a batch file used to start Editor like this:
set APTLIGATURESENABLED=no

We may have also set it from PE's custom folder but I can't tell for sure
anymore.



We had problems with ligatures with Arbortext 6 and Windows 7. It seemed that Arbortext 6 was still using XP font definitions. I hope the description and solution below help.

Examining the Arial [1] and Times New Roman [2] fonts shipped with Win7, we see that "Latin Small Ligature Fi" is located a code point U+FB01 and "Latin Small Ligature Fl" is located a code point U+FB02. Examining the same TTFs [3] we find these glyphs located at these standard points but also at U+F001 and U+F002 respectively, which is a private use area of the Unicode space. On the Win7 verisons of these fonts there is no glyph defined at the U+F001 and U+F002 code points.
[1] Font name: Arial, Version: Version 5.06, OpenType Layout, Digitally Signed, TrueType Outlines: arial.ttf, ariali.ttf, arialbd.ttf, arialbi.ttf
[2] Font name: Times New Roman, Version: Version 5.07, OpenType Layout, Digitally Signed, TrueType Outlines: times.ttf, timesi.ttf, timesbd.ttf, timesbi.ttf
[3] OpenType Font, Digitally Signed, TrueType Outlines, Typeface name: Arial, File size: 359 KB, Version: Version 3.00, Typeface (c) The Monotype Corporation
[4] OpenType Font, Digitally Signed, TrueType Outlines, Typeface name: Times New Roman, File size: 400 KB, Version: Version 3.00, Typeface (c) The Monotype Corporation

You can also disable ligatures in AE 5.4 in the FOSI:

<docdesc>
...
<lettersp allowligs="0">
...
</docdesc>

or in a .tmx file for the doctype:

\ligaturesenabled=0

I haven't used AE 6 yet, perhaps someone else can say whether these are still usable.

David

David S. Taylor

Project Manager, Structured Information
Production and Marketing | Building Regulations | NRC Construction
Building M-23A, Room 114 | 1200 Montreal Road | Ottawa, ON | K1A 0R6
Telephone: 613-990-2731 | Fax: 613-952-4040
David.S.Taylor@nrc-cnrc.gc.ca<">mailto:David.S.Taylor@nrc-cnrc.gc.ca>




Disabling ligatures in general was a solution we considered, but we had too many existing files that would make this impractical. We had to fix the fonts.

FYI - pltotf.exe and tftopl.exe are located in ...PTC\Arbortext Editor\bin\x86

Top Tags