cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Glitch with sub-component visibility

Garnet

Glitch with sub-component visibility

Hello All,

 

I noticed a glitch (or easily made mistake) with visibility of an assembly. Imagine you have a tool composed of parts A, B & C. The actions below are all completed within a single step of a sequence:

 

  1. Fade In tool (make visible)
  2. Unscrew portion C from the tool
  3. Fade out C
  4. Perform animation with the tool
  5. Fade out entire tool (assembly)

 

The issue with this, is that C gets faded out twice, since it is contained within the assembly -- and this confuses Creo Illustrate - so a glitch occurs. This is expressed by C appearing visible from the very beginning of the step. Sometimes I've seen this glitch expressed later in Vuforia Studio (after exporting the PVZ file) rather than Creo Illustrate.

 

This may not be a common issue: My assembly is a vacuum pump with hundreds of components and many layers of sub-assemblies. There are also multiple special tools used in overhaul, and some of these tools have attachments that must be removed or added. The workaround is to manipulate sub-assembly components, rather than the top level assemblies, but it's easy to forget or loose track.

 

Maybe someone could take a look at this scenario and fix it for Creo Illustrate 6?

Is there a "visible" switch that could be programmed to say "if visibility of child part = 0 then turning off the visibility of a parent has no effect on the child"

 

Thanks,

Wes

Tags (2)