Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

2D Detailing: Geometric Tolerances (GTOL)

Attached to this blog post is a short presentation on the new enhancements to Geometric Tolerances (GTOL) in Creo 4.0 in Drawing mode.

Any questions or feedback you have related to GTOLs should be provided as comments to the blog post.

That will be the easiest way for me to keep track of the comments and also be able to provide timely responses to your questions. If you follow this post, you can be notified of those comments as well and be able to learn from what others are asking. I may also periodically update this post to add some new details or information related to GTOLs.

Also, don't forget to follow the main blog post for 2D Detailing - which will have links to other 2D Detailing-related content 2D Detailing Home: Start Here!


Raphael‌, I am struggling to figure out how to get dual dimensions to show up in GTOLs.  Dual dimensioning is working fine for dimensions but for the life of me I can't figure out how to get them to show up correctly in the GTOL box.  This is working fine in Creo 3.  Thanks.

Creo 3.0

Creo 4.0

By the way, the model is in metric units but the drawing is set to display "Secondary [Primary]".  These settings don't appear to be impacting the GTOL tool.

I am facing the same issue, dual dimensions are working well with the exception of GTOLs, I always get the secondary value in the same unit system as the primary.


Did you solve this somehow? Thanks in advance!

When creating the GTOL, right click and hold and then try changing the destination.



You are a life saver! it worked! thank you.


I have a simular problem 🙂

I live in the metric part of the world but the company I currently work for dont think 3D/2D is anything important.

As they are a global company , we dont have any support.

Or at least any support that you can talk to.

My issue is this:

3D is in metric and the 2D is in metric but NOT the 2D-template that we use.

Measures on drawing is in mm, but the sheet is Inch.

3D measures is in mm.

But GTOL becomes in Inch. 

And looking in the Drawing properties its a mix...

ANSI and ISO here and there..

I have tried to find what propertie that controlls GTOL-units.

Anyone have a clue?

How do I get GTOL to always be ISO/metric?



Version history
Last update:
‎Jun 15, 2016 01:37 PM
Updated by:
Labels (1)