Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Your Friends List is a way to easily have access to the community members that you interact with the most! X

Link to Download Sneak Peek

No ratings

Hi everyone

Use this link to download Creo 4.0 Sneak Peek

And dont forget the license is embedded and will expire on August 5 2016



where shall the license file recived go?

Br Thomas


Have you tried running creo?  If creo runs then you will not need to do anything with the license file that was e-mailed to you



Saw a preview at LiveWorx last week. With our company going to MBD and using GD&T, I liked what I saw with the GD&T Advisor tool. Also the full screen capability and the onscreen tolls windows should make it better to use.

Downloading it now.


Jim Barrett-Smith‌, can you please clarify on who exactly is supposed to be allowed access to this?  Is this only for attendees at LiveWorx 2016?  Is it only for customers currently on maintenance?  Should the availability of this beta version be announced to the broader PTC Community?  People outside of this group are asking and I'm not sure how to respond.  From the "Read This First" document:


Sneakpeek is available to past and present customers, meaning customers do NOT have to be on active maintenance.

SP is open to all customers, they simply need to e-mail - 

thanks, Jim


Does anyone know where is the new 3D Sweep feature?




the 3D Sweep is not in Sneak Peek release. Also the mirror feature (in part) will be available in future release (I suppose they will be available with F000)


correct Dario.

Both enhancements are not stable enough yet for distribution in sneak-peek. We are working hard towards delivery in F000, but cannot fully confirm it yet.


What are the requirements for the video card? It looks like Creo 4 needs more video resources than the previous version, am I right?


I'm trying to install, but always see download error in the middle of some elements - How can I solve it?

Why button isn't active?

All my attemps to install until now finished with this:

and only finish button is active no step back no other way...

Can I somehow continue where stopped?

Please help me!




Try disabling your virus checker.

thanks, Jim

Hi Mihai

The requirements are in the Read this First document, which is posted in this forum.

Thanks, Jim

Creo 4 Sneak Peek network issue for download.JPG

I continue to get the above error when the installer is launched.

ok I finally install it 😉

Could someone indicate what features are completely new or refreshed and need to be tested?

I noticed new Real-Time Rendering Button:

and keep searching...

The best way to find out what's new in Creo 4.0 is to go to the "All Content" section and then choose the tabs of either "Blog Posts" or "Documents". Here you'll find the descriptions of the new stuff put there by the various Product Managers. You could also select a category on the left side to narrow down to a specific topic of interest.

Is there a version for Windows 32bit? The installmgr in the posted link is named 32 but it doesn't run on my machine.

Ok, I have read in the "Read me first" that it only runs on 64bit machines.

Same error here, is it possible to have an "offline installer" instead of a downloader?

So the error was caused by me selecting "run" in the Internet Explorer download dialog box. Selecting "save" and running from the saved copy works. But then if I double click on the installed Creo shortcut it doesn't run giving me this std.out:

langLoadExtTbl: File "pro_i18n.res" could not be opened.

langLoadExtTbl: File "pro_i18n.res" could not be opened.
Error loading font file font.ndx
Cannot initialize message system; index file msgtxt.ndx not found.
generate UI traceback and exit
Generating automatic traceback in C:\Users\Public\Documents\traceback.log...
generate plain traceback and exit

I know someone solved issues by disabling the antivirus, but I can't do that.

How does installing SP Creo4.0 play with existing Creo/Windchill installs?  Will they be completely separate from each other and can easily live on the same machine?  Our setup is validated to a particular configuration, so adding in something that shares or potential changes some aspect of that wouldn't work for me and i'd have to look at a network install or a separate PC.

I have PTC Creo 3.0 and PTC Creo 4.0 and everything is going well, it is completely separate.

I also have my companies production version of Creo 3.0 and WindChill 10.2 running, and had no issues installing or running the SP of Creo 4.0. The SP of Creo didnot look to connect to any install i currently had on my machine.

Hi Jim

My Creo 4 installation worked fine until today, now I get "License request failed for feature"..."Invalid host" when I try to start.

Any ideas?

The ordinate dimensions pile up one on top of the other and there isn't a way to clean them up WITHOUT MANUALLY ADDING A JOG.  Cmon people, Cadkey used to clean up its ordinate dimensions automatically... why cant we get this fixed????

I like the visual mirror though.  that will be handy

Where is this located, in the rendering?

Funny I cant find it again.......I thought it was under the view tab under the model display.  Oh  it only works with a part file.

so view/model display/visual mirror.  Alias had this function I used it all the time.

Hi Jeff, Dennis,

you can go to View-Scenes-Edit Scene - Environment and turn on Reflection.

Then use display mode Shading with Reflections.

Is that what you where after?

best regards..Martin

Martin this is function that allows you to model just one half and still see the mirror of your part.  So you don't have to keep turning on and off a mirror feature.

There isn't a feature here its just a trick with mirrors

I am also seeing the same error as Alexander when I try to launch any of the Creo products.

Alexander and Shaun

I am investigating,

thanks, Jim

If its any help: I installed the sneak peek when I was at our site in Budapest Hungary, and there I could run the software. It hasn't worked since I came back to our Stockholm Sweden site.

If the license file is generated on install, maybe it gets confused by me switching countries?

This might be because of the dual network adapter cards…

Please check the Sneak peek edition license file… i.e.  MAC address with which the license file is configured.

PTC_HOSTID=<mac address>

Please check if the network adapter MAC address matches with the MAC address in the license file

Thanks, Jim

It looks like it may have issued the license to the MAC address of our outbound internet proxy since the MAC address in the license file does not match any of the MAC addresses on my laptop.

I presume that if I remove and re-install from a direct internet connection, a new license will be issued with the correct MAC address?

Yes an uninstall and re-install should solve the issue.  I apologize for the inconvenience, and please do confirm the issue has been resolved


Problem remains: I have uninstalled, rebooted and reinstalled but still get the same error. The licenses are locked to a mac address that doesn't exist on my computer. I have no option to use a "direct internet connection" that Shaun speaks of.

Please go to C:\Programdata\PTC\Licensing and see if an old invalid license file exists. If yes, please delete and do reinstallation.

Thank you Amol, that did the trick

Hello all,

When I try to install from the "pim_installmgr_32.exe" as administrator, this error message appears :


Is it limited to 32 bits machines ?

What is the solution to this trouble ?

Thanks, regards

Hi olivier SOUDY,

The error indicates - there is no network connection and it is unable to connect to PTC server.

It's a web download and needs active internet connection during the installation.



When you download the above exe from browser, try selecting "save" and then running from the saved copy.

Hi Amol,

thanks you for your answer.

I have an active internet connection at the moment, with a network cable.

Thanks, regards

I have tried this because i have read a post above.

Hi, Can you please check firewall and antivirus settings. Something is stopping to connect to PTC server.

ok I will check this with our IT departement.

nice to see:

1. they fixed the perspective

2. Import image is nice.

3. I like the new way to pull up dimension properties

Why cant I shade with edges and have reflections and bump maps???


Now it's working fine.



Great to hear. Can you please confirm what has resolved the issue exactly? Antivirus/Firewall?



Hi Amol,

it was very strange. I work in differents locations in the company. In one of them I have not had this connection problem.



Version history
Last update:
‎Jun 08, 2016 01:57 PM
Updated by:
Tags (1)