cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Determining the Visibility of a ProDtlNote (blanked layer/layer state)

Marble

Determining the Visibility of a ProDtlNote (blanked layer/layer state)

Working strictly with Sheet metal drawings, I want to grab all of the drawing notes on the drawing and categorize potential mfg processes involved.  Bend radii, special Die information etc.  These all exist as note in the drawing.   Pretty simple to do if the part is static.  Our Creo operates as configure to order.  The parts are highly configurable and have many wall features, forms,  (some operation model as cosmetic, note is only indicator) coming and going using pro/program.   The drawings are programmed using layer states.   Basically the engineer configures the model to a configuration, details the drawing, puts these detail items on a layer by creating a "state", then a simple drawing program is written to turn on states for certain configurations.  This auto-cleans up the drawings.   assemblies are configured and the parts all configure top down using pro-program.  Parts are dynamic in dimension, so infinite are the possible configurations.  At the assembly level,  My program traverses the parts, open the drawings, and export them.  This is the point where i also want to dump the note data in order to make MFG routing decisions.

THE ISSUE:   ProDtlNoteDataIsDisplayed does not seem to consider layer status, and can falsely report visible, when the note is on a blanked layer.  When layers are blanked, the detail items' visibililty status still shows as visible.    Also when layers are blanked via LayerState control, using

ProLayerDisplaystatusGet  Layers report that they are visible, despite being set to blank in the layer tree.  

 

 I have tried:  ProDtlNoteDataIsDisplayed 

isit all layers,  collecting all layer items,  identifying the notes, and using

ProLayeritemStatusGet to check visibity.  Results not reliable, when layers are blank, the function still returns True that it is visible.

My last chance:  I am attempting to use ProLayerstateModelItemIsHidden.  Get all states, Check all modelItems on state, the check if hidden)

 

Anyone have any experience dealing with ProDtlNotes on layers and deciding what is visible and what is not? 

even bette, dealing with the visibility of th edtlItems on Layer States? 

 

 

  ProLayerItemStatusGet

4 REPLIES 4

Re: Determining the Visibility of a ProDtlNote (blanked layer/layer state)

It appears some of my post was chopped out during the POSTing

 

I have tried: ProDtlNoteDataIsDisplayed - does not seem to consider layer status.

 

I have:  Visit each layer, Check the layer visibility using ProLayerDisplayStatusGet, get the notes on that layer,  then if not visible, store thos notes in array.   Layer visibility seems to be confused by Layer States.

 

I have:  Visited all layers, collect all the layeritems, run thru and check the ProDtlNotes,  use ProLayerItemStatusGet to check visibily.  Results seem confused by layers states or visibily of Layer.

 

 

 

Re: Determining the Visibility of a ProDtlNote (blanked layer/layer state)

for layer states one should use ProLayerstatesGet(...) followed by ProLayerstateLayersGet(...) to get layer visibilities per each layer state. visiting layers with ProLayerDisplayStatusGet(..) would only get layer statuses for the active layer state (if any)...

 

Re: Determining the Visibility of a ProDtlNote (blanked layer/layer state)

ave you used this before?  I looked into this and the documentation seemed to be pointed exclusively at Assembly.

  Here is what the TK documentation says:  Layer State:   A layer state stores the display state of existing layers and all the hidden layers of the top-level assembly. You can create and save one or more layer states and switch between them to change the assembly display. 

 

Thanks,  I will look into this and see if my drawing level layerstates report.

Re: Determining the Visibility of a ProDtlNote (blanked layer/layer state)

tt.png

seems to be working fine in part mode... had not seen any problems with those functions since Creo 2.0

Announcements