cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Enable Simscape Multibody Link Creo-Pro/E Plug-In

sreck
Newbie

Enable Simscape Multibody Link Creo-Pro/E Plug-In

I want to enable the Simscape Multibody Link Creo-Pro/E Plug-In to transfer my 3D modell to simscape. I followed the steps at this link: http://de.mathworks.com/help/physmod/smlink/ug/installing-and-linking-simmechanics-link-software.htm...

and then this steps: http://de.mathworks.com/help/physmod/smlink/ref/linking-and-unlinking-simmechanics-link-software-wit...

I generated a new .pro and a new .dat file.

.dat:

name Simscape Multibody Link

startup dll

exec_file matlabroot\bin\win64\cl_proe2sm.dll

text_dir matlabroot\toolbox\physmod\smlink\cad_systems\proe\text

unicode_encoding false                                                                                                    'got the message without this line too'

end

When i start creo parametric as admin i get this message(my translation):

Creo Toolkit starting mistake

Creo Toolkit registry file C:\Temp\Creo\myprotk.dat:

application 'Simscape Multibody Link'couldn't be started; you can find details in the trail file.

after that i get a second message:

failed to start application 'Simscape Multibody Link'

Text of the trail file:

!trail file version No. 1600

!Creo  TM 2.0  (c) 2016 by PTC Inc.  All Rights Reserved.

!Exit Logger data:

!              Process ID: 3328

!              Application: Creo_Parametric

!              Start date&time: 2016/09/13  17:38:11

!              language: german

!              machine type: x86e_win64

!              datecode: M110

!              Server: NONE

!              Workspace: NONE

!              traceback file: C:\Program Files\PTC\Creo 2.0\Parametric\bin\traceback.log

!end Exit Logger data.

< 0 0.848593 1220 0 0 716 1366 0 0 768 13

!mem_use INCREASE Blocks 455047, AppSize 51258409, SysSize 61240360

< 0 0.634074 1004 0 0 535 1366 0 0 768 13

< 0 0.634074 904 0 0 535 1366 0 0 768 13

!%CIWillkommen bei Creo Parametric Academic Edition 2.0.

! Message Dialog: Warning

!               : Creo Toolkit Registrierungsdatei C:\Temp\Creo\myprotk.dat:

!               :  Anwendung 'Simscape Multibody Link' konnte nicht gestartet werden; Details finden Sie in der Traildatei.

< 0 0.630519 904 0 0 532 1366 0 0 768 13

~ FocusIn `UI Message Dialog` `ok`

~ Move `UI Message Dialog` `UI Message Dialog` 2 10.112125 10.732725

~ Activate `UI Message Dialog` `ok`

! Message Dialog: Warning

!               : Starten von Applikation 'Simscape Multibody Link' fehlgeschlagen.

~ Activate `UI Message Dialog` `UI Message Dialog`

~ FocusIn `UI Message Dialog` `ok`

~ Activate `UI Message Dialog` `UI Message Dialog`

~ Activate `UI Message Dialog` `ok`

~ Minimize `main_dlg_cur` `main_dlg_cur`

Matlab version: R2016a

Creo Parametric 2.0

I hope you can help me.

1 REPLY 1

Re: Enable Simscape Multibody Link Creo-Pro/E Plug-In

Hello Stefan,

As I was responding to your post and inadvertently I fixed my issue while doing so. So, I am going to elaborate on what I did to fix my issue and maybe you will fix yours while doing so. First off, the error message I was receiving was as follows:

Creo Toolkit registry file C:\Program Files\PTC\Creo 3.0\F000\Common Files\text\protk: cannot spawn application 'Simscape Multibody Link'; read error 'No such file or directory'


My problem was a bad path in my "exec_file" path. I missed a backslash in the path and therefore, CREO didn't know where to look to find the "cl_proe2sm.dll".

YOUR PROBLEM:

Assuming you have already completed following the directions to install Simscape Multibody Link, http://www.mathworks.com/help/physmod/smlink/ug/installing-and-linking-simmechanics-link-software.ht..., you now have to enable Simscape Multibody Link. This is described in detail here: http://www.mathworks.com/help/physmod/smlink/ref/linking-and-unlinking-simmechanics-link-software-wi.... After looking at what you put in your protk.dat file, I think I notice a couple things that might get you working.

name Simscape Multibody Link                                                                (This is good)

startup dll                                                                                                      (This is good)

exec_file matlabroot\bin\win64\cl_proe2sm.dll                                            (This is incorrect, see item 1 below)

text_dir matlabroot\toolbox\physmod\smlink\cad_systems\proe\text          (This is also incorrect see item 2 below)

unicode_encoding false                                                                                (This is good)

end

  1. Assuming you installed Simscape correctly from above, you need to change the "exec_file" path to point to where the "cl_proe2sm.dll" file is located. I am running Windows 10 64-bit so my exec_file path was as follows: C:\Program Files\MATLAB\MATLAB Production Server\R2015a\bin\win64  (If you are not sure where the "cl_proe2sm.dll" file is located just search for it under the MATLAB folder in your Program Files folder) (Once you find where the file is located, copy this path from the Windows Explorer Address bar and paste it in-place of the old path)
  2. Again assuming you installed Simscape correctly from above, you need to change the "text_dir" path to point to where it says on the website. When it says, "matlabroot" it doesn't mean literally put that in your path, it means starting from the matlab root folder, find toolbox\physmod\smlink\cad_systems\proe\text. "matlabroot" is a reference to where you installed matlab. My text_dir path was as follows: C:\Program Files\MATLAB\MATLAB Production Server\R2015a\toolbox\physmod\smlink\cad_systems\proe\text



Also, I noticed that you modified your config.pro file to point to where the protk.dat file was, which I believe you fabricated yourself. Make the above changes first, and if it works, you do not need to change anything. However, there should already be a protk.dat file that was created by CREO by default. To find its location, (1) open creo, (2) click "File", (3) Select "Help", (4) Select "System Information", (5) Scroll down till you see "Configuration files read:" and you should see where CREO is referencing the default protk.dat file. (Mine was: C:\Program Files\PTC\Creo 3.0\F000\Common Files\text\protk.dat)

Once you have verified all of your paths are correct and followed all of the directions correctly, you should be up and going. Let me know if it works. Good Luck Stefan!

-Chris

~'`;.,/`': Chris :'`\,.;`'~>
Announcements