cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Visit the PTCooler (the community lounge) to get to know your fellow community members and check out some of Dale's Friday Humor posts! X

SmartELECTRODE drawing template setup.

MarcoP
4-Participant

SmartELECTRODE drawing template setup.

Hello.

Im trying to set up the drawing templates for SmartELECTRODE, but I've got some difficulties I hope someone can help me with. The problem is when trying to add EDM positions to the drawing, using a custom (repeat region) table, it will add positions of ALL electrodes, where I only want to add the positions of the electrode on the current drawing (I've chosen option "One sheet per model"). My template looks like this: 

TemplateTemplate

And this is the result:

ResultResult

And its funny because if I add my custom table (which I've saved as a .tbl file) after the drawing is the created by SmartELECTRODE, this is what I get:

Table added manually (correct)Table added manually (correct)

Another "weird" thing, there's probably a reason, is that when using the table from the original drawing template (see picture), 

Table template in ASM_EDM standard drawingTable template in ASM_EDM standard drawing

the correct values will be added to the table. (see picture)

Result using standard drawing table.Result using standard drawing table.

Also when this is fixed (if it possible) I'd like to merge the "ASM_EDM" drawing with the "EDM_DEFAULT" drawing, but then the table will not transfer. This is the result:

Merge, no tableMerge, no table

I'm trying to recreate some drawings my colleague brought from his old work, so I'd say this is definetly possible. Though, I've never seen these drawings being created, so if everything was created automatic, I can't tell for sure, but I've been told there were no manual work to do when creating these drawings.

 

EDIT: Also noticed my dimension relations are missing, unless I use the standard table template (picture 4 and 5) But I guess that could be because SmartELECTRODE never finishes making the drawings, when using a custom table.

 

If you need any other information, feel free to ask.


I will appreciate any help, thanks in advance


Kind Regards

Marco

1 ACCEPTED SOLUTION

Accepted Solutions
MarcoP
4-Participant
(To:MarcoP)

Hi, I found the solution.

To add a custom table to your drawing, you must have the "standard table" in your drawing template. By "standard table" I mean the table that can be seen on picture 4.

 

So, if you are working on template drawing "asm_operation", the text in the top left corner of the table should say "asm_operation". This will load the table defined in /templates/asm_operation.tbl

 

I tried defining my own custom table already, but it didn't work, the table shown on picture 5 was always inserted.

But what I did wrong was having option "USE_ORIGINAL_TABLE" set to "No - The burnsheet table on drawing sheets is created by the software."

This should be set to "Yes - The burnsheet table on drawing sheets remain unchanged."

View solution in original post

1 REPLY 1
MarcoP
4-Participant
(To:MarcoP)

Hi, I found the solution.

To add a custom table to your drawing, you must have the "standard table" in your drawing template. By "standard table" I mean the table that can be seen on picture 4.

 

So, if you are working on template drawing "asm_operation", the text in the top left corner of the table should say "asm_operation". This will load the table defined in /templates/asm_operation.tbl

 

I tried defining my own custom table already, but it didn't work, the table shown on picture 5 was always inserted.

But what I did wrong was having option "USE_ORIGINAL_TABLE" set to "No - The burnsheet table on drawing sheets is created by the software."

This should be set to "Yes - The burnsheet table on drawing sheets remain unchanged."

Top Tags