Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to Learn more.

7.4 ThingWorx does not launch due to license error in Windows

No ratings

Please open your ApplicationLog located in ThingworxStorage/logs and inspect for errors. Something like the following might be observed:


2017-03-31 16:29:19.591+0300 [L: ERROR] [O: ] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] C:\WINDOWS\Sun\Java\bin is listed as a java.library.path but it does not exist

2017-04-12 13:51:53.515+0200 [L: ERROR] [O: c.t.s.s.l.LicensingSubsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Failed to load FlxCore library. Ensure it's in PATH (Windows) or LD_LIBRARY_PATH(other platforms) or set with the VM arg, -Djava.library.path. Error message : com.flexnet.licensing.DllEntryPoint.entry([B)

Typically, if the license file has been downloaded and placed correcrtly, according to the 7.4 installation guide, the error in the log will specify where the file was found. If the license path was specified per the installation guide in the tomcat java path, you may try to clear it from the Tomcat java settings and keep these parameters:

-Dserver -Dd64




And then set up the license path in the environment variable path:

  • Go to explorer, right click on "my computer" -> Properties -> Advanced settings -> Environment variables -> edit "PATH", add ; and then path to your tomcat extensions folder, “ ;<path to extensions folder of tomcat> “ or, for example ";C:\ptc\Thingworx\webapps\Thingworx\WEB-INF\extensions"

Quick add to say that for Linux you can use the following option as a java option when starting your Tomcat


Or perhaps like this...


Be aware, Thingworx 8 does the same and RHEL install guide is missing -Djava.library.path=$CATALINA_HOME/webapps/Thingworx/WEB-INF/extensions in SYSTEMD file.

For both sections, we do have the Djava.library path:

Open /usr/lib/systemd/system/tomcat.service

Note that systemd is a folder not a file.

My bad, I can see it now, it caused me lot of headache when upgrading and not checking systemd unit properly. 😃 In windows section, it is clear to just add something, in RHEL it is done by replace all thus easy to overlook...

Thank you for your feedback, I'll pass this to the doc team

Version history
Last update:
‎Apr 12, 2017 10:44 AM
Updated by:
Labels (2)