Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to Learn more.

Troubleshooting Steps for ThingWorx Analytics – Getting Started

No ratings

ThingWorx Analytics is capable of being assembled in multiple Operating Systems. In this post, we will discuss common issues that have been encountered by other users.

Permissions Denied – Read/Write access to Third Party Components

This is encountered when executing the desired Shell script to begin the creation process. In MacOS and Linux you may encounter a “Permissions Denied” error on the two required components in the creation, the packer-post-processor-vhd and packer components.

Error Message

This will result in a Terminal dialog message that will read “Process Completed, No Artifacts Created”. This indicates that the Packer Script has failed to complete the task, and the desired appliance images were not created.

To correct this issue, you will have to change the permissions of the packer-post-processor-vhd and packer components to be able to be read and executable by the user account that is attempting to create the appliance.


Run the following commands in the Virtual Machine terminal (you may need to run as SUDO or as Root):

  • chmod +x packer-post-processor-vhd
  • ​chmod +x packer

After running the above command, run the Shell script of the desired VM Appliance output. This should resolve the issue with “Permission Denied” while executing the build scripts.

Error Starting Appliance in VirtualBox

Users have experienced this issue at the first run of the Appliance, right after it has been assembled. This issue is unique to VirtualBox versions 5.0 and above.

Error Message – Dialog Box

If you encounter the error depicted below, please check under settings for the imported OVA for any errors:


This issue is the result of invalid settings in the Appliance Configuration. You will need to check for Invalid Settings, by navigating to the Settings Menu for the Appliance:


The “Invalid settings detected” indicates that when the Product was assembled, some configuration settings were not applied correctly by the creation tool scripts.


Hover your mouse over the settings and it will direct you to cause, in this case it is due to remote monitor setup. Just change the settings in Display (Remote Display Tab) by unchecking the Enable Server button.


Press OK after unchecking the “Enable Server” option, and start the Appliance.


I am seeing the following error, right at the end of creating the VM. The installation guide talks about running the script twice but I have now tested it four times in a row and get the same issue. Did anyone else see this?

==> virtualbox-iso: Unregistering and deleting virtual machine...

==> virtualbox-iso: Running post-processor: vhd

Build 'virtualbox-iso' errored: 1 error(s) occurred:

* Post-processor failed: connection is shut down

==> Some builds didn't complete successfully and had errors:

--> virtualbox-iso: 1 error(s) occurred:

* Post-processor failed: connection is shut down

==> Builds finished but no artifacts were created.

One idea would be to remove the post processor from the script and run it separately - any ideas on how to do this would be very welcome!


Thank you for posting your question.

Can you confirmed if you are hardwire (Ethernet cable) connected to the internet during the creation stage of the Packer Script process?

Also, can you provide what version of Virtual Box you are running?

Please note that the post processor is required for the packer script to complete the assembly of the Appliance. Unfortunately there is no way to remove it from the script and have a completed Appliance as there are checks built in that would require considerable changes to run it separately.



Hi Neel

I can confirm that I was connected all the time with cable and stable Internet connection.

I tried with Virtualbox version 5.1.14 r112924 (Qt5.6.2)

I am using a Mac with the latest OS installed

Thingworx Analytics 52.2

As a workaround I tried installing VMWare Fusion and now I got the machine up - but a new problem came up...

As a response from the API when I try to create a dataset (both using the web interface and Postman) I get this error message. The REST interface is working, I tried with the "versioninfo" request and got a valid response.

{ "errorId": "db55846e-7ab8-47a8-be0d-65c8b19b4476", "errorMessage": "Could not open JPA EntityManager for transaction; nested exception is javax.persistence.PersistenceException: org.hibernate.exception.JDBCConnectionException: Could not open connection" }

Hi Erik

This latest error is because postgres did not get installed .

You can find details on this issue and the workaround at

Note when you get errors it is a good practice to first search in the PTC Knowledge Base as you will very often find articles that cover the issue.

Also should you want to investigate the initial issue with VirtualBox, it probably will be useful to send a full installation log file, see if one did not get created.



Hi Christophe,

Excellent - thanks for the quick reply. Are you able to send me the document in the link - it is not available to partners and customers yet.

best regards Erik

Hi Erik

Apologies I overlooked the status of the document.

It is now public so you should be able to access it ... let me know if that is not the case.



Hi Christophe,

The link works now and I was able to create a new VM.

However ...

There is a new error message when I try to create a dataset. There is topic in the knowledge base about this but no answer .


"errorId": "15ce7cfe-9420-4fbe-a7b0-8f14c5d05057", "errorMessage": "No application found for id mytestid" }


This looks like you entered mytestid for application id, the only one that exist by default is neuronuser.

Could try neuronuser for application id and see how it goes ?



Version history
Last update:
‎Sep 29, 2016 12:25 PM
Updated by:
Labels (2)