cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

HEAD missing from ncl file in Creo 4

SOLVED
Highlighted
Alexandrite

HEAD missing from ncl file in Creo 4

I was utilizing the HEAD word to pull up a macro in IMSpost to output probing strings and variable prompts. It is no longer being output in the ncl for Creo Parametric 4.0. Any ideas how to force this back out?

Creo 2.0

PPRINT /                                                 
PPRINT / OPERATION CSYS NAME : MACH_CSYS
HEAD / 1
PPRINT / NC SEQUENCE NAME : B270_6IN_TANG_G56

 

Creo 4.0

PPRINT /     26        T0026      1      4-750_OD_BORING_HEAD
PPRINT / OPERATION CSYS NAME : NC_ASM_DEF_CSYS
PPRINT / NC SEQUENCE NAME : B270_3IN_F-MILL_G57

1 ACCEPTED SOLUTION

Accepted Solutions

Re: HEAD missing from ncl file in Creo 4

I tried a few things, but the best way to get cl data out as I did with Creo Parametric 2.0 was to create HEAD.ncl, and put HEAD / 1 in the file. Then I call it up in PRE_MACHINING_FILE in the 1st nc sequence to get the ncl file the same as before.

View solution in original post

8 REPLIES 8

Re: HEAD missing from ncl file in Creo 4

To be sure it is a post error, use the same file that you did in Creo 2 and repost it in Creo4. This will eliminate changes in the manufacturing operation steps.

 

Re: HEAD missing from ncl file in Creo 4

Did that. Used an older cl file also. We just went to Creo Parametric 4 April-2. Someone else flagged me about the probing not coming out. It is under a macro named HEAD /.

Re: HEAD missing from ncl file in Creo 4

I tried a few things, but the best way to get cl data out as I did with Creo Parametric 2.0 was to create HEAD.ncl, and put HEAD / 1 in the file. Then I call it up in PRE_MACHINING_FILE in the 1st nc sequence to get the ncl file the same as before.

View solution in original post

Re: HEAD missing from ncl file in Creo 4

Did you check your PPrint table if HEAD_NO option is set to yes.

pprint_table.png

Re: HEAD missing from ncl file in Creo 4

When I use PRE_MACHINING_FILE as HEAD.ncl with HEAD / 1, I get:

$$-> BLOCK_START /
HEAD / 1
$$-> BLOCK_END /

 

and if I use HEAD_NUMBER added to Parameters under PARAMETER_UI I get:

$$-> BLOCK_START /
HEAD / 1
$$-> BLOCK_END /

 

but when I change HEAD_NO to Yes in the PPRINT, I get :

PPRINT / HEAD_NO : N/A

 

I need the CL word to trigger a macro in my post.

 

Thanks for helping to look for a resolution.

Re: HEAD missing from ncl file in Creo 4

I suspect that your work center type is set to "Milling"

To get head number display correctly the work center type need to be "Mill/Turn" or "Lathe"

Re: HEAD missing from ncl file in Creo 4

In Creo 2 it was putting it in the ncl when set to Milling. What changed in Creo 4?

Re: HEAD missing from ncl file in Creo 4

I can't make the HEAD_NO work the way you described. I've tried both Creo 2 and Creo 3 and all I'm getting is the

PPRINT / HEAD_NO : N/A

It looks to be some configuration or maybe site and/or parameter file that are different but, unfortunately, I don't know what to look for.

Announcements