cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you get called away in the middle of writing a post? Don't worry you can find your unfinished post later in the Drafts section of your profile page. X

Autosave error Matcad 15

kamaotori
3-Visitor

Autosave error Matcad 15

Hello,

 

One of my users is facing an autosave issue in Mathcad 15.

Every 10 minutes (as the autosave was set) there's an error prompt with the path only and it's not saying what's wrong with it.

User got all the permissions in the mentioned folder.

I've tried to change the "default worksheet location" in the Tools>Preferences, but i guess it's not where autosave files get saved as the error appeared with the same path as before.

 

I've seen the registry below in another topic, but it's not the path for autosave files.

[HKEY_CURRENT_USER\Software\MathSoft\Mathcad 14\McadFiles]
"LocalWorkingDirectory"="C:\\Program Files (x86)\\Mathsoft\\Mathcad 15\\"

 

What can be the issue? Any ideas how to fix the issue? Or how to change that Autosave directory?

[error in the attachment]

8 REPLIES 8

Hi,

please read information available on https://community.ptc.com/t5/PTC-Mathcad/Autosave-on-15-not-working/m-p/69542#M27396 page. Maybe it helps to solve your problem.


Martin Hanák

My bet was on the such long pathname, but then how can I change the path for the autosave files or somehow change the default name of these autosaves files, so they aren't so long.

 

I've tried to change the "default worksheet location" in the Tools>Preferences - but the error shows the same old path (so maybe it's not the autosave directory)

Then i've checked this registry as it was mentioned somewhere as a path for autosave, but it's totally different.

[HKEY_CURRENT_USER\Software\MathSoft\Mathcad 14\McadFiles]
"LocalWorkingDirectory"="C:\\Program Files (x86)\\Mathsoft\\Mathcad 15\\"

Hi,

please ask PTC Support.


Martin Hanák

Thanks for all your replies.

 

I'm just a remote IT support, therefore I only have this basic support account.

There's an article about my user's issue, but it's not accesible with this type of account.

https://www.ptc.com/en/support/article?n=CS256784&language=en&posno=2&q=autosave&source=search

"Article - CS256784 - Autosave fails with a lengthy error when worksheet has long name and/or stored in too deep location in Mathcad 15"

 

Guess i have to go through every key in the registry hoping to find the one that is responsible for the path.

 

No solution provided in CS256784, see attachment.


Martin Hanák

Thanks for your quick responses.

Seems like I am on my own now .

-MFra-
21-Topaz II
(To:kamaotori)

Hi,

The fact that you use the autosave does not exclude the possibility of losing the file due to any accident that may happen every so often. For this reason, in addition to the autosave it is good to save the file daily with a different name, for example, adding the date to the name. With today's hard drive capabilities, adding a new file every day doesn't create any problems.

Werner_E
24-Ruby V
(To:-MFra-)


@-MFra- wrote:

The fact that you use the autosave does not exclude the possibility of losing the file due to any accident

Fully agreed on - the need for making backups is unquestioned.

But the autosave feature of Mathcad is a very convenient way to add security between two backups

What kamaotori is reporting here is that one of his users is not able to use Mathcads autosave feature at all and always gets an error message.

 

In the past there were reports of crashes which could be cured by deleting the content of the autosave directory from time to time.

The autosave directory should be here:

c:\Users\username\AppData\Roaming\Mathsoft\Mathcad\14\Autosave\

 

I know of no way to change the location of this autosave directory. The path cannot be found in the registry. So if there is a registry key you have to create which overrides the probably hard coded path for the autosave dir, its undocumented and unknown to me.

One way to shorten the path of the autosave filenames which comes to my mind is using the command "subst" to turn a directory with a long path into a virtual drive and use this drive for storing the workfiles.

 

 

Top Tags