Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Mathcad 14 M020 Animation ,Play Animation window blank though cursor moves , only one Player in Options work..Reinstalled Mcad -problems still there


Mathcad 14 M020 Animation ,Play Animation window blank though cursor moves , only one Player in Options work..Reinstalled Mcad -problems still there

Mathcad 14  M020 Animation ,

Play Animation window blank though cursor moves ,

only one Player in Options work..Reinstalled Mcad -problems still there

They come up with error initialization video stream

Have used some of these Video Players before  successfully



What do you mean by "player in options"? Yous you mean the codecs which are offered in the options of the "Record Animation" window.

Whats wrong with using the one codec which works OK? Guess its "Microsoft Video 1".

Most codecs offered here installed codecs which can decode, but not encode and so can't be used for the creation of an animation and result in the error message "Error initializing video stream" if you chose them.

BTW, you get the very same error message if you forget to fence the area to be shown in the animation in your Mathcad sheet before you press "animate".



Thanks for the reply

Sorry made a mistake, --it was the Replay Window that appeared blank after the initial animation

You are right, only Codec  Microsoft RLE  worked, When Replay Window trouble began I tried other

codecs hoping to find a codec that would  display  on Replay Window (Screen -3) See below

Anmation -1  .png

1)  As you mentioned this time I tried both (A) highlighting the Frame Expression --> Animate button

     and (B)  highlighting the plotted graph- f(x) vs x (Fig ~1) --> Animate button

     a dotted box appear around them

2) Both methods gave the same results as follows

3) Usually, when it used to work, after pressing Animate button there was display on (Record Animation)

     Screen -1, now nothing

    and for method (B) after pressing Animate button, it showed animation display on Screen 2

4) Now no animation display on either Screen 1 or 2, some flicker  takes place

5) After FRAME = 216 ( the end) is displayed below Screen -1

    the Replay Screen -3 appears on Left Top Corner PC screen

6) When I clicked on the Right arrow in Screen -3 , the cursor begins to move but no replay DISPLAY

Just now I tried a REPAIR  Mathcad14 -M020.exe - it was of no avail.

Wonder what has gone wrong!!

So there is no error message but Mathcad simply does not create any animation, right?

Sorry, but I have no idea what the reason for this could be and probably I would had suggested a repair or re-installation.

Not sure if re-registering the dlls would do any good.


I'll try anything.  Please let me know how to re-register the dlll


You use the Program Regtool.exe in your Mathcad installation folder. Its purpose ist to re-register all of Mathcad's DLL's and this procedure was known to fix quite some problems. But I am just poking around and have no idea, if it could help in your case, but I guess it should not do any harm either.

EDIT: Not sure, but I think in MC14 the prgram is called mcregister.exe, not regtool.exe


Did a search for Regtool.exe   under  C:\Program Files (x86)\Mathcad\CD_English\Mathcad\program files\Mathcad\Mathcad 14

file not found

Thought it got some how omitted during recent Re- install M020

So I again re-installed Mathcad14_M020 which comes under Title CD English(zipped files)

PTC cmnty - 2          .png

Did a wild card search (*.*.exe )  in the Folder CD English Could NOT find Regtool.exe in the list

Any idea of the un-nested folder name that contains  regtool.exe   ??


You need to search for "mcregister.exe" in "C:\Program Files\Mathcad\Mathcad 14" path.

mcregister.exe   not found  in C:\Program Files\Mathcad\Mathcad 14

Have done all what I could find on line

Unfortunately I don't have any Mathcad 14 installed anywhere so I can't check if there should be one of the aforementioned files. I can only conform that in my MC15 installation folder there is a McRegister.exe.

There also is an mcmreg.exe and I guess you will find that, too. But I think that this file is only good for registering the various components (*.mcm) and has nothing to do with animations.

In fact I have no idea if mcregister.exe would have been of any help, either.

So I'm sorry to say that I am out of ideas concerning your problem.

Guess you are not under maintenance and so not entitled to call PTC support.

Can you update your version to Mathcad 14 M035 service release (latest for MC14 version):

Clicked on your url ---> Access Denied - Insufficient Privileges

Is there a fee  for upgrading from M020 to M035?

1. Contact with your VAR: Reseller Partners - PTC

2. You can also purchase a license for Mathcad Prime 3.1 and then use this license file for the latest service release of Mathcad 15 M045.

Clicked on your url and signed in ---> Access Denied - Insufficient Privileges

Is there a fee  for upgrading from M020 to M035?

What Windows OS are you using? Note that the system requirements for Mathcad 14 are as follows:


Here you can find a "Release Notes" for Mathcad 14: Release Notes for Mathcad 14

  1. MDAC 2.8 not found in my windows 8.1. So I  Installed it ---> still  the same animation glitch
  2. Also  located mcmreg.exe,   clicked on it to see what happens
  3. See pasted message  below

Gave a another try to repair M020 -- This time  it came up  with error., Attempted several times to Repair

same error  repeated  as shown below

How does one  attach a file  from a directory on this reply page? - like you have done  (Pic_ 1.png)  , I do not see the option on the  tool bar

Is there a way to find that all dll files are INSTALLED ?

Thanks for all your  efforts to help me out in the Animation problem

1. Install it first "Microsoft Visual C++ 2005 SP1 Redistributable Package" which can be found here:

2. Install Mathcad by using "Mathcad 14.0 M020.msi" "silent" installer. If errors appear, then just kept hitting "Ignore"/"Ok" until the installation completed. Opened up "Programs" in "Control Panel" clicked on "Mathcad" and select "Repair".


3. For uploading a files use "Use advanced editor" option and then click on "Attach" in the lower right corner:



4. You still did not specify your OS. Also check the following discussion: Installing Mathcad 14.0 M020 with Add-On Collection on 64-bit Windows 7

You've gotten a lot of assistance with figuring out what was wrong, but I haven't seen any "try this" stuff.

Attached are two files:

  1. A Mathcad (version 15) file that creates an animation, and
  2. The animation it creates.

Your Mathcad should be able to play the animation (.avi)  If it can't then you've got a problem, and I'm sorry.

If it can, then you should be able to open the .mcdx file (14 and 15 can share files.)

There are simple steps to creating an animation, but I have to remember them (by trial and error) every time.

Good luck!!

AnimateFx.xmcd.zp   would not animate after selection & Tools--> Animate ---> Record

Nothing happens  and no errors show up-  selected  Microsoft RLE  from options (that's all that used to work)

Viewed your other file fx animation.avi   on Media player -- the exponential  plot

I think some dll files do not get installed with PTC  CD English for Single  License install for Mathcad 14

Is there a check to see that all dll  files are installed?? if missing dll detected , then it could be installed

Correcit me if  I am wrong-   certain dll files are necessary for codecs in Animation ??