cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Have a PTC product question you need answered fast? Chances are someone has asked it before. Learn about the community search. X

Permissions for Asset Detail Menu

bmellish
5-Regular Member

Permissions for Asset Detail Menu

When using Asset Advisor, drilling into an asset and viewing the Asset Detail page, my regular (Maintenance Engineer) users get the following error:

Not authorized for ServiceInvoke on GetEffectiveMenu in 3DS.PTC.SCA.SCO.AssetMonitor.AssetDetail.ActionMenu]

The administrators do not have this problem.  Are special permissions required for the Action Menu?  There is also a service PTC.SCA.SCO.AssetMonitor.AssetDetail.AssetDetailServiceController

Which fails when you call GetMenu with the following error:

Unable to Invoke Service GetMenu on PTC.SCA.SCO.AssetMonitor.AssetDetail.AssetDetailServiceController : null]

I verified that the service is getting the correct input arguments, but there is some deeper permission issue here.

1 ACCEPTED SOLUTION

Accepted Solutions
bmellish
5-Regular Member
(To:slangley)

This problem was cause by a "ghost" thing.  I ran a delete on a few assets that were generating error messages when I hit the page, but did not exist.  Somehow asset advisor holds on to a reference to things that were removed via the platform.

View solution in original post

4 REPLIES 4
slangley
23-Emerald II
(To:bmellish)

Hi Ben.

 

For the first concern around the Asset Details page, we are going to create a case and will then need to schedule a WebEx so we can get a better understanding of the issue.

 

In regard to the 2nd issue, it appears that no inputs are being passed to the GetMenu service, since it's returning a null, though you indicated you had validated the inputs that are being passed.  Is this working for Administrators or is everyone experiencing this issue?  What user is calling the Service?

 

Regards.

 

--Sharon

bmellish
5-Regular Member
(To:slangley)

This problem was cause by a "ghost" thing.  I ran a delete on a few assets that were generating error messages when I hit the page, but did not exist.  Somehow asset advisor holds on to a reference to things that were removed via the platform.

slangley
23-Emerald II
(To:bmellish)

Ben.

 

This tool may be helpful for removing "ghost" objects:  https://marketplace.thingworx.com/tools/ghost-entities-cleaner

 

--Sharon

slangley
23-Emerald II
(To:slangley)

Hi Ben.

 

Since you found the cause of your issue, would you mind marking it with  "Accept as Solution" for the benefit of others who may have the same question.
 
Regards.

--Sharon

Top Tags