Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Visit the PTCooler (the community lounge) to get to know your fellow community members and check out some of Dale's Friday Humor posts! X

Creo 2.0 Installation problem


Creo 2.0 Installation problem


I am having problems installing Creo 2.0 Student Edition.

The Installation Assistant starts up and goes through the first few steps.

But it will not allow me to enter the product code in "Simple Licence Entry".

I am running Windows 7.

Does anybody have any ideas on what is preventing this.


Note that you must have adminstative privalges on your computer to install Creo. Right-click on the setup.exe file and select "Run as administrator".

I have tried this already but it is still not working.

Any other suggestions?


I've had a few users complain about this - you're certainly not alone. It also happens on XP. One fix seems to be to copy the installation image to the local drive. For example copy the contents of the installation DVD to a folder on the C:\ drive.

Not ideal I know but it seems to work.

Another problem can be the windows firewall / an other security / virus software. Try disabling this during installation so it can talk to without problems.



Good point James. Please temporarily turn off any virus protection and fiewall and then run the executable as administrator.

I am having a similar issue with Creo 2.0 on some of our machines. The installation runs fine but upon first launch the splash screen comes up and Creo hangs. I can disable our Symantec Endpoint Protection and on some machines it will launch and finish installation just fine, then re-enable Symantec Endpoint and Creo works perfect but on other machines it continues to hang even with Symantec disabled. Does anyone know what Symantec Endpoint would be blocking so that our IT department could write an exception to allow the installation?

Hi Tristan,

I had a similar problem with some installs recently. The basic issue is on first launch Creo checks what is installed and attempts to install up to three packages - Product View Express, Thumbnail Viewer and the Creo Agent/Platform 9. It was the platform that caused big issues when I was installing.

I looked around to find out what the Agent/Platform did and I think it's related to the "learning connector". In the end just removed the installer creoagent_32_64.msi so it couldn't run. Adam will probably be able to tell us what we're missing not having it installed!

If you've installed in a defaultish location you can find the installer packages at;

C:\Program Files\PTC\Creo 2.0\Common Files\M010\install\addon

Hope this helps!