cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - You can Bookmark boards, posts or articles that you'd like to access again easily! X

Creo 3.0 Parametric Running Slow

mborboremarodri
1-Newbie

Creo 3.0 Parametric Running Slow

I'm a student who is using PTC Creo 3.0 Student Edition, I have installed the software on my laptop since September of 2016, and it works great without no problem. But yesterday the software crashed and started works very slow, when I try to do a sketch or access the menus its works very slow. I think the problem is not in the computer's hardware, because the software works great until yesterday. I have others CAD and design programs on my computer and I've checked them, for make sure if I had a problem with the graphic card, and there isn't any problem with them. I have windows 10 and also all the drivers updates.


I have checked the forum before and I saw a similar post about it, it mentions about modify the config.pro file, I followed all the steps and tried it, but the program still have the same problem.

15 REPLIES 15

PTC Creo parametric, student version, has been running well for several weeks on two nearly identical laptops.  Today, on one laptop, PTC creo has slowed down to a crawl and is nearly useless.  Trying to rotate even the most simple part is agonizing.  There is a terrible lag for doing everything.

I have tried (1) reverting to default settings, (2) rebooting, and (3) uninstalling and re-installing creo and nothing has helped.  Any ideas?  Why has not one helped Mr. Rodrigues?

Same thing has just happened to me, had a funny moment when trying to open a simple part and I just clicked past some error messages, now its useless. Such a pain I was thinking of uninstalling and then installing again but you say that has done nothing? Any resolution on your problem? Sounds exactly the same on the same day!

‌i have got the same problem now!! My creo 3.0 was working fine until a crash and now it's very slow only when I open/create new parts and assembly. did you managed to solve this issue?

It may be that the graphics card has failed, which is what caused the crash in the first place.

rhelber
4-Participant
(To:dschenken)

Yep!  That was it.  My graphics card driver was out of date on my new laptop.  I had to download the GeForce Experience program, since I have an NVIDA graphics card.  Only then could I get the latest driver!  My teenage son figured that out.  I hope everyone get their program working. Cheers.

theatrerabbit
5-Regular Member
(To:rhelber)

Thank you, this tip was useful for  me 🙂 But my Creo still doesn't work fast enough. Maybe it's the specific geometry of my part.

not possible as my brothers PTC creo 3.0 was working fine the night before and there was no crash and now it lags too. My 2 classmates are also experiencing the same issue.To be clear, it only lags when i open a new part/sketch/ asm OR when i open any of my parts/asm. Basically when i try to turn the piece or try to select a surface, there is extreme lag.

Hi guys, finally I found the problem. I have a nvidia graphic card and I realized that when I update the lastest drive of nvidia the PTC Creo crashs and starts running slow. And I proceeded to uninstall this last update of nvidia, and the program run normally again.

The same happen to my friend, who have the same program on his laptop (also whith nvidia card), I said to him to try this and his program run normaly again.

ngoutis
5-Regular Member
(To:mborboremarodri)

I'm experiencing the EXACT same thing on my Windows 10 pc -- Creo 3.0 M070 Student Edition. The software was working fine last weekend when I was using it. Launched it today, attempted to toggle annotations off, and the session crashed. Relaunched, and its slow as s#$t.

dschenken, this is NOT a hardware problem. Graphics card is fine. Other softwares are fully functioning. My guess is some Windows update may be to blame -- hopefully someone from PTC can chime in and let us know.

dschenken
21-Topaz I
(To:ngoutis)

You can't be sure about the graphics card being fine. I had one fail and the only function that was affected was video playback. 3D rotation was fine. Except for video, ALL OTHER SOFTWARE including Pro/E worked perfectly. Got an exact model used replacement, dropped in and video decoding worked fine again. NOT a software problem.

NICK, I suggested hardware because no one had mentioned changes to the SOFTWARE.

However, and just because the people asking for help always fail to do the minimum work on this:

Graphics card model?

Graphics card driver version?

OS? (only Nick managed that)

Is it running on an emulator under MacOS?

It's like calling a mechanic and saying "The car doesn't run right - what is wrong? I put gas in it and it ran right last week, so how can fix?"

Windows 10,

NVIDIA GeForce 710M

Latest driver though I'm not an expert

And this is a windows machine not an emulator on a Mac

Hope that helps, I can see its frustrating when people dont give enough information.

Hi

same Problem here with NVIDIA GeForce GT640M, huge lag, no serious working is possible.

I tray also to uninstall latest NVIDIA driver, but this can't be a durable solution.

Hope that someone from PTC takes care of this problem.

Problem solved.

Installed latest Nvidia driver manually, because auto update didn't operate.

aouellet
5-Regular Member
(To:mborboremarodri)

Hi all,

As best I am able to tell this issue is due to a Nvidia graphics driver update. Your solutions would be to either update the driver to one that works, or to manually swap/update to a functioning driver.

You can also try updating to Creo build code M110 which is what we have released right now.

Best,

Alexander

Problem solved!
Worked for me too - thanks everyone.

Went to Nvidia's website to manually download the newest driver, since 'check for updates' failed to work properly in Geforce. 

Now Creo works smoothly again.

Top Tags