Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you get an answer that solved your problem? Please mark it as an Accepted Solution so others with the same problem can find the answer easily. X

Error 0x06000003 - could not run the Quality Agent!! Help!


Error 0x06000003 - could not run the Quality Agent!! Help!

Downloaded 2.0 and can't use it. Error message pops up before anything can be done. Help please, I have work that has to get done this morning before classes! Download took forever and a day last night, so not sure if that had something to do with it?


I uninstalled the program(Creo 2.0) and reinstalled. Same problem....

Repaired the Quality agent, and retried. Same problem.....

hey Richard I have the same problem...Do you have any idea how to fix?

I had thé same problem and the only solution and it seems like the problem comes with m200 vrrsion. I fixed it by downloading an older version (m120) and now everything works fine.

Where did you find that older Version for download?

I have the same error. I saw that it don't works and runned "C:\Program Files\PTC\Creo 2.0\Parametric\bin\reconfigure.exe" to reconfigure the program.

And actualy it runed normaly with the a promt to register the Quality Agent! .... But after trying to activate, I found out that a executeable ( "C:\Program Files\PTC\Creo 2.0\Common Files\M200\x86e_win64\obj\prod_dcu.exe" ) has a bug and is anyways linked with the activation!!! Reinstalling doesn't helps because the M200 is buggy. May I find any other version of Creo 2.0 and replace this file.

So PTC guys you have the bug and we are waiting for a bug-fix.

Für meine non-english Freunde.

Das Programm habe ich wiederhergestellt mit dem Programm im obigen Ordner und festgestellt das Q.A. registriert werden muss. Gesagt, getan und Fehlermeldung vom mit dem obigen prod_dcu.exe erhalten. Wiederinstallieren bringt nichts weil M200 fehlerhaft ist.

Goodbye Sumaktas

Grüße Sumaktas

Hi Richard,

This is a known error with Creo 2.0 M200, and the development team is working hard to find a solution ASAP. I will let you know once we have a fix.



Hi Chris,

Creo 2.0 M210 Student Version does not solve the "prod_dcu.exe has stopped working" issue.

I also tried reinstalling - with no effect.

Is this problem connected to Windows 10?

If you know anything new I would be happy to hear from you.

Kind regards,


Why the student version is great even if its a Older version so:


2. Login and if you have rights, you will get to the next step

3. Read The Terms and continiue if want get the software

4. Now you are in the final step and see the in front of you. Just download the needed version

(5. Product Key is needen also. So You can ask a frind for it, if you have no idea, how to get it)

Good Luck Johannes Raphael


But already tried this. If I click on Creo 2.0 in step four it just downloads M200. Coul not find for example 2.0 M190 or an other Version of Creo 2.0 that works  (and I need 2.0 because of my University). Thank you for your answer anyway

Hi everybody!

I've tried to install Creo 2.0 M200 several times and didn't succeed. Always receiving the above mentioned error message "0x06000003" and couldn't run the quality agent.

Need to work urgently with this tool next week, because of my school! Is there any alternative, e.g. another version or is there a chance to fix this bug in the next few days?

Many thanks for your help and support or any other advise!


Top Tags