Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - New to the community? Learn how to post a question and get help from PTC and industry experts! X




What is the best/fastest way to load/import all of the KOP models into a Windchill Library or "COMMONSPACE" Folder? Not very good with Windchill yet but it would be tedious to load one at a time or as multiple parts/documents. Can it be put in all teams' Projects?


Hi Stuart,

the fastest and most accurate method I've found is this:

1. Open Pro/E connected to your Windchill server

2. In the internal Pro/E browser workspace, select "Tools", "Import to Workspace"

3. Select "Add"

4. Browse to the folder where your files are and use "Shift", "Select" to pick all the files in that folder.

5. Repeat for each folder in the KOP file you donloaded.

6. Select all and "Check In"

I think I prefer to dump everthing into a single folder and not have the folder structure that was in the downloaded KOP.

If you do wish to re-create the KOP folder structure in Windchill, after step 5, select "Next", and then set the folder location after each folder import.

I would love to hear any ideas of how to do it faster!

By the way, I don't believe it's feasible for PTC to import the KOP directly into each team's Project due to initial configuration of the projects as well as standard Windchill functionality. (There may be something new for next season though )

Thanks Josh.

I did search around and found a doc discussing how to do the importas you describe. I was successful initially but then decided to load all ProE parts to one folder, as you suggested. Too much of a pain to make all those folders.

I deleted my Workspaces as well as re-did the Folders structure in Our Project area, but now get nothing to show up in the just created Workspace. I was in the process of taking a break and starting again later any suggestions?

Also what is the quickest way to change access priveledges for our "Library" folder. Want to make it Read-only for all but myself.

Hi Stuart,

Regarding access rights, select "Edit" at the top of the folder view if you are in that folder and then "Manage Security".

If, for example, you're at the top of your folder structure and see the "Actions" column next to your "Library" folder and then "Manage Security".

If there are other users with the role of "Project Manager", there is nothing you can do to limit their access to your "Library", except move them out of that role. Regarding the rest of the users, they should only have "Read" and "Download" rights.

Last, for the Workspace you mentioned that nothing's showing up in, did you "Add" files or download the files to this workspace?


Still not working. Even tried from Home PC and doing just one part.

Here is my process:








Everything looks fine through the "Object List" picture. I can't quite imagine what could go wrong from that point.

I just tried to import a file from the commercial version of Pro/E with my Education edition and it didn't work, although I did get an error message.

Are you in Wildfire 4 or Wildfire/Creo 5?

Running Wildfire 5.0 M040 Schools Edition here at work; at home; and on our team computers.

Any issues with SET LOCATION Path??

I just made a part within ProE and checked it in w/o problem. Checked out; made changes; checked in. Looks fine.

Tried one of our parts made in commercial ProE and get expected "this is Schools edition; file is Comm edition" like you did.

I was suspicious of the dash in your path, but tested and it works fine.

I hate to admit it, but I think you have me stumped!

My last resort with Windchill stuff has usually been to wipe out everything local by deleting the .wf directory.

Maybe we can get some help from somebody at PTC? Mark or Scott?

Thanks Josh.

I had assumed that you were PTC as you are extremely knowledgeable on the subject and seem to be the first one to respond to everyone's questions!

Do Mark or Scott persuse the areas? Way to forward the thread? I can always e-mail Mark directly.


BTW: What is the TEAM you work with?

Hi Stu,

thanks for the compliment! I'm just a Pro/E, Pro/I, Windchill hack that is rather fanatic about supporting FIRST.

Mark and Scott are usually really good about addressing issues on Planet PTC and the fact that they haven't intervened on this one probably means they are swamped. I would encourage you to contact - directly.

I'm primarily a mentor for Team 1671 and as of this year Team 3296. I work with a couple of other local teams as well when they need help.


We are still running Ilink 3.4 here at work but looking into/need to go Windchill PDMLink 9.1 or ProI 9.1, maybe. Cannot beat Ilink 3.4 for the CAD guys here! Who thunk that Robotics would give me more of a flavor than when I have PTC come in and talk about it and quote $$$$s.

I think I have resolved my issue. Must have been some bad files/models in my KOP download. Will re-download it again and cross my fingers.

Never even saw until a few minutes ago the text in the ProE message window --

File search finished: 137 found, 3 missing.
Import failed.
File search finished: 86 found, 3 missing.
Import failed.

I had no issues when I imported the items in the Rookie Kit folders.


Just looked 1671 up. No ice storms there!

I work right across the street from Hartford's Bradley Airport -- When they say Hartford CT broke records with 79.6" so far.

Looks like you have a very CAD team. Wish we could dedicate "enough" students.

I'll have to come say hello in ST. Louis.

Yes, I've been watching the posts on Chief Delphi. It looks like there are quite a few teams that have some major challenges!

Team 1671 has definitely been a CAD powerhouse for the last couple of years. Aside from the sheer quantity of students that know and are learning Pro/E, they also have a training program run by the students, allowing me to put more time into getting other local teams up to speed.

Hi Stuart,

So, did you try deleting the .wf file? That wasn't clear from your posts.

If that you did delete the .wf file, and that still didn't work, I noticed you asked about SET LOCATION path.

I recently had my workspace not show up, and it turned out to be that I changed an environment variable. Changing it back to the default made my workspace work. It's not exactly the same as your issue, but I wondered if you asked about the path because you noticed a difference between the two systems. It might be worth looking more closely at that variable.


THX Celia.

As you can see from my post just before yours, I think issue is with some of the KOP models and their relationships, etc. Importing KOP folder/by folder to get it right and then download the KOP zip from PTC and try the failures again.


Top Tags