Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Have a PTC product question you need answered fast? Chances are someone has asked it before. Learn about the community search. X

License Generation Problem


License Generation Problem


I am having a persistent problem for last 2 days. I am unable to generate the license file for Pro/Engineer Wildfire 4.0 School Edition. Whenever I click on "Generate File" during the installation, it says "PTC Setups was unable to contact the PTC Download Server. If you use a proxy server with your web browser to access internet you will need to specify that server now for PTC Setup."

I am afraid I am connected to internet, besides I don't use proxy. But it keeps giving me this error always. I brought my laptop at the University's IT Help Desk for installation as well, they told me that it might be because the License Server is temporarily down. Could anyone please tell me what the real issue is?




I have been having the same problem today. A call to a contact inside PTC says they're having a temporary problem with their license generator, and that we should try again later. He couldn't give me a definite estimate on when to try again, but this is a high priority for them, so they will be fixing it ASAP.

Umm, I had been trying to login my PTC Account 3 days back, it always gave the message that the application is turned off for maintenance. Finally it worked after 2 days i.e. yesterday. But it seems that the license server is still not fully functioning -- under maintenance. I emailed - yesterday and just few minutes back I have got a reply from them. I have given them my network physical address. They might generate the license file manually. Waiting again for their response. You can try that too. I hope it will work for both of us.



I tried again last night, and the License Generator still isn't working for me. I'll try e-mailing - with my MAC address and see if that gets me anywhere. I really wanted to be up and running by tomorrow evening for a team meeting demo. This is more than a little frustrating.

I am agitated as well. I have to start working on my final year project and I am losing my days. Next week would be Christmas holidays for 3 weeks and I won't be able to meet my supervisor. I thought I will do some work in this one and half week and will show it to him, but alas .. this license generation. - just responded once, they are not responding back .. been 2 days now. Double frustrated!

Let's just hope license server starts functioning properly soon

Hi Absar,

Sorry for the inconvenience. We had experienced a glitch on the automated license generation server last week. The issue has since be resolved and you should be able to generate your licenses. If you continue to experience the issue, please send me an email at -.




I am facing the same problem. I have downloaded Creo Elements (former Pro/ENGINEER Wildfire 5.0 schools edition) from your site and when i try to generate License File it sends me this message:

ptc engineer.JPG

What should I do? I really need this program because I have a test next week on my college (FESB, Split)

I have good internet connection but I don't know what is proxy server. I don't think I'm even using it.

Best regards,


I solved it by "offline license generating".

But thanks just like u had time to help.


How did you fix the problem? I don't see an option for offline license generating.



Security on some computers and networks can prevent access to the licensing login fields. Where this happens, PTC provides online web forms to create a license.

Capturing the computer Host ID/MAC address

Download, unzip and run this app on the PC/Server. It will report your computer’s Host ID.

  • Make a note/copy to clipboard the 12 digit Host ID.


Requesting a license

Go to the link below for the edition and type of license that matches the product code you have been given.


  • Login using your login.

  • Paste your product code into the appropriate field.
  • Type in/Paste the host ID in the appropriate field.
  • Complete any other required fields and submit the form.

Within two hours you will receive an email with your license attached.

Installing PTC Creo

  • Copy the license file to the install computer
  • Run the install and at the licensing screen drag and drop the license file into the license field near the bottom of the install window.
  • Complete the installation following the installation instructions for your version of PTC Creo.

Thanks Tim! This allowed me to install PTC Creo, but now, when I first open the program, a pop up appears titled "Warning Message List"

It then says:

License request failed for feature

Requesting PROE_Schools...

C:\Program Files\Creo Elements\Pro Schools Edition\text\licensing\license.dat:(-5) No such feature exists.

Displaying status for license file: C:\Program Files\Creo Elements\Pro Schools Edition\text\licensing\license.dat

License Server is UP:

Warning(-3): No license server system for this feature.

There is a license server manager/vendor daemon running, but it's for

other vendors.

Feature: PROE_Schools

License path: C:\Program Files\Creo Elements\Pro Schools Edition\text\licensing\license.dat

FLEXnet Licensing error:-3,278. System Error: 22 "Invalid argument"

For further information, refer to the FLEXnet Licensing End User Guide, available at "".

License In Use Free Version Expire Date SCN

CREODMA_Student2 Uncounted 33.0 19-nov-2013 Student2 Locked to: **************

CREODMA_Student2 Uncounted 33.0 19-nov-2013 Student2 Locked to: **************

CREODMA_Student2 Uncounted 33.0 19-nov-2013 Student2 Locked to: **************

I tried copying the license file I recieved in the email over license.dat, but they appear to be the same thing.

Any ideas?




Did by chance you enable or disable one of your network cards (wirless or hard wire) after generating the license file? The license is attached to the 1st priority card on your computer, if that priority changes or that card is disabled, the license will not work.

Open a comand shell (Start, type "cmd" and press Enter). In the command shell, type "config /all" and press Enter. You will see at least one Physical Address listed. Compare any listed to see if they match the Host ID shown inside your license file. If it does not, we know what the problem is.




No, I haven't enabled/disabled a network card. It's attached to my wireless card, and the Host ID is the MAC address of my wireless card, as it should be.

Any other ideas?



If the Host ID in your license file matches your MAC address, them maybe it is your wireless card priority 2. I'm not sure but I have seen this before.

Yes, the wireless card was priority 2. I moved it to priority 1. No change. I rebooted my computer. Still the exact same error message. I checked, and the wireless card was still set as priority 1. I'm going to reboot it a few more times and let it sit overnight.

Hi David,

Can you please send me an email and I can connect to your machine directly to take a look. My email address is -.



I think I am having this problem, considering I have been trying to change my ethernet adapter settings on my Linux side to comply with a different company's policies, but the steps listed at that website don't work in Win8. Do you have any ideas about what I should try?

I don't have a Windows 8 computer but I am told this will work:

Change the Network Connection Priority

Open your Control Panel and select Network and Internet> Network Connections.

  • Now click on the Alt key to make the Menu bar appear.
  • Click Advanced Settings to open the Properties dialog box.


From the Advanced Settings dialog box, you can edit the priority.


I have the same Problem. My Creo SchoolsEdition pop up with the title "Warning Message List"...

I read the posts and change the Priority of my Adapter. And the physical address fits together with my license.dat...

The Warning is also the first pop up, when starting Creo.

A few days before, my Creo works without any warning.


To solve your issue we would need a little more information such as the full message you are receiving and the version of Creo you are installing.

I would suggest that you review our FAQ section at If this doesn't help, please submit a support request from the Request Academic Support tab. This will ensure the entire support team sees your request and it will be addressed accordingly.



Top Tags