Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Help us improve the PTC Community by taking this short Community Survey! X

ProE 5 will not start


ProE 5 will not start

I installed ProE 5 Student Edition from my school back in August. From what I remember, it worked fine then. I recently tried to use it for a class but it would not open at all. There was no error message or splash screen. When I open it on my desktop, it will show the mouse as "busy" and then open, but on my laptop, I click the icon (or the start menu, or even the exe in the program files) and it flickers to busy but immediately stops.

I've tried uninstalling and reinstalling many times. I've copied over the files from my desktop with no results. I've cleaned out the temp folders and fixed my registry with CCleaner (nothing ptc or proe related though). I've tried updating my video drivers and even adding that line to disable them in Nothing has worked. It doesn't even start up in safe mode either.

What is wrong and how can I fix it. All and any help is greatly appreciated!




This is a tough one. No simple answer and not enough info. You should at least state the Graphics card and OS version.

I'm going to try to help, but I'm from the Unix world.

Basically Pro-E starts from a script, not a binary. It needs to set some environment variables before it can start. That said, first try to start it up from the command line. Different versions of windows has it in some different locations. Sometimes it's called the "Command Prompt". Go to Start > All Programs > Accessories > Command Prompt. Basically you want to enter the line from your shortcut into there. Move the mouse cursor to the shortcut and "right-click" on the icon and select "Properties" This should show the location of the start script. Enter this into the Command Prompt. It should reveal at least some error message and possibly give a clue to what's wrong.

Thank you for replying quickly!

Both computers are running Windows 7 Pro with my desktop using an nVidia GeForce 7950GX2 and my laptop running an ATI Mobility Radeon HD 5870. My desktop is using an Intel Core 2 Quad Q9450 and the laptop an Intel Core i7 Q720.

I ran the cmd command on both computers and while it worked on my desktop, it again did not work on my laptop, but it didn't give any errors either. I am perplexed myself as to what it may be. Any other suggestions?



So basically you entered the command and it just returned back to the prompt and nothing displayed or it never returned back to the prompt?

My next question is what was the command you entered?

It just returned to the prompt with no messages and it happened on both machines. I simply entered that shortcut path within quotes ("C:\Program Files\ProENGINEER Schools Edition\bin\proe.exe") and it started it up on my computer, but not my laptop.

OK that at least shows its not hanging. Two more things to check. See if it's running in the task manager.


Pro-E is finicky with graphics drivers. Check and make sure you either have the latest certified driver or a known one that works. Try here for the latest:

Looking at ATI's page:

It shows the Graphics card supports OpenGL 3.2, but it say's the driver is due in 2010. I know 2010 is almost over, but I haven't confirmed the driver is released yet.

Do you at least have the latest?

Another thing, I believe the Windows version has both a 64 bit and 32 bit version. Are both your computers running the same bit version?

Both computers run Windows 7 64-bit. I did install the latest drivers but decided to uninstall and rteinstall them to se if that would help. I also ran a windows boot disk to fix any start up problems hoping it might fix any registry problems. Lastly I retired running ProE in every possible compatibility mode to see if I got any result. Nothing I did helped except that when running multiple compatibility modes, the screen flickered to 256, a lower res, etc. but nothing else happened. ProE still does not start. I am tempted to just reformat the laptop, but do you have any last suggestions before I do?

No, at a loss for any new ideas. Hopefully somebody else may have a suggestion. You may have to try the reformat.

I'll state the known:

1) It doesn't appear to be a license issue, Pro-E usually starts up and complains it cannot find a license.

2) Pro-E doesn't appear to hang, at the Command Prompt the command completed and returned back to it's prompt. Although, you haven't yet told us if there is a Pro-E process running utilizing the "Task Manager".

3) Doesn't appear to be a 32-64 bit issue, both computers are 64 bit.

4) Doesn't appear to be a Graphics issue, you have tried the latest graphics driver and turned off accelerated 3D in

Also, there is now a new version of Pro-E Student Edition out. This occured after the name change to Creo.

Try downloading that and see what happens.

I recently reformatted and reinstalled everything on the laptop. Even with a clean OS install and new install of Pro/E, I still cannot get the program to start. It has the exact same issues as last time. There is no process in the task manager either. Could I need to install DirectX or would that have been installed with the graphics driver?

Also, how does one go about editing the file as I may have done that incorrectly, and thus never tried running it without gfx hardware?

Has anyone been able to run this program with this graphics card?

You need to edit the file or create it. The default location is at:

C:\Program Files\proeWildfire 5.0\text\

Enter the line:

graphics win32_gdi

This should turn off the requirement for accelerated 3D OpenGL graphics.

Also in the "Installation and Administration Guide" for wf5 states

You can run Pro/ENGINEER in the Direct3D 10 graphics mode on the Windows Vista operating system. Set the value of the graphics configuration option to d3d to run Pro/ENGINEER in this mode. Direct3D 10 is an API provided by Microsof that enables you to render 3-dimensional graphics accurately.


graphics d3d

Try the entry things let us know the results. Do not add both "graphics" lines, only one at a time to see if it works.

By there not showing any pro-e process in the task manager just confirms that pro-e is not hanging. There is something causing it to shut down before graphics startup

Got it a little wrong. There is a third option to try:

use_software_opengl yes

In the same "Installation and Administration Guide" it states:

On Windows, set the use_software_opengl configuration option to yes to invoke the OpenGL application locally on your machine. PTC recommends that you use this configuration option in place of WIN32_GDI to address issues related to graphics cards.

Does the graphic configuration fixed the problem?

Can you check the size of the installation folder?

Can you check for any sdt.err or sdt.out files in the start-in folder (by default is My documents)?

The fallowing executables should be allowed to run on your machine (firewall and/or antivirus):

- for 32 bit machine:

<installation folder>i486_nt\obj\xtop.exe

<installation folder>i486_nt\obj\pro_comm_msg.exe

<installation folder>i486_nt\nms\nmsd.exe

<installation folder>i486_nt\obj\xtop.exe

-for 64bit machine:

<installation folder>\x86e_win64\obj\xtop.exe

<installation folder>\x86e_win64\obj\pro_comm_msg.exe

<installation folder>\x86e_win64\nms\nmsd.exe

<installation folder>\x86e_win64\obj\xtop.exe

None of the changes helped. I added a firewall exception with no success. The folder size is 2.92 GB or 2.96 GB (size on disk). I found a std.out file along with a ptcsetup text file. The ptcsetup file states that activation failed at the very end. The std.out file is attached. It seems to be a license issue, but I'm using the same license from my desktop and it works fine on that system.

Creo Elements/Pro Schools Edition license is locked to the Host ID (physical address) of your computer; you cannot use licenses created for other PC...

Please send an email to - to request a new license for that machine.

To find out your Host ID, click Start and choose Run. In the Run dialog box, type cmd and press RETURN. In the DOS window, type ipconfig/all. Look for the network Physical Address for your Host ID. The Host ID also appears in the bottom-left corner of the first screen in the Creo Elements/Pro installation.

Hi Valeriu, I have the ProENGINEER University Edition for Secondary Schools 5.0.

My plan is to buy 5 new work satations, that's why I would appreciate if you please helpme to define the basic system requirements to start working with Creo Elements.

thank you very much.

Hello Jorge,

You can check the list of Minimum Hardware Specifications.

Here are a few suggestions for RAM and Graphics:

1) - Get as much RAM as you can. I would purchase 2 GB of RAM, however Pro/ENGINEER will run fine using 1 GB. RAM is relatively cheap these days and the more you have the better, especially as the Microsoft operating system and software tools keep pushing the envelope. If you can push it to 3 or 4 GB’s I would do that also as it might keep that computer running a few years longer.

2) - Graphics Cards are probably the most important component for running Pro/ENGINEER efficiently. Graphics Cards must support OpenGL* - see Please note that typically “gaming” cards do not work well with Pro/ENGINEER.

For additional information on platform support details, please review the official Creo Elements/Pro 5.0 (formerly Pro/ENGINEER Wildfire 5.0) Platform Support Matrix.

I hope this helps!


Hello Valeriu Maria Baciu, I have bought a new workstation from Lenovo, has 4 GB on memory, Windows 7 64bits, 500GB on hard drive, Core i7, I have installed Pro/Engineer 5.0 University Edition for my classes, I want to use this workstation as a server in order to be able to move to different places with my students, I would appreciate it if you please explain me the process to follow me on how to get it.

for your help, thank you very much in advanced.


Jorge Luis Martinez Graciliano


I saw the same thing happens on a machine in our lab. The problem was a environment variable set with the wrong type. The variable was the path of cmd.exe


Using WF4.. on Windows 7, having an issue that sounds similar to this..


Program has worked fine for a while.

Now, program does not start at all.

Only nmsd.exe process is running in the 'Task Manager'

and the std.out file gives only: "Serious internal error; cannot continue."


In saving some config options i saved over the top of the file (not just the current session file).

I suspect this has thrown something out that the program needs to start up? (paths?,variables?)


Have tried uninstalling / reinstalling - no different

Now looking for a file? (Unfortunately I didnt have the original backed up before i saved over it..)

Any ideas help much appreciated..


Pro/E will read files in the following order:

  1. Global: C:\Program Files\ProENGINEER Student Edition\text
  2. Home Directory: This is typically Documents or My Documents
  3. Start In folder: The folder that Pro/E starts in.

If there are any files in these locations, temporarily rename the files to config.bkup and then try starting Pro/E without them. This will verify if they are the cause of your problem.

If you can verify it is the file, you will need to comment out lines of the file (using an "!" mark) to find out which option in your file is causing the problem.




Many thanks Adam

I have investigated and I have even deleted all the config files from all the locations you mentioned and the program still does not start.

I have now also gone back and installed WF2 and that seems to work ok.

(But I need WF4 because the files arent backwards compatible of course!)

Have Un & reinstalled WF4 again and that made no difference..

All that does happen is that process 'nmsd.exe' starts up, but nothing further happens from there.

Puzzled.. and really appreciative of any further advice???

Are you connecting through the same network adapter you used when it was installed? I had the same problem as you, suddenly Proe 5 would not start, no splash screen or anything. I had moved my PC and connected to the internet via a lan cable instead of wireless. Refitting my wireless card solved the problem. Its based on the mac address of your licence, found in Program Files\ProENGINEER Student Edition\text\licences\licence.dat Look for the line PTC HOSTID=HOSTID= and then what follows is the (not to be confused with apple mac) MAC address that Pro engineer is expecting. To compare it with your current MAC address open command prompt, and type ipconfig /all and look for "physical address" of your network adapter. This must be the same as the number in your licence.dat file for Pro engineer to start.

I have tried EVERYTHING mentioned in this thread, and I'm still having the same problem. No splash screen, no nothing. Like a previous poster mentioned, I used it successfully for a few months, but now it's completely unresponsive. Seriously cramping my homework style...


Sorry your having the problem. Could you please send a support request to -? Someone from the Academic Program support team will get with you to fix the problem.



I have the same problem. I tried everything in this thread... it is a q9400 4x2,67ghz, gtx260, windows 7 64bit ultimate sp1. I can not do my cad programming on my 11,6" notebook....


I have similar problem with Windows 7 x64 and ATi Sapphire X1950XT 512MB DDR3 (opengl 2.0). After some fiddling with drivers and options I managed to solve the problem.

1. Install Catalyst 7.11 (my choice) or 8.12;

2. Set options:

enable_opengl_shader yes (Catalyst 7.11) or no (Catalyst 8.12)

graphics opengl

use_software_opengl no

Top Tags