cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

How to hide planes

Newbie

How to hide planes

Hi all,

I do not know how to hide these datum planes aka not to show at all. I do not want to use layers because they propagate all the way through to the part level. I discovered, by pure accident, that when CTRL-ALT keys are pressed, Creo hides them all.So, does anyone know to how to hide these planes by default?

HIDE.png

11 REPLIES 11

Re: How to hide planes

If these datums were created on part level they should be hidden using layers on part level. If they are assembly datums you can hide them via layers on the assembly level, there is no propagation...
Maybe you need to specify your problem a little.

Re: How to hide planes

Constantin, when plane is set to be a datum plane, it shows itself on screen even when button "plane visible" is off. I need to know if there is a setting somewhere in Creo that I can set so it does not show on screen unless I choose "plane visibe=ON". And I do not want to use layers to solve this issue.

Re: How to hide planes

Hi Danilo,
I think it will only be possible using a layer.
Layers are not evil, they are friends

Re: How to hide planes

I agree with you about layers, but I do not want to use layers for a simple plane visible on/off issue.

Re: How to hide planes

Using Layers is presently the only answer. It can be less painful to include layer rules in the models to automatically move add the set datums to a layer and remove them from other layers to make visibility control easier.

Re: How to hide planes

I am confused about what you are asking.

If you just want default planes not visible when you start Creo you can set

display_planes no

in the config.pro, but this is only setting the default position of the switch on the graphics toolbar.

Re: How to hide planes

It gets even worse when you use the newer ISO style datums (also recommended by ASME). They have a behavior all their own. We had discussed this at length.

The 1st thing I recommend is not making the default datums tagged datums (for lack of better way to define them). If you assign the datum to a surface, they behave a little better. Or create datum planes specifically to use them as GTOL datums and nothing else. Don't ask me why, but it does make a difference.

Then I found out that these new style datums have a mind of their own which is somehow related to their use in drawings. A datum I couldn't hide for the life of me in the model suddenly would disappear when called to show in a drawing. Now try bringing it back! That is why you don't want to use the primary datums.

The old style tags are a little more forgiving. I even had trouble deleting the new datum tags at one point. I had to change them to the old version and then they could be deleted.

You are certainly not alone in this. A search of the forum on "datum tag" will get you more information.

I think the term "persistent" somehow applies to these. I think I remember they not always following layers either, at least not the new style.

And from the past, yes, even in the old Pro|E times, tagged datums were a true issue in large assemblies where they were persistent as well.

Re: How to hide planes

Matt, does this setting "display_planes no' hides also datum planes? The answer is NO.

Re: How to hide planes

David, I would have no problems with layes if they do not propagate all the way to every detail. So when I open the detail, datum planes are also gone and that is very bad on some commercial items where I cannot constrain them without using planes.