cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - You can Bookmark boards, posts or articles that you'd like to access again easily! X

Anyone running Creo3 date code M20 on MacBook Pro?

sdesaulles
3-Visitor

Anyone running Creo3 date code M20 on MacBook Pro?

I have a MacBook Pro (Retina, 15-inch, Early 2013, 2.8 GHz Intel Core i7) It was runniing Creo 3 M10 datecode just fine under BootCamp. Creo kept reminding me on startup that the M20 datecode update had been released.

As I wanted to install the keyshot plugin, I thought I might as well update first. Disaster.

Lots of things that could have been what often gets called "graphics errors" - so when selecting tree filters on the model tree, click in a box to tick or untick and nothing happens, close the dialogue and reopen it and yes, they had been selected, but not dislpayed. Just one example but the whle GUI became hobbled, things disapeared from the top 'ribbon' menus, blank patched where items should be revealed.

But not just graphics. The scrollwheel zoom just totally stopped working, in fact all middle mouse button motion control was disabled.

It was so 'hobbled' I removed it (even the software removal was corrupted) and re-installed M10 datecode. It is now working again.

So, question, is anyone else out there running Creo3 M20 on this version of the MacBook Pro successfully?

Also is anyone running it on the latest MacBook Pro sucessfully?

Lastly, anyone encountering similar errors on an "approved" machine. Obviously PTC don't approve Macs and doubtless Mac are too arogant to submit their machines to PTC for approval - so doubt that will ever happen, but intrigued to know if approved machines suffer similar issues.

Oh and one last question why is creo_2.0 listed as a popular tag but not creo_3.0, is no one using it?

Thanks

Stephen


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
11 REPLIES 11

Creo 2 was released a long time ago and has a lot of users and Creo 3 was released recently and has far fewer users.

Did you save or copy the config.pro file on the install of M020? Were you using the graphics win32_gdi config option?

...would hve thought it might still be a "popular" tag, although not at all popular with me currently.

First I did an "upgrade" type install that used ts defaullt config file, the one it places in the install directory, then I was using the same config.pro file as previously with M10

Then I did a "fresh" and again I used its defaullt config file, and again then used the config.pro file as previously with M10, once again loads of graphics inconsistencies as described.

I didn't alter any graphics options, so not sure if I was using the one you mention, I certainly would not have picked it though as it has 32 in the title and the MacBooks have been 64 bit for some years.

The only think on the graphics was that Concurrent Enginering (my PTC support in UK) suggested my driver was old, about 9 months old, and should be updated. I updated that and it made no diffference to M20's corrupted behaviours and if anything made M10 run slower than previously.

On the original question, are you running on a MacBook Pro?

Thanks for the reply.

Stephen

The configuration option "graphics win32_gdi" tells Creo to not use the graphics accelerator or drivers, bypassing incompatibilities. It has nothing to do with 32/64 bits.

Of the many apps that are nice on a Mac, the particular hardware is not what I would select for CAD work. The lack of Quadro support is the primary issue. It looks like your model has a video stream decoder in the Iris Pro section built into the i7 and a GeForce, which is a gaming level device.

Hi David,

Thanks for the clarification on that, I will try it, needless to say, I'm not expert on the configuration options and tend to just leave as 'default' unless advised otherwise.

On the hardware, long ago I ran Wildfire 4 and 5 on a Dell Precision M60 that weighed a ton but was "certified" by PTC for ProE, it crashed very frequently, when the intel Macs came along I switched to running on the 17" MacBook pro, not supported, but the graphics ran better and it crashed far less frequently. Annecdotal I know, but I've not had great experience of running on "certified" hardware.

My current MBP, allbeit a "gaming level device" seems to run the Creo 3 M10 datecode fine, and works very well with other CAD and 3D rendering, ie SolidWorks, Alias Design, Rhino Keyshot etc, as ever, it seems to only be Creo that has "issues". I do run Creo 3 on a new MacPro "trashcan" also, (although I haven't "upgraded" to M20 after the laptop experience) and it runs beautifully, but when working away from my studio I need something portable, and yes, I suppose in an ideal world I would have a PC laptop just to run Creo.

The latest MBPs have a NVIDIA GeForce GT 750M with 2GB video rather than 1 in my current machine, not "quadro" perhaps that might help.

Thanks again.

Stephen

Hello,

I am also running Creo 3.0 on my MBP 13". Using BootCamp with Win7. I used it last night for a model working fine. When i went to shut down computer, Win7 automatic updates began, (4 updates in total). I let it go through since it starts automatic. Woke up today to continue modeling, and now mouse scroll is not working for ZOOM or MANIPULATING. Mouse Scroll unrecognizable. I tried in browsers and other programs and scroll is working fine. Went to Costco and purchased another mouse Logitech ANywhere MX. Still not working. I thought i was the only one. I did not read what updates was it making last night.

Hope there is a workthrough. Please advise. Thank you.

Best Regards,
David

Hi David,

You didn't say what datecode you were using on your MBP, if M20, then perhaps like me you could revert to M10 to retreive the functionality. I did try to bash on without the use of the mid mouse button, and like you tried a different mouse as I assumed it was that and not the software that had failed - (I've had plenty of mice that have failed over time, but never had ProE, even from pre-Wildfire to now fail to recognise the middle mouse button) but very difficult to use Creo like that.

You will see help here to do with graphics cards that can't handle OpenGL (as fas as I'm aware the MPS can, you don't say the specific spec, but mine does) and need to somehow do that in software on the CPU, but I think this is more fundamental and not related to the graphics card - that was the opinion of my PTC support experts anyhow.

Interesting you are running W7, so am I, and yest the latest "auto updated" version.

Let me guess, no other application lost MMB functionality, just Creo?

Good luck.

Stephen

Hello Stephen. Thank you for your reply. I am sorry since i am not too familiar with the program since i am a student and currently began using Creo 3.0.

I managed to download some software on the new mouse i bought (Logitech Anywhere MX) and managed to retrieve functionanilty on the scroll and scroll button with some configuration it allowed me.

Tested Creo 3.0 and working flawless. Luck i guess.

Thank you for your response and feedback. Really appreciated.

Note: I'm sure this wont be the best workaround for some out there since i just bought new mouse that permiited the config. It would be good to make it work with current mouse and not purchase other. There has to be some config to do in Creo 3.0 to make it work with current hardware.

Best Regards,
David

Hmmn, interesting, I have one of those mice, stopped using with Creo as the scroll can't be used as the middle click, you have to use the other little button behind it and keep shifting from one to the other, (or at least I couldn't find a way to use the wheel to click).

Would be interested to know what settings you applied. I have the supremely ugly Logitech "Perfomance Mouse MX", that I "upgraded" to just to get the middle click back, so perhaps there is a similar setting I could apply to that.

I did try to get the Apple Magic mouse to work with Creo as its the best tracking mouse I've ever used (including the 'dark field' Logitech and what was supposed to be a super responsive Razer Ouroboros gaming mouse) , but just cannot find a fix for getting a middle click on that, scroll works fine, but Creo really needss the click

Thanks

Stephen

Hi Stephen,

Yes. Saw that using this mouse. I also could not get the scroll wheel to click. I am using the small button behind it to click and manipulate. It isnt that bothersome for me since i was not accustomed for years to using the click wheel, so I can manage with the behind button. I imagine that for intense design then the click wheel is much better.


When i bought the Logitech Anywhere MX i had not idea that the click wheel behaved like this.

These were the downloads i made. (setpoint) let me configure mouse buttons since at beginning Creo 3.0 didnt even register scroll wheel, nor behind button.

http://support.logitech.com/en_us/product/5846#download

David.

StephenW
23-Emerald II
(To:ptc-6790176)

This may be associated to http://communities.ptc.com/message/270733#270733

You might want to try the config.pro option as noted in there.Seems like an odd thing but it might work.

set_trail_single_step NO

Top Tags