cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about PTC Community Badges. Engage with PTC and see how many you can earn! X

Creo 2.0 M020 is out: report your update experience.

TomD.inPDX
17-Peridot

Creo 2.0 M020 is out: report your update experience.

I'll start this with the link to the Update Advisor:

https://www.ptc.com/appserver/cs/update_advisor/update_advisor.jsp

You can plug in your version and the latest released version.

I'm not looking forward to doing the update but I have already downloaded both the files.

I may wait to have support on the phone to see how to properly uninstall the previous version first.

Tell us how your update went, and did you see improvements to your favorite peeve?

You probably need to be current on maintenance to access the Update Advisor.


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
16 REPLIES 16

I think the update advisor is broken or maybe theres no advice when I try to take an advice on going from Creo Parametric 2.0 M010 to Creo Parametric 2.0 M020.

I also have the intaller for Creo Parametric 2.0 M020 downloaded but I hesitate to intall it before I finish my current project that I make in Creo Parametric 2.0 M010.

I am curious if they noticed and fixed some of the bugs previous builds of Creo Parametric 2.0 had and managed to fix them.

As I've done uninstalling of Creo Parametric 2.0 M010 (why I keep using this long name all the time?) I can give you few hints on that as it's pretty simple and there should be no problem getting rid of it. But I don't recommend doing so until you are sure about M020 for it to be the only version of Creo on your laptop.

So it's propably better to install Creo 2 M020 as a new intallation into a different folder and not try to remove M010 first or make an update of the M010 build which could be even worse in result.

I'll write back when I am done with my installation.

The advisor is working. Probably what is more important is the Reported Issues section.

Both lists are quite extensive. Unfortunately, the information you can gather from the list is still quite criptic but better than nothing.

UpdateAdvisor.PNG

...

And having done the F001 to M010 twice, I will be doing the complete uninstall and re-install. Remember I had some sort of bug with the CoCreate import module not installing or even available for install after the fact. I'm not interested in testing this out for them. I reported it and I don't see it in the bug fix list.

I did the update without CS.

Save all your customized files to a zip outside the Creo install folder!

I have Swiss fonts and Customer formats that I zipped up and moved to a C:\Creo2_M020_install folder. Make sure you leave nothing behind, because the Windows Uninstall will WIPE those folders clean!

I uninstalled everything with the Windows Control Panel that was installed on the same date as the last install... EXCEPTthe FlexLM stuff! (mine is custom)

Reboot!

Extract the downloaded ZIP install file (HUGE!) into a C:\Creo2_M020_install\M020 folder.

Extract the downloaded ZIP install file (help files) into C:\Creo2_M020_install\M020_help folder.

I then ran setup from the C:\Creo2_M020_install\M020 folder.

Remember to add Mechanism extension to the install

Change the install folder to C:\Creo2_M020\ (or whatever you prefer)

Added the optional Exchange options (Direct modeler in my case)

Note: the original FlexLM license was already selected and nothing needed to be done there.

After a while the install was complete so you just click finish after that.

I then ran the setup in the C:\Creo2_M020_install\M020_help folder

- By default, the help install knew the new folder location for the Creo 2 install; no options required changing.

I changed the system path to the new ...\BIN location in the system Path statement.

- You can find the system variables by typing "path" in the "search programs and files" part of the start menu. I choose to copy the entire statement into Notepad and then past it back into the editor.

Update all your shortcuts to the new folder (if you use specific paths). I only needed to change the ...M010... to ...M020....

Update all the icons in the shortcuts (they still point to the M010 which is now missing)...

- hint to finding the icon location: .../Creo 2.0/Parametric/install/nt/parametric.ico

Reinstall all your customized and additional files that belong in the installed folders. Fonts and formats in my case.

REBOOT!

When you start your favorite shortcut, Creo 2.0 will take a bit longer to boot than usual and will install a couple of components. After that, you should be back where you were. If not, you didn't follow my instructions

I know there are other methods; this is the one I chose just to be thorough (considering the pain I went through last time only to find out all this is what I -should- have done according to customer service).

I had to finally install Creo Parametric 2.0 M020 today cause else I wouldn't be able to finish an assembly drawing I was doing in M010.

It kept on crashing when I tried to redefine xsection hatching on some imported components. Moving to M020 resolved the issue.

The uninstallation of M010 went smoothly as well as fresh installation of M020.

What I've noticed is that M020 help installer is twice as large as installer of M010 but I didn't have a time to check if there's any difference yet but I am curious what's there to see.

~Jakub

dveljkovic
6-Contributor
(To:James62)

Crashing while trying to defne cross hatching (in model or drawing modules) was the same issue I had with Creo 2.0 M010. M020 solved this problem. But now, everyhitng is so slow, especially if you have surface model involved instead of solids. I also niticed that M020 uses much more memory. It is so bad that all of my 12 giga is used by Creo. Before 8 giga was all time high.

I attempted to install Creo 2.0 M020 last week....

A fresh install would not run.

so I installed M010, and upgraded to M020. Still Creo would not run.

So at this point, I'm still running M010.....

James62
10-Marble
(To:Daves1)

hi,

Did you wipe the FlexLM licence server installer too during the uninstallation of M010?

Daves1
1-Newbie
(To:James62)

Hi Jakub,

I didn't touch the FlexLM license. The license runs off our server not my local machine.

Thanks for the idea though...

Dave,

can you post some error message or the contents of std.out file (see startup directory) ?

Martin Hanak


Martin Hanák

Martin,

I had to revert back to M010, so the Std.out file from M020 is gone. When I have time to try again, I will send the error messages for you.

M020 just wouldn't run for me. I would start it and nothing would happen, I wouldn't even get the Creo splash screen.

Dave

dveljkovic
6-Contributor
(To:TomD.inPDX)

We switched to Creo 2.0 M020 because M010 was crashing on some of our customer's models while wf4 was working correctly on same models. M020 wasn't crashing (so we were very happy) but now it crashes on everything, by random, constantly. At least, M010 was crashing when we tried to make cross sections in assemblies or assembly drawings so we knew to be very careful not to use it. But M020, you just cannot find a pattern when it crashes. Although I noticed, once, I tried to open the assembly and just before it crashed, in status window it was showing a message about some xpr file. I removed that file and it opened the assembly without crashing. But then, it would crash just when you rotate whole assembly ... Who knows, maybe Creo 102.0 M220 will solve these issues ...

I'm sorry you are having problems with M020, Danilo. I have not had that experience with M020. It seems even more stable than M010 and certainly more stable than F001.

Please submit this to customer support and let us know if you find resolution.

I might suggest updating video drivers as a start. Something seems corrupt.

dveljkovic
6-Contributor
(To:TomD.inPDX)

Already submitted. PTC set priority to LOW. Maybe for them priority is low. For us it is a life or death. But I already know what they will say. Is the system on approved list or is the graphic card on approved list? Or drivers, or anything else? I love this "approved hardware, software, driver list" alibi they have to wash down their hands when their software does not work.

Sounds like a trouble with parts containing family tables.

I've been able to crash M020 only while working in IDD so far but things there have been the same with all the subversion Creo 2.0 and of Creo 1.0 as well so it became predictable to me.

dveljkovic
6-Contributor
(To:James62)

Maybe Creo 2.0 should not aloow to have family tables in assemblies at all. One less reason for crash.

dveljkovic
6-Contributor
(To:TomD.inPDX)

I have found a solution for the problem. Shade_quality was set to 25 instead of default value of 3. Now, everything looks OK memory-usage-wise. Will test further.

Announcements
NEW Creo+ Topics: PTC Control Center and Creo+ Portal