cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Creo 7 - hardware not supported

JohnK55
Regular Member

Creo 7 - hardware not supported

I've just installed Creo 7 & everything went OK, the issue I have is when I attempt to create a new part or open an existing Creo 6 part I get a traceback error then it crashes. 

My software supplier has said it's due to my hardware not being supported by PTC. 

What spec of machine should I be looking at to get it to run or do I wait to see if it will be supported. It runs Creo 6 without any problems.

23 REPLIES 23

Re: Creo 7 - hardware not supported

@JohnK55

 

 

You may try clearing the cache by renaming .wf to something else. Default location for cache is %appdata%\\Roaming\PTC\ProENGINEER\Wildfire

 

If this doesn't work share the traceback to review. 

Re: Creo 7 - hardware not supported

I don't know of any major differences for hardware being supported. The greatest number of issues I see is when a user doesn't have a supported graphics card. Do you have a supported Nvidia Quadro or AMD card? If not you might have been lucky that Creo6 wasn't crashing on the unsupported hardware. I guess in either case I would try updating the graphics driver.

Re: Creo 7 - hardware not supported

It looks as though it's a graphics card issue as it currently only lists Quadro cards & I'm running a GTX 1080

Re: Creo 7 - hardware not supported

I'm running GeForce GTX 1060 and Creo 7 works just fine. I can open old assemblies and parts from Creo 6 and create new parts in Creo 7. 

Please check your drivers. I updated mine just before installing Creo 7. I'm running version 445.87 now.

Re: Creo 7 - hardware not supported

As I have posted many times, the DirectX cards are not supported, but may work.

GeForce cards are DirectX cards. The Quadro series is the OpenGL line of cards.

The higher end GeForce cards do seem to work with out any issues are a lower cost than the Quadro cards.

Re: Creo 7 - hardware not supported

Hi Ben,

I think the question was what will work, not what is officially supported. I think it is a valuable contribution to this discussion that my Creo 7 is working fine with GTX 1060 which is the same GPU generation as John's. From my point of view of a single user, the same GPU that worked with Creo 6 works with Creo 7. I don't believe the GPU hardware is the reason here. Maybe other things to try in addition to updating drivers is to use another working directory, clear caches or make sure the Creo 7 is not trying to use any configurations from any older Creo.

 

Moreover GeForces do support OpenGL:

https://us.download.nvidia.com/Windows/445.87/445.87-win10-win8-win7-release-notes.pdf

 

This release supports the following APIs:

  • Open Computing Language (OpenCLTM software) 1.2 for NVIDIA® KeplerTM and later GPUs
  • OpenGL® 4.6
  • Vulkan® 1.1
  • DirectX 11
  • DirectX 12 (Windows 10)

Re: Creo 7 - hardware not supported

You're right that it's about what will work BUT there is no guarantee that it WILL work with the unsupported cards. I have also seen it work with unsupported cards but I have also seen it not work. Trying newer drivers is really the only thing you can do. 

Also there are different levels of OpenGL support. the cheaper "game" cards only really support PART of the OpenGL standard but the Quadro cards truly support the standard. 

No real fight here and I think Ben would agree, we're not saying it WON'T work but that is likely the source of the issue.

Re: Creo 7 - hardware not supported

I've reinstalled Creo 7 but still have the same issue. Creo starts OK but as soon as I try to create a new part it pauses then comes up with a fatal error

 

Update! I just tried to open an old part, it opened but after a couple of seconds I got a fatal error.

Re: Creo 7 - hardware not supported

What does the Trail file say or std.out?

Re: Creo 7 - hardware not supported

I've attached the trail.txt & the std.out

Re: Creo 7 - hardware not supported

@JohnK55 

 

Couple of points to test as try starting Creo :

1. Without any config files. (No config.pro/Config.sup).

2. Without any external/toolkit applications

3. Clear/Rename the cache, .wf directory, (default location is C:\Users\USERNAME\AppData\Roaming\PTC\ProENGINEER\Wildfire)

 

Also, If you are in active maintenance you can contact PTC Technical Support. 

Re: Creo 7 - hardware not supported

1. I didn't think you could start Creo with config files?

2. As far as I am aware I don't  have any external/toolkit applications

3. Cleared cache.

 

It was PTC tech support (via my software reseller) that told me the hardware was unsupported thats why it won't work.

Re: Creo 7 - hardware not supported

You can run without config files. Very useful when you have issues.

Just rename all config.pro files and config.sup. There could be 3 config.pro files.

One in the Creo 7 text file under the load point.

One in your home directory.

One in your start-up directory.

 

I did see an error in your trail file. IS the Y:/ drive mapped to your computer?

!%CECould not read from Model Tree config file Y:\CreoStandards\tree.cfg.
< 0 2.138074 3399 0 0 1804 3840 0 0 2160 13

 

The traceback error can only be resolved by PTC, but fixing config and the model tree may be the csue of the error.

!MT_CUST - Applied settings for mode # 1 : MT Part Solid
! Message Dialog: Warning
!               : Fatal error encountered. A traceback has been written to
!               : C:\Users\Public\Documents\traceback.log
!               : Please send it to Technical Support.

Re: Creo 7 - hardware not supported

I updated the drivers but it was after I installed Creo 7.0, I think I'll uninstall & reinstall to see if it helps.

This is the display info taken from the System Information window.

JohnK55_0-1587753295174.png

 

Re: Creo 7 - hardware not supported

That is the latest driver alright. I noticed you're using 4k resolution with 30 Hz. Probably you're using some scaling as well. Could any of those trigger a crash? 

Is config.pro option graphics  win32_gdi still valid for Creo 7? That should bypass your GPU and render with CPU. The performance may be poor, but it should eliminate GPU as the culprit.

Re: Creo 7 - hardware not supported

I added the Graphics  win32_gdi into the config but have the same issue.

I haven't changed any graphics settings, it's how the machine was set up when I got it.

Re: Creo 7 - hardware not supported

Do I need a config.pro for each version of Creo I'm running, I currently have Creo 3.0, 4.0, 5.0, 6.0 & 7.0 installed (different client, different version) & I've noticed they all call up the same config.pro, also, Creo 7 seems to have a lot more start up templates than previous versions.

Re: Creo 7 - hardware not supported

There may be some options in config.pro for Creo7 that does not like from older versions.

For debugging, limit yourself to the system installed  config.pro in the <loadpoint/text folder. This one should be delivered and installed by the PTC installation. Any config.pro files in your home or startup folder may have conflicting errors.

Re: Creo 7 - hardware not supported

Hardware notes for Creo 7.0 can be found in attachment.

Re: Creo 7 - hardware not supported

A little update to this issue.

I'm now running an Nvidia Quadro P2200 graphics card & still have the same issue, from what I've now been told, it's not actually a graphics card issue, my HP Workstation is not supported!

It an HP Z420 & apparently hasn't been supported since Creo 5.0 (Creo 6.0 runs fine)

Re: Creo 7 - hardware not supported

@JohnK55, Yes thats correct, HPZ420 is not been tested from PTC and hence its not under the supported platform list. As Creo Parametric 6.0 is working it does not mean that even Creo Parametric 7.0 should run correctly. The graphic card on the machine or something else might not be able to take the load of Creo Parametric 7.0 and hence crashing.

 

You can try the below config option in Creo Parametric 7.0 and see if it helps. Also see creating a new part works fine rather then opening an existing one. Try opening a small part file created in Creo 6.0 as well.

 

  • Run the application with hardware graphics acceleration turned off
    • Set –g:win32_gdi using, press RMB on Shortcut icon of application > Add space and –g:win32_gdi next to *.exe in target path
  • Rename (.wf ) directory
    • Default location of .wf on Windows 7: C:\users\<username>\AppData\Roaming\PTC\ProENGINEER\Wildfire
  • Add config's
    • enable_opengl_fbo  to no
    • enable_opengl_vbo to no
    • enable_opengl_shader to no

Below is the platoform support page for Creo 7.0 just for your reference

https://support.ptc.com/WCMS/files/175339/en/hp_creo7.pdf

Re: Creo 7 - hardware not supported

Creating a new part or opening an existing part has the same result, a few seconds pause then a fatal error appears. The traceback log was sent to PTC who also suggested the opengl configs

I've already tried the opengl configs when I installed the new Quadro Graphics card, they had no effect & the other options messed up the graphics. Had same issue but when running Creo 3.0 panning & zooming with any control was impossible.

 

Re: Creo 7 - hardware not supported

@JohnK55, Try disabling Intel Graphic card on the machine and see if that helps.

Announcements