Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Have a PTC product question you need answered fast? Chances are someone has asked it before. Learn about the community search. X

creo 4.0 won't load and now 3.0 won't either....


creo 4.0 won't load and now 3.0 won't either....

I should have known not to try this on a Friday afternoon......:-(

so I downloaded the files, ran the setup and half way thru Norton showed an error for a file......that i should have written i hit don't allow and setup crashed.

anyway, i restarted the setup but had to do that 3 times with similar Norton file errors but eventually got the program loaded......but it won't start. Quickview does though

well I gave up trying to get 4.0 to start but now my file "lmadmin_ptc" file in services will not start so i can't get my license to start so 3.0 won't start.....I'm fucked.

any Ideas on getting out of this mess? so typical of how I remember PTC.


When I do an upgrade, I always have a PTC tech on the line.

I remember making a support case about that error.

Everyone keeps trying to convince me that it is not a real issue... just Norton's tables are slow to update.

Seems this is going to happened more often that ever before.

Nothing to help with - but I will take the example of why hot-back-ups are valuable to roll back undesired outcomes. That said, I should take my own advice, so I can't be too critical. But if your livelihood depends on the software, always make a back-up, practice restoring the back-up and keep the back-up safe and make a back-up of it as well.

  1. Open the <FlexNet loadpoint>\bin directory.
  2. Run the ptcsetup.bat command.

but there is no ptcsetup/bat file in that directory so I'm still stuck.

I think that System restore only affects the Windows system components; this is supported by:

More About System Restore & Restore Points

The Windows System Restore utility will not in any way affect your non-system files like documents, music, video, emails, etc. If you were hoping that Windows System Restore would in fact restore or "undelete" any deleted non-system files, try a file recovery program instead.

from How To Use System Restore (Windows 10, 8, 7, Vista, XP)

I uninstalled all creo 4.0 and reinstalled, still struggling. I'm going to try the license email that i was sent "again" and see if i can't get this to work.

It's kinda nice that i'm getting feedback so that's much appreciated.

With one caveat, yes... just remove all the programs stuck in windows manually using the Windows Uninstall routine.

Know that FlexLM is a stand-alone function.  Mine was downgraded to like WF4 days because I would loose my license when I put my computer to sleep.

Since your problem is likely the license manager, and somehow your installation was corrupted (since you are missing files), a complete purge and then re-install should get you back where you were.

License files... are you sure you got the NIC address of the physical network card?  Even the routing executable from PTC can report the wrong adapter.  It picked up my wireless router.

Another problem has been that Windows will give devices number like 1, 2, 5, 12, 27.

Funny thing is, priority is given only to the first digit.  So 27 has greater priority than 5.  Same 12 is before 2.  Somehow this caused problems in my Creo 2 install a long time ago.

Also know that Creo, all versions, share the user settings by default,  I do not know how well vetted having Creo 2, 3 and 4 is on the same machine without managing the user setting will affect system usage.

Now you see why I have a PTC tech on hand.  It is never as smooth as others will lead you on for it to be.

Soon, I have to put Creo 4 on a new machine along with Creo 2 and move all my data.  You don't know how much I am dreading this process.

Edit: one last thing, we've also been adding a couple of entries to the search path for Creo.  You might check that it is pointing to the right folders.

step 2. Open the <FlexNet loadpoint>\bin directory.

step 3. Run the ptcsetup.bat command.


the only file close to this is reconfigure which i tried (it's similar to the regular PTC set with same results) and I've also started the regular PTC setup and go to licensing. I add my SO code and then it's ask for log in and after login i get a "success".

step 4. Once the ptcsetup utility loads use the text-box labeled "License File" or the small "folder" button


STEP 5. Click the "Configure" button to continue install the new license.


license summary.

source = 7788@dan-pc  status = unreachable.

and the kicker is every time i reply to this thread i get 6 license file emails but still can't figure out how to get one loaded OR which one to use.



On your PC lmadmin_ptc service is used to manage Creo licence.

Default installation directory is C:\Program Files\PTC\FLEXnet Admin License Server on 64-bit Windows operating system.

Please check, if this directory exists.


license.dat file is located in C:\Program Files\PTC\FLEXnet Admin License Server\licensing directory.

Please check, if this directory exists.


license.dat file must contain following two lines

SERVER nameofyourcomputer PTC_HOSTID=MACaddressofyournetworkcard 7788

DAEMON ptc_d "C:\Program Files\PTC\FLEXnet Admin License Server\i486_nt\obj\ptc_d.exe" "C:\Program Files\PTC\FLEXnet Admin License Server\licensing\ptc.opt"

Please check, if these lines exist.


Martin Hanák

directories exist but license.dat file is missing

ptc.opt file is in the directory.


if I understand your previous responses well, then you received license file via email. Therefore you can save license file from email into C:\Program Files\PTC\FLEXnet Admin License Server\licensing\license.dat file and modify SERVER and DAEMON lines as described below:

license.dat file must contain following two lines

SERVER nameofyourcomputer PTC_HOSTID=MACaddressofyournetworkcard 7788

DAEMON ptc_d "C:\Program Files\PTC\FLEXnet Admin License Server\i486_nt\obj\ptc_d.exe" "C:\Program Files\PTC\FLEXnet Admin License Server\licensing\ptc.opt"

After file modification, restart lmadmin_ptc​ service.


Martin Hanák

Here's what I recommend:

  1. uninstall flexnet from the system.
  2. From your Creo 4 software install disk or folder, run the setup.exe
  3. In the installer window, uncheck the Creo software and pick to install the licensing software.
  4. If your server shows unreachable, remove that by picking the minus button.
  5. You should now have a empty field for the server. At this point drag and drop the license file you got from PTC into this field. It should say installing.
  6. Once the install is finished, Open a command shell and cd to this folder: C:\Program Files\PTC\FLEXnet Admin License Server\bin
  7. type ptcstatus
  8. You should get a listing of how many licenses are in use and not in use. If you see the word counted, that's bad.
  9. If your Creo software still doesn't run, go to the parametric\bin folder and run the reconfigure command and make sure it is pointing to the correct server.

The other issue you may run into is the type of license you have may have changed. So Creo 3 could be looking for a license feature that doesn't exist in your new license file. In that case you need to edit the license configuration.

See attached for more information on licensing.

NEW Creo+ Topics: PTC Control Center and Creo+ Portal