cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Cant connect Properties to Thinworx Composer on Raspberry

SOLVED
Highlighted
Regular Member

Cant connect Properties to Thinworx Composer on Raspberry

 

Hello Guys, 

and thank in advance for your help. 

I am trying  to connect a Raspberry Pi 3 to Thingworx using the EMS 5.4. 

I am able to autobind in the config.json file but if im trying to bind it via LSR its not connecting. 

Also the Properties dont get connected. 

config.json

{ 
	"ws_servers":	[{
			"host":	"172.20.1.18",
			"port":	80
		}],
	"appKey":	"xxxxx",
	"http_server" : {
		"host": "localhost",
		"port": 8085,
		"ssl": false,
		"authenticate": false
	},
	"logger": {
		"level": "INFO"
	},
	"auto_bind":  [{
		"name": "Am2302Thing",
		"gateway": false
	   }],
	"certificates":{
		"validate": false,
		"allow_self_signed": true
	},
	"ws_connection":{
		"encryption": "none", 
		"verbose": true, 
		"msg_timeout": 1000
        }
	
}

config.lua

scripts.log_level = "DEBUG"

scripts.Am2302Thing = {
	file = "thing.lua",
	template = "Am2302Template",
	identifier = "2302",
	scanRate = 10000,
	TaskRate = 300000
	}

scripts.rap_host = "localhost"
scripts.rap_port = 8085

scripts.rap_ssl = false


scripts.rap_server_authenticate = false

scripts.script_resource_host = "localhost"
scripts.script_resource_port = 8086

scripts.script_resource_ssl = false

scripts.script_resource_authenticate = false

screenshot.pngscreenshot2.png

Greetings Niels screenshot2.png

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Cant connect Properties to Thinworx Composer on Raspberry

Hello.

 

This is a known issue with EMS 5.4 and a bug has been reported.

 

The suggested workarounds for the time being are to either enable SSL in EMS 5.4 using TLS encryption or to downgrade to EMS 5.3.4.

 

Thanks,

 

-- Craig A.

2 REPLIES 2

Re: Cant connect Properties to Thinworx Composer on Raspberry

Hello.

 

This is a known issue with EMS 5.4 and a bug has been reported.

 

The suggested workarounds for the time being are to either enable SSL in EMS 5.4 using TLS encryption or to downgrade to EMS 5.3.4.

 

Thanks,

 

-- Craig A.

Re: Cant connect Properties to Thinworx Composer on Raspberry

Hello Craig,

 

its now working because i am using the EMS 5.3.4.

but out of curiosity how should i configure my files to enable SSL, because i think i tried it too but it didn´t work.

 

Thanks for your Help

Greetings Niels