Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to Learn more.

Coupling Mashup with Digital Twin


Coupling Mashup with Digital Twin



I have a technical question.

Here is the summary of what I am doing: I have an ANSYS Twin Model Connected to PTC on ANSYS Twin Builder using PTC Connector. The twin model has 1 input and 3 outputs. I was approaching the problem on 2 phases:

1- Using PTC "Thing" I can change the input, and the output change and I can see the update on the Mashup working fine (not continous update ofcurse)

2- Now, to make the work more realistic, I need to connect the physical model, to the twinbuilder to PTC. I origionally can run my physical twin using a Python code, and I can see the changes on the twin model.

I updated the Python code, so it connect to PTC and run the work. which seems to work. However, the issue here is the updates I see on the twin builder and on the python code, I do not see on the mash up.


I am connecting the gagues in the Mashup using the getproperties and setproperties. Am I missing somethig here that is needed as I am attachimg the physical model?


Please advise



I am not familiar with ANSYS digital twin. So, I will try to help you on the ThingWorx part. In the mashup builder, if you click GetProperties, you will see under Data Properties tab there is a check box for Automatically update values when able. Could you please check this and test?






Thanks for your input.  I tried what you suggested, but it did not worl. Actually it affected the Mashup Gauges for the output and it shows nothing now. 

BTW, in my mash up, I have a numeric Entry to manually enter the input, do you think I should remove that now?



I have a nother question, I am trying to add to my mashup the data coming from a power supply (the current I set and the output voltage). Do I need to create a special 'Thing" Or another tool should be used for this purporse.



Could you please provide an export of your Thing and the mashup? 

Sure. Please find them attached.

Thanks a lot.


While I could not test it as Spiral_PTC_Templete was missing, the mashup seems fine to me. I believe you would want GetProperties to be executed as soon as the mashup loads. If this is the case then please bind the loaded(hover at top right corner of mashup) event of mashup to GetProperties. You could also have done this while adding GetProperties to Data tab by checking the checkbox Mashup Loaded?. Also, you could test after removing the auto refresh binding with GetProperties when Automatically update values when able is checked



I have another question came up. As my Cloud trial will expire tomorrow, so I am moving to Local installation as adviced by Mark.


I succefully installed the PTC Thingworx locally, and I exported my project but when I import it to the new system, it fails. I tried to export seprate components, I was able to import the mashup, the templete, but it fails when I import the thing.  you can see in the attcahed image the error message I get.  Any advise on how to figure this issue and how to fix it?



I am unable to see the full error message from the screenshot. Could you please share ApplicationLog.log file? It will be in ThingworxStorage\logs folder.

Sure. Here it is.

For the records, my cloud trial ends today. 

I see this error

Unable to process import java.lang.ClassNotFoundException: com.thingworx.extensions.cse.ProtocolAdapterSubsystem


I believe ProtocolAdapterSubsystem is part of Connection Services Extension(CSE). Is it possible that your trial version had this extension and your new instance does not have this? Also, what is the  ThingWorx version of your trial instance and your new instance?

Hi @rjanardan 


The trial version is:  8.5.1-b64


The new local version is: Thinworx 9.0.0-b9557


And this is possible that I do not have it as my trial version included some projects I did not create.




I looked for the file  ProtocolAdapterSubsystem  and I found it in the old one. but I can not delete it. It is not part of my project but seems to be included .

Import the extension CSE in your new instance and then try importing your entities. Probably this was installed on your trial instance as part of Azure IoT Hub connector.

I do not know how to import these files you mentioned as I did not add them to my old work.


But now as my trial is expired, I am trying to rebuild my work on thenew local platfiorm. I can not import my old work so I am trying to redo it, but I can not see the ANALYTICS Section. I installed Analytics platform but I do not see it. As you see in this photo. Any guidance here will be highly apppreciated.




Hi @Ghandour 


To see the Analytics icon you need to installed the ThingWorx Analytics Extension that you can find on the PTC Software Download page under product ThingWorx Analytics.

Make sure to install the extension compatible with your version of ThingWorx.


Kind regards


Top Tags