cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Eclipse - Importing Entities as XML in the project.

Highlighted
Regular Member

Eclipse - Importing Entities as XML in the project.

I have been trying to import entities that were made in the composer to the extension project that I am building in Eclipse, Now when I import them in Eclipse they do show up under the entities folder on the project.

But when I create the extension from eclipse and I import the zip file in the composer everything goes well but the entities that were  imported into the project are not created in the composer. Only the entities that are part of the java code in eclipse are created in the composer. Is there a way for me to import entities as XML in Eclipse and have the them be part of the extension so when ever the extension is imported into Composer the entities are created? 

 

Appreciate any pointers as I am stuck at a dead end here.

4 REPLIES 4
Highlighted

Re: Eclipse - Importing Entities as XML in the project.

@nkhoja 

 

Did you check to see if those entities got zipped up with the rest of the files?  Additionally, there's information on page 12 at this link regarding the folder structure ( https://www.ptc.com/support/-/media/support/refdocs/ThingWorx_Platform/8,-d-,3/thingworx_extension_d... )

Highlighted

Re: Eclipse - Importing Entities as XML in the project.

@nmilleson 

 

Yes, I am attaching the screen shot of the zip file and it does show me the entities as One XML file, But I feel these should be separate. Each entity should be a separate XML file. What am I doing wrong? I am following the same PDF that you referred to in the post. Appreciate your help, If you want I can create a case so that you and I could have a one on one call to get this sorted promptly  

nkhoja_0-1601068327789.png

 

Highlighted

Re: Eclipse - Importing Entities as XML in the project.

@nkhoja ,

 

I don't work for PTC, just a community member.  Two things I would try just to narrow down the problem:

 

1.  Your screenshot above looks like you are putting the entity files into /Entities/Downloads/ ... should those be just in the /Entities/ folder?

2. I would try just a single entity as a test.  I haven't tried importing an xml in an extension using more than one entity per xml file

 

If that doesn't work, you can check your application log.  I've gotten a "Successful Import" message before and still found errors in the Application Log.  

Highlighted

Re: Eclipse - Importing Entities as XML in the project.

Hey @nmilleson .

 

Oops sorry, I have only gotten replies from PTC employees in the past. My bad.

 

So I did try moving the entities to the /Entities folder and got the same result. 

Tried debugging things from the application log and I resolve one problem another one comes up.

If I create an entity using the java script and import that it works fine, It's only with the ones where I take a bunch of entities

 

 Invalid content was found starting with element 'ThingGroups'. One of '{Subsystems, ThingShapes, Resources, DataTags, NotificationContents}' is expected.

 

This is what I got now lol, before it " one of the Content element ' Extension Package' cannot be empty" 

 

 

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum!