cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - You can subscribe to a forum, label or individual post and receive email notifications when someone posts a new topic or reply. Learn more! X

Error Executing Event Handler 'ForwardEvent'

AliBenBelgacem
14-Alexandrite

Error Executing Event Handler 'ForwardEvent'

Hello

I have a mashup with a led widget. I use getproperties to get the value and i am activating the auto update values from mashup

 

I have a weird behavior :

When i change the value manualy from the thing the property is updated automaticaly on the mashup (no problem)

When the value is changed from subscription function , the value is changed in the thing but  the led value still not changing and i have this error on the log monitor :

Error Executing Event Handler 'ForwardEvent' for event Type.Thing:Entity.MyThing:Event.DataChange

I get the value only when i refrech manualy the page.

the auto refresh widget does not exist so i have no other alternative.

 

I search in all the topics in the community but none is a solution : 1 here  and 2 here 

 

My thingworx version is :9.1

 

My code work perfectly on 9.3 version

 

Any help is welcome.

 

Thank you.

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Weirdly, it was a licence issue. we re installed the licence and it's esolved

View solution in original post

7 REPLIES 7

@yhan Please take a look.

Hi @AliBenBelgacem,

I can't comment about why this happens, but can you please add which ThingWorx versions you refer to? You mentioned only the major and minor versions in the original post, but it is not enough to detect where the change might have happened, since we have 15 "9.1" releases and 6 "9.3" releases.

I suspect a bug that was fixed, but that's the most I can say from what you mentioned.

Hi,

the version used id : ThingWorx 9.1.0-b10877

 

Br 

Ali

Hi @AliBenBelgacem , and the ThingWorx version where this works is 9.3.(which patch version).?

sorry,  ThingWorx 9.3.0-b20

Weirdly, it was a licence issue. we re installed the licence and it's esolved

Hi @AliBenBelgacem 

 

This isn't indicative of a licensing issue.  Did you perhaps change permissions?

 

Regards.

 

--Sharon

Top Tags