cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Issues in Establishing connection between ThingWorx foundation and ThingWorx Industrial Connectivity

Contributor

Issues in Establishing connection between ThingWorx foundation and ThingWorx Industrial Connectivity

I have installed thingworx foundation downloadable trial version one machine and thingworx industrial connectivity on another machine.

 

I am following below guide while establishing connection between thingworx foundation and thingworx industrial connectivity

https://developer.thingworx.com/en/resources/guides/thingworx-industrial-connectivity-guide

 

This guide assumes that you are utilizing the hosted Foundation server in combination with the downloadable Industrial Connectivity. It also mention that some instruction requires modification in case of "downloadable Foundation trial".

In my case the above mentioned guide does not work. I am not sure what are the steps which required modification in case of hosted foundation server.

Please let me know if any one had tried the same for hosted Foundation server.

I am also attaching the connection settings for thingworx industrial connectivity and error I am getting while establishing connection between foundation and industrial connectivity.

 

2 REPLIES 2

Re: Issues in Establishing connetion between thingworx foundation and ThingWorx Industrial Connectiv

@cgoma  The guide you referring is correct and you can refer this page in help center too. 

 

1. Could you disable "Trust self-signed Certificates" & "Trust all certificates" and try?

2. Is the Application Key (appKey) a valid one created on your server and not expired? 

 

The following logs may provide more insight into the cause of your issues:

 \ThingworxStorage\logs

<tomcat_home>\logs

 

Thanks,

Vibhuti

You may refer to this article for more information.

 

 

Re: Issues in Establishing connetion between thingworx foundation and ThingWorx Industrial Connectiv

Hi @cgoma,

 

Have you found a solution to your problem?  If so, we would appreciate if you would post it here for the benefit of others with the same issue.

 

-Vibhuti