cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you get an answer that solved your problem? Please mark it as an Accepted Solution so others with the same problem can find the answer easily. X

SQL database connectivity issue

VaibhavShinde
16-Pearl

SQL database connectivity issue

Hi,

I am not getting any error in logs,specific to Database configuration but still i am unable connect to the SQL Database.

i already worked with this Database, but this system is different so i am trying to connect. please see below snaps which i configured.

VaibhavShinde_0-1594038191977.png

Instead server name i tried putting 'localhost', 'ip Address' but still not.

 

Thanks

4 REPLIES 4

Hi @VaibhavShinde 

 

Your connection string is missing the port number, by default 1433 - it might not work if you changed that default port.

Also you need to ensure that SQLServer is configured to serve a static TCP/IP port, see https://www.ptc.com/en/support/article/CS263390.

 

Hope this helps

Regards

Christophe

 

Hi @cmorfin ,

I tried both by putting 1433 as port and enabling TCP/IP or Enabling all ip ,also enabled named pipe.

but still not connecting..and still not getting any related error.

 

VaibhavShinde_0-1594105302087.png

Thanks,

Hi @VaibhavShinde 

 

Two other thigns to check/try:

- make sure the firewall on both machine is not blocking communication. If possible do a test by stopping both firewall

- in your database thing, create a test SQL service  with a simple select * from <tableName>, replace <tableName> by a small table existing in your database.

Execute the service - this should give some additional error that could give some hints.

 

Regards

Christophe

 

Hi @VaibhavShinde.

 

If one of the previous responses allowed you to resolve your issue, please mark the appropriate one as the Accepted Solution for the benefit of others with the same issue.

 

Thank you for participating in our community!

 

Regards.

 

--Sharon

Top Tags