Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Need help navigating or using the PTC Community? Contact the community team. X

Thingworx Foundation 9.2.0 Install Error


Thingworx Foundation 9.2.0 Install Error

 I was unable to install ThingWorx Foundation 9.2.0. It crushed and give no clue why it cannot finished install.

The entire folder will be deleted even before I press Accept button. The log is attached below. 

The java version is 11.0.12. JAVA_HOME = C:\Program Files\Java\jdk-11.0.12; Path: %JAVA_HOME%\bin




Hello @KW_9996225 


Are you running the installer by checking the SSL configure checkbox?. If yes you can also skip checking that once and run the installer and SSL can be configured later once installation is done.


Apart from it you can also refer following article to resolve the issue


Let me know if it didn't resolve the issue or you have any further concern.



Om Dukiya


No, I just skip the SSL setting.


I checked that there is only one JAVA 11.0.12. And I also try to the second method to delete the license.bin but unfortunately I still failed to install.

Some versions, including 9.1.3, 9.1.4 and 9.2.0 date codes, have been pulled out and  temporarily removed from the downloads.


It's probably due to security concerns and most likely not related to your issue, but mentioning it just in case...

I've never encountered anything similar and actually only installed Thingworx using installer just once, so can only provide somewhat educated guesses.


1) First of all, have you tried to install on another machine? I always try to do it just to see if the issue is reproducible and/or tracks from previous installations don't interfere.

Installing on another machine (which are usually VMs these days) quite often succeeds so you can forget about the initially failed installation. I'm not a big fan of trying to poinpoint the cause of a random issue which only appears once and is not reproducible.


2) There are two lines of interest in the bitrock_installer_16884.log - the first one reports an error and the second one mentions the location of the additional log file. Is this log file available or gets deleted before you can get it? And can you attach / share the "C:\Program Files (x86)\ThingWorxFoundationH2Trial/ThingworxPlatform/platform-settings.json" file?


Error running C:\Program Files (x86)\ThingWorxFoundationH2Trial/installer/functions_files/json/read_json "-configfile=C:\Program Files (x86)\ThingWorxFoundationH2Trial/ThingworxPlatform/platform-settings.json" "-jsonpath=PlatformSettingsConfig.LicensingConnectionSettings.timeout": 2021/07/26 17:03:31 PlatformSettingsConfig.LicensingConnectionSettings.timeout does not exist
[18:03:31] Wait 560s for /\[[^\]]+Thingworx.war\][^\n]*\[[^\]]+\]/ in "C:\Program Files (x86)\ThingWorxFoundationH2Trial\tomcat\current\logs\thingworx-foundation-stderr.2021-07-26.log"


This seem to trigger aborting installation - the next line starts aborting installation


[18:07:36] Executing abort action : ccif_start_post component



3) A general note... You may call me old-fashioned and overcautious, but I try, whenever possible, to avoid installing stuff into folders containg spaces - nowadays it's usually OK, but I still encounter issues now and then with different software when using spaces in folder names.

This time I install it in another place whose name get no space in it. Still failed. I may try on another mechine, thank you for advice.

Well.... I believe I now see the possible cause and I think I've encountered something similar before...

So, platform-settings.json indeed doesn't have the PlatformSettingsConfig.LicensingConnectionSettings.timeout and Thingworx defaults to 560s

[18:03:31] Wait 560s for

Duing the installation you're supposed to automatically get the trial license from the PTC's licensing service, but the licensing generation server seem to not to respond promptly, so installer waits for the license, but times out somewhere around 240s (multiple "[18:xx:xx] waiting 5s" lines in the bitrock_installer_16884.log ).


Do you have something like "Configure licensing later" on one of the installation steps to try to skip this part?


I've encountered issues with automatically requesting / generating licenses (during startup, not installation, since I normally install manually, not using installer), but I've just tried to automatically get license (during Thingwox startup) and got one promptly, so, at least for commercial licenses, licensing generation service seem to work correctly at the moment, so my assumption about the root cause of your issue may be wrong.

No, there is no way to skip the licensing part but I do find license.bin in Folder:ThingWorxPlatform. Is this the license I need? It's 4kB large. 

And I also find that in thingworx-foundation-stderr.2021-07-27.log (The filename appear in Waiting 560XXXX)there is only one line: Apache Commons Daemon procrun stderr initialized. But I found in other's computer of who successfully install the Foundation that there are more lines there.

Is the Tomcat malfunction? I manually run startup.bat and the window last for a few minutes then closed. The screenshot below is captured the moment it ready to close. Is it normal? Or it shows other cause of install failure?


The license file is normally named "successful_license_capability_response.bin". License.bin used to work before, but I'm not sure about current status.

You can try to make a copy and name it "successful_license_capability_response.bin", just to test, but I wouldn't count on this.


The main source of startup information and issues is the ApplicationLog.log file in the ThingworxStorage\logs folder.

Check what's there and share it.

I try to install mannally and I got this error:

ERROR in ch.qos.logback.core.joran.spi.Interpreter@3:88 - RuntimeException in Action for tag [contextListener] com.thingworx.exceptions.ConfigurationException: java.lang.RuntimeException: Failed to create SecurityManager, Failed to load SecretProvider 

What could it mean?

If I understand correctly, it's from Tomcat logs, and Thingworx logs don't get created yet.

I'd guess, especially considering you're doing a manual install, you don't have the THINGWORX_PLATFORM_SETTINGS environment variable. Create it and set the value to the folder containing platform-settings.json (D:\AB\Foundation in your case? Or a different folder, if you install to a new location)


You'd likely need a few more settings, and I usually add them all into the <Thingworx>\bin\setenv.bat file.

I've atached a sample of such a file.

Eventually I install the Foundation manually and I finally see the interface. Thank you for your advices and I have to say that there must be so many error. For example, it always say Access denied just because the program can't access JVM so I copy two dll: msvcp140.dll, vcruntime140.dll. And the json file do have some error so I take your advice to set the system variable.  If the installer failed I suppose that install manually will be the only solution.


@KW_9996225 , it seems to me that you are trying to install Trial version of Thingworx 9.2 and the installation failed when it tried to connect license server. As @DmitryTsarev mentioned, 9.2 is not available at this moment till about Aug.9th. I would suggest to hold on it till 9.2 is downloadable if the project is not very urgent. When the new installer is available, please execute it as "Run as Administrator" .  If the issue happens again, please provide the installer log as well as the platform-settings.json.

Top Tags