Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Want the oppurtunity to discuss enhancements to PTC products? Join a working group! X

Thingworx installation error


Thingworx installation error

Hello. Can anybody help me with installation of Thingworx trial edition? I`m trying to install it on PC with windows 10. Required java 8 and postgreSQL 9.6 are already installed and defined in Path. The installation stops at the last seconds of process, when system tries to unpack files and get access to the package.

Maybe, someone knows what to do to solve this problem?


Hello @DD_9594739,


Installation errors with installer usually occur when the JAVA_HOME environment variable is not defined correctly. Please ensure the JAVA_HOME variable is pointing to C:\Program Files\Java\jdk1.8.x_xxx\. From your logs,it seems like you installed a JRE and not a JDK.


JAVA_HOME variable is pointing exactly to the jdk folder. Screenshot is attached.

Before installing, check that you have installed 64 bit Java, and confirm ‘keytool’ is available on your path. The default Oracle Java installation does not put keytool on your path.


Be sure that Windows Defender - Real-time protection is turned off.


Below are some additional troubleshooting steps.
ThingWorx unable to start:
1. A ThingWorx trial was previously installed on this machine and the trial period has expired.
2. ThingWorx was unable to open server port 8443 due to insufficient permission or an already running process.
3. ThingWorx was unable to write to required directory locations.
4. Anti-virus software may have prevented ThingWorx from starting
Installer script could not connect to ThingWorx:
5 Anti-virus or Firewall software prevented the installer from connecting.
6 ThingWorx took to long to start and the installer timed-out.
7 The SSL cert is not where either the install script or ThingWorx Foundation expects it to be located.

Well, nothing helped.

1. ThingWorx platform is absolutely new to me, I didn't install it earlier/

2. Server port 8443 is free, I checked it.

3. Due to installation process I checked the folder for ThingWorx, the system created it.

4. I tried to switch off the antivirus. It didn't help.

5. I also tried to switch of Firewall.

6. I don't really know how to check this.

7. I didn't use SSL cert due to installation.

Have you tried using this guide:


Some things to double check:

  1. You are using 64 bit Java JDK
  2. You have modified you PATH variable so that the command 'keytool' works from a command line prompt
  3. You have turned off Windows Defender live protection
  4. You are not trying to re-install on a machine that had an expired trial 

The installer works for new Azure VMs




23-Emerald II

Hi @DD_9594739.


If one of the previous responses allowed you to find a solution to your problem, please mark the appropriate one as the Accepted Solution for the benefit of others in the community.





Top Tags