cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you know you can set a signature that will be added to all your posts? Set it here! X

Widgets don't appear in runtime

JulianaGuerra
11-Garnet

Widgets don't appear in runtime

Hello! I'm currently working with Thingworx v8.5 and experiencing some issues with Mashups. As I'm adding widgets to the design it's all working as expected in the mashup builder, however, once I select "View mashup" some widgets don't appear in runtime. I tried with different widgets in the mashup and experienced the same problem with many of them.
This is not a problem regarding imported widgets since this is happening with the native widgets. There are no errors on the logs.
How can I solve this problem?
TWX_mashup.png
15 REPLIES 15

Hi @JulianaGuerra.

 

If you're running 8.5, it's recommended that you upgrade to one of the patch releases.  A number of issues were corrected with widgets in 8.5.1, but 8.5.5 is due to be released today, so I would wait for that one.

 

Also, you may want to test under a different browser to see if the behavior is consistent.

 

If you still have problems, please provide us with the mashup and other entities for recreating the issue, and we will take a closer look.

 

Regards.

 

--Sharon

 

 

Hi,

 

Do you have Enable Beta Widgets active in Platform Subsystem? 

 

raluca_edu_0-1588060044333.png

Regards,

Raluca Edu

Unfortunately, it didn't solve the problem as the widgets still don't appear. But thanks for the suggestion!

Can you see any error in Application.log? Or in Developer Tools in browser?

Hi,

I work with Juliana.
Answering your question, unfortunately, no error message is displayed in the logs (ApplicationLog, ScriptLog, ScriptErrorLog, etc.), or in the Developer tools browser. I tried to reproduce the error, while tracking the logs (using tail), but I didn't identify anything.

Hi @Constantine.

 

When doing a fresh install of 8.5+, we're not seeing the beta widgets.  Did you perform an upgrade from an earlier major/minor release?

 

Regards.

 

--Sharon

Hello @slangley,

 

We don't see Beta widgets in the Mashup editor either, but the "Enable Beta Features" checkbox is still available on the PlatformSubsystem, as of 8.5.4. I was just wondering what it does (if anything).

 

Regards,
Constantine

slangley
23-Emerald II
(To:Constantine)

Hi @Constantine.

 

The decision was made to leave the toggle for this feature in place for future use.  It currently does not provide any functionality.

 

Regards.

 

--Sharon

Hello @raluca_edu,

 

Are those beta features described somewhere?

 

/ Constantine

If I understand it correctly, themable widgets are out of beta in 8.5, but the option is still there as of 8.5.4. Looks like there's something else...

slangley
23-Emerald II
(To:Constantine)

Hi @JulianaGuerra & @williammarinho.

 

Did you confirm exactly which patch level of ThingWorx 8.5 you are running?  If you're still on 8.5.0, it is best to upgrade due to the many bug fixes that are included in the latest releases.  Once you have done so, please re-assess for the problem.

 

Something else that could be causing the issue is the existence of custom extensions or old Marketplace extensions that are not compatible with 8.5.

 

Regards.

 

--Sharon


We updated our server to version 8.5.5-b130. Now, as ptc images and ptc labels are shown correctly. But, some extension widgets, which worked before, are still missing at runtime.

No messages are found in the logs. I checked the server logs, and the developer tools.
When I inspect the generated HTML, the container that should contain the widget is created, but without any children.
image.png
In Debug info, the binding is shown correctly.
image.png

Hi @williammarinho.

 

I recommend opening a case for your issue.  Please let me know if you would prefer that I open it for you.

 

Regards.

 

--Sharon

Hi @williammarinho and @JulianaGuerra.

 

Just wondering if you opened a case for the issues you were experiencing with the missing widgets.  If so, please either provide the case number or the solution if the case has been resolved.

 

Regards.

 

--Sharon

Top Tags