cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

getting error after running "sudo ./luaScriptResource"

AkshayKumar
10-Marble

getting error after running "sudo ./luaScriptResource"

pi@raspberrypi:~/microserver $ sudo ./luaScriptResource

[INFO ] 2017-09-11 14:10:20,284 ./luaScriptResource: Using config file: /home/pi/microserver/etc/config.lua

[FORCE] 2017-09-11 14:10:20,284 ./luaScriptResource: Starting up ....

[INFO ] 2017-09-11 14:10:20,291 ./luaScriptResource: New path is /home/pi/microserver/etc/thingworx/clibs:/home/pi/microserver/etc/custom/clibs:/home/pi/microserver/etc/community/clibs:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

[FORCE] 2017-09-11 14:10:20,313 httpServer: starting http server port=8001

[INFO ] 2017-09-11 14:10:20,397 thingworx.shape: Creating a new shape.

[INFO ] 2017-09-11 14:10:20,399 PiThing: -- Configuration -------------------------------

[INFO ] 2017-09-11 14:10:20,400 PiThing: scanRate: 1000

[INFO ] 2017-09-11 14:10:20,400 PiThing: scanRateResolution: 500

[INFO ] 2017-09-11 14:10:20,400 PiThing: taskRate: 30000

[INFO ] 2017-09-11 14:10:20,401 PiThing: keepAliveRate: 60000

[INFO ] 2017-09-11 14:10:20,401 PiThing: requestTimeout: 15000

[INFO ] 2017-09-11 14:10:20,402 PiThing: registerRate: 43200000

[INFO ] 2017-09-11 14:10:20,402 PiThing: register: true

[INFO ] 2017-09-11 14:10:20,402 PiThing: getPropertySubscriptionOnReconnect: false

[INFO ] 2017-09-11 14:10:20,403 PiThing: maxConcurrentPropertyUpdates: 100

[INFO ] 2017-09-11 14:10:20,403 PiThing: defaultPushType: VALUE

[INFO ] 2017-09-11 14:10:20,403 PiThing: useShapes: true

[INFO ] 2017-09-11 14:10:20,404 PiThing: identifier: Not Specififed

[INFO ] 2017-09-11 14:10:20,404 PiThing: ------------------------------------------------

[INFO ] 2017-09-11 14:10:20,406 thingworx.template: Adding shape 'shapes.metadata' to template 'thingworx.template'

[INFO ] 2017-09-11 14:10:20,407 thingworx.template: Adding shape 'shapes.propsubscribe' to template 'thingworx.template'

[INFO ] 2017-09-11 14:10:20,409 thingworx.template: Creating new templates.PiTemplate named 'PiThing'

[INFO ] 2017-09-11 14:10:20,410 PiThing: -- Initializing properties ---------------------

[INFO ] 2017-09-11 14:10:20,411 PiThing: Initialized property upToDate [baseType: BOOLEAN, pushType: NEVER, handler: nil, value: true]

[INFO ] 2017-09-11 14:10:20,412 PiThing: Initialized property cpu_volt [baseType: NUMBER, pushType: ALWAYS, handler: nil, value: 0]

[INFO ] 2017-09-11 14:10:20,412 PiThing: Initialized property cpu_temperature [baseType: NUMBER, pushType: ALWAYS, handler: nil, value: 0]

[INFO ] 2017-09-11 14:10:20,413 PiThing: Initialized property cpu_freq [baseType: NUMBER, pushType: ALWAYS, handler: nil, value: 0]

[INFO ] 2017-09-11 14:10:20,413 PiThing: ------------------------------------------------

[INFO ] 2017-09-11 14:10:22,384 PiThing: -- Starting script --------------------------

[INFO ] 2017-09-11 14:10:22,384 PiThing: Registering core callback handler

[INFO ] 2017-09-11 14:10:22,385 PiThing: Starting main loop

[INFO ] 2017-09-11 14:10:22,385 PiThing: Calling lifecycle start listeners.

[INFO ] 2017-09-11 14:10:22,385 shapes.propsubscribe: Initialized

[INFO ] 2017-09-11 14:10:22,386 thingworx.handler: Creating a new handler.

[INFO ] 2017-09-11 14:10:22,693 PiThing: MicroServer is now available.

[INFO ] 2017-09-11 14:10:22,694 PiThing: MicroServer is online.

[INFO ] 2017-09-11 14:10:22,694 PiThing: Successfully registered PiThing with MicroServer.

[INFO ] 2017-09-11 14:10:23,53 PiThing: Error occured while accessing EMS. Checking isConnected.

[INFO ] 2017-09-11 14:10:23,57 PiThing: EMS is available: true, online: true

[INFO ] 2017-09-11 14:10:23,57 PiThing: Attempting to GetPropertySubscriptions from server failed. code: 500, result:

[INFO ] 2017-09-11 14:10:23,381 PiThing: Error occured while accessing EMS. Checking isConnected.

[INFO ] 2017-09-11 14:10:23,385 PiThing: EMS is available: true, online: true

[INFO ] 2017-09-11 14:10:23,385 PiThing: Attempting to GetPropertySubscriptions from server failed. code: 500, result:

[INFO ] 2017-09-11 14:10:24,698 PiThing: Error occured while accessing EMS. Checking isConnected.

[INFO ] 2017-09-11 14:10:24,701 PiThing: EMS is available: true, online: true

[WARN ] 2017-09-11 14:10:24,702 thingworx.server: Could not set properties on server. code: 500, resp:

[INFO ] 2017-09-11 14:10:26,536 PiThing: Error occured while accessing EMS. Checking isConnected.

[INFO ] 2017-09-11 14:10:26,540 PiThing: EMS is available: true, online: true

[WARN ] 2017-09-11 14:10:26,541 thingworx.server: Could not set properties on server. code: 500, resp:

[INFO ] 2017-09-11 14:10:28,329 PiThing: Error occured while accessing EMS. Checking isConnected.

[INFO ] 2017-09-11 14:10:28,333 PiThing: EMS is available: true, online: true

[WARN ] 2017-09-11 14:10:28,333 thingworx.server: Could not set properties on server. code: 500, resp:

[INFO ] 2017-09-11 14:10:30,638 PiThing: Error occured while accessing EMS. Checking isConnected.

[INFO ] 2017-09-11 14:10:30,642 PiThing: EMS is available: true, online: true

[WARN ] 2017-09-11 14:10:30,643 thingworx.server: Could not set properties on server. code: 500, resp:

I am getting error while setting properties, please suggest me where i went wrong ,,Thank you..

5 REPLIES 5
Gowresh_R
5-Regular Member
(To:AkshayKumar)

Hello,

 

Have you rectified this error? I am getting the same error. Would appreciate any help.

Gowresh_R
5-Regular Member
(To:AkshayKumar)

Hello,

Have you rectified this error? I am getting the same error. Would appreciate any help.

Hi,

 

Please check your lua code, it might be an error in the code preventing the properties update.

Could you show us config.lua, config.json and other files containing your code?

 

Thanks,

Raluca Edu

Gowresh_R
5-Regular Member
(To:raluca_edu)

Thank you for your reply. Here are my files.

Gowresh_R
5-Regular Member
(To:raluca_edu)

My problem was solved. It was a small beginner's mistake. I failed to understand the concept that both the executable (wsems and luaResources) have to be run simultaneously. Running them fixed the issue.

 

Thank You.

Announcements