cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

numeric entry widget not setting default value

Highlighted
Participant

numeric entry widget not setting default value

I have a numeric entry widget that is not setting the default value I pass to it because it is saying that it is out of range from the min value set. But this is not true, my default value is 24 it is within the min and max (the max and min change based on what question you are on). I try the "hardcoded" way and set values that work but still get the same issue. Anyone have any idea what is going on. It works as expected sometimes and other time not. 

 

Not Working

WL_9354361_0-1598297046969.png

WL_9354361_1-1598297070892.png

WL_9354361_2-1598297100277.png

 

8 REPLIES 8
Highlighted

Re: numeric entry widget not setting default value

You may not be showing enough information.

Min and Max are both showing bound, what values are you providing for that from where?

and then you aren't showing the default value property either.

Highlighted

Re: numeric entry widget not setting default value

WL_9354361_0-1598372851325.png

This is the configuration basically if first checks to see if the user answered the current question already. If they did put their response else display the default value (I have a table of questions with default, min and max  and another table of responses). And the min and max values are the source that is being display above the numeric entry (min: 1 max: 24) So the min and max values are coming though yet I get the error saying 24 is out of range in original post.

 

Highlighted

Re: numeric entry widget not setting default value

So you can't assign 24 as the max? or 24 as a value after you set the limits at 1 and 24?

Highlighted

Re: numeric entry widget not setting default value

I can't set it as a value after the min and max have been set. I get this error saying its out of range.

WL_9354361_0-1598378254463.png

 

Highlighted

Re: numeric entry widget not setting default value

But 1-23 are ok?

Highlighted

Re: numeric entry widget not setting default value

I tried 1 and it gave the same warning errors of being out of range. 

Highlighted

Re: numeric entry widget not setting default value

If I refresh the page whole webpage it works correctly but when I run through the instance again without refreshing the page the same error happens.

Highlighted

Re: numeric entry widget not setting default value

Not too sure what to tell you, perhaps get TS support.

Do the dev tools show any errors at all or give more insight to what it thinks as to how it is configured in runtime?

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum!