cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Thingworx Navigate

SC_10200351
5-Regular Member

Thingworx Navigate

Hi,

I need to upgrade Thingworx Navigate from 1.6 to 9.3, 

From the Thingworx Navigate Upgrade Support Matrix I saw that  I can upgrade Navigate from 1.6 to 8.5 and then to 9,3.

But in Ptc software Download it seems that the release 8.5 for Navigate isn't available.

Can someone help me?

 

SC_10200351_0-1674482140062.png

 

 

 

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
schauvelin
14-Alexandrite
(To:SC_10200351)

OK. Thanks. Open a case to get Navigate/TWX media..

View solution in original post

4 REPLIES 4
schauvelin
14-Alexandrite
(To:SC_10200351)

Hello,

 

8.5 has been removed for security reason.

If you need it temporarily for Upgrade purpose, please open a case and we should be able to provide you the media.

Which DB are you using?

 

Kind regards. 

SC_10200351
5-Regular Member
(To:schauvelin)

PostgreSQL

schauvelin
14-Alexandrite
(To:SC_10200351)

OK. Thanks. Open a case to get Navigate/TWX media..

SC_10200351
5-Regular Member
(To:schauvelin)

Thank you!

Announcements