cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't connect TWX studio with TWX

Newbie

Can't connect TWX studio with TWX

Hello, I have a problem.

I'm making a project using thingworx studio and thingworx with refering youtube guide.

(link : https://www.youtube.com/watch?v=BXbPh7IuTqc&index=5&list=PLrCBNJga3kdGsw2Uof9SOldO4OxsK1cJG)

Almost things are smooth but connection with 3D Gadget and thingworx data is not good. The realtime data(thingworx Thing's property value) is not reflected.

I think the connection is correct. Actually I checked that the connection status was good about 2 weeks ago.

When I changed the thing's property value, the 3D Gadget's value displayed it simultaneously at thingworx view(mobile app).

I attach some image files, please check them and help me.

thanks a lot.

PS. I tried to bind 'GetpropertyValues' service instead of property value, but nothing changed.

thingworx_property value.PNG

Battery Property value is 1.0

twx studio connection status.png

Battery Property value is binded 3D Gadget's Text.

not reflected a things property value.png

Doesn't display 10.

2 REPLIES 2

Re: Can't connect TWX studio with TWX

Hi Yoo hwan​, Does your experience show static data? For example I set the battery level as 20 from Studio. Try doing that first first and then link the same property in ThingWorx Studio with ThingWorx.

Next point of debugging is to view experience on a browser and press F12 to check logs and find the Root cause.

Try these steps and let us know if you still face any issue.

I hope it helps.

Thanks,

Ankit Gupta

Re: Can't connect TWX studio with TWX

Hello Ankit Gupta

I resolved it. The reason was an authorization of accessing Thingworx Composer.

I published a TWX studio project as a public project, so 'es-public-access' user tried to access TWX thing's property values.

However 'es-public-access' user didn't have any authorization for accessing to TWX Composer. (I have no idea about the reason. Distinctly it worked correctly 3 weeks ago.)

Anyway I can publish my projects without any problem now.

Thanks, Gupta.