Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to Learn more.

Hololens and Vuforia Studio: Models are not oriented correctly


Hololens and Vuforia Studio: Models are not oriented correctly

Dear Community,

I have some problems with Vuforia View installed on Microsoft Hololens.

I tried to play the default "Studio Sample - HoloLens Experience", but the orientation of the quadcopter does not follow the orientation of the Thingmark.

I illustrated the situation that I see through the Hololens with Vuforia Studio, please see the attached picture: If I am the blue cube looking at the Thingmark as the blue arrow does, the quadcopter appears behind my head rotated as shown in the image.
Theoretically the quadcopter should appear perpendicular to the thingmark. Instead here it seems to change the position according to the orientation of the hololens.

Then, I tried to create my own experience with a new model, that should have been perpendicular to the thingmark. The result is the same. Moreover, I also checked the "Tracked" and "Tracking indicator" in the thingmark options inside Vuforia Studio in this second experience; I can see the empty green hexagon at the base of my model that is oriented in a wrong position. I suppose that the green hexagon should coincide with the thingmark, but it does not happen.

Does anybody know how to solve this situation?

Thank you in advance.


Hello Gabriele,

I saw that your post is still remaining without answer, so wanted to check now  the problem according your description.

I checked it with the current version of Vuforia studio 8.3.5.

So I persume that you mean the default project comming with the Studio installation  quadcopter whithout any modification (of course you need  to set your own thingmark)

So I tested the project- first created a copy of it and then took a thingmark from my server:


Then publish it to the server and now tested the issue on the HoloLens:


So unfortunately I was not able to reproduce the problem.

The question is now

- what is the version of Vuforia Studio which you use?

-what is the version of your HoloLens ?... I tested with this one:


According to the current documentation  required is (HoloLens must be updated to the latest OS (RS4 10.0.17134.165 )


I used the Vuforia View . What is your version of Vuforia View? To check it : "Hey view,  version"


So , if you did some changes on this project, may be , it will be helpful to export the project. We can check if the issue is could be caused by some unintentional chage in the project.