Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Creo View not opening

5-Regular Member

Creo View not opening

Greetings all.

I have a question regarding Creo View and Windchill. There are a couple of users that are having issues with Creo View opening properly. They are able to see preview images in Windchill but when they click on the preview image, all they get is a new window with a white background. A number of us do not have this issue so I am thinking it has to be in the settings somewhere but I have not been able to find any differences in settings. I am either not looking in the right place, or they are someplace I can't get to.

We are using Windchill PDMlink 10.1 datecode M040 and Creo View version Creo 2.0 datecode M040 build 15.

Any assistance that you can offer will be appreciated.

Thank you for your time and have a good day.


I am interested to see if anyone has a solution because we have a similar issue but we get a black screen. If they close IE out it will then work for them. We are running the same datecode and build of PDMLink, but do not know for sure what the version of Creo View.


We've had this issue also. As stated in several other posts, insure your users are in compatible IE versions. We found on certain PC's (mostly non CAD) that we had to alter a couple of settings in CV Options. Go to File tab, Options; at the top change pulldown to Defaults and select Drawing Viewer. There check the box for Use background color, suggest leaving the background white. You may also want to select the Monochrome display. This way your drawings open as black lines on a white background, otherwise the print may be another color (ours was blue and harder to read).

Lastly, before updating to WF10, I had times when a drawing would seem to open but wouldn't show. Clicking in the empty white space would cause the file to appear. Not sure the cause, just know it worked.

Good luck.


Dean, are they running a supported version of IE or whatever browser you are using? I have users here that upgrade to IE11 and then we have Creo View issues (have to stay at IE10 or lower). As far as the black screen, I have seen this only with older version of CV, running Creo View 3.0 seems to have fixed that issue. WC 10.0 M040 - CV 3.0 M020

5-Regular Member

We are running IE 9 which is a supported browser. I am going to have them try a different browser to see if that helps; after I verify they are using IE 9 first.

If nothing else upgrade them to the latest version of CV...might fix the issue.

We had to add our Windchill address to the "Trusted Sites" list in IE and set the security slider to Low to get it to behave.

We have used the Local Intranet settings with success as well.

On IE 10 and IE 11 sometimes the compatibility settings need to be tweaked. I know it isn't officially supported, but that doesn't mean it wont work. Just riskier.


If you prefer, you can keep the security setting level at Medium and just make the following change:

Put <windchill server url> in the trusted sites list, reset the settings to medium and then make the following single custom level change:

"Allow script-initiated windows without size or position constraints" set to Enable



An update:

I had the user try to open Creo View in Firefox but still had an issue; Firefox did not play well with Creo View.

We then went through the CV 2.0 install process again, which seemed to take quite a while, and updated the license server information. After all of this, the user is able to utilize Creo View now.

Thank you all for your comments and suggestions. Have a good one.

Go to the Quick Links/Software Downloads and try to reinstall Creo view. When you will start CV first time you should be correct when the browser asking you.

If you are working through Firefox open CV window and press on the plugin icon. Then check the plugin permissions.


Sorry for russian language in image. I guess you understand me )

Another possible reason for the white screen could be an issue with the graphics card driver. Make sure that you're using the latest driver.