cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - You can subscribe to a forum, label or individual post and receive email notifications when someone posts a new topic or reply. Learn more! X

Drawings are not opening in Pro-e after they are released to production in WIndchill

ganarajaV
1-Newbie

Drawings are not opening in Pro-e after they are released to production in WIndchill

I have a problem;

Some of the drawings belonging to certain ECN are released to production in WIndchill. After this when I try to open in PRo-E it's not opening. An error message shows as "can not be retrieved". When I check event manager it says, Download failed after maximum number of retries. I am using Windchill 9.0 (date code 080) & Pro-E wildfire 4.0.

Thanks in advance

Ganaraj

12 REPLIES 12

Hi Ganaraja,

I guess the drawings which you are trying to open are large sized or complicated drawings, so the retriveing is not possible.

if possible, please try the solution:

Go to wt.properties file at the location <Windchill_HOME>\codebase.

Go to the attritbute wt.content.downloadTimeOut=600.

Then increase the value from 600 to a higher value (let's say 800 or 1000).

Then try to download & open the drawing.

Regards,

Sandip

This could either be a problem with the client downloading the file, or with the server making the file available for download. If it's an issue with the client downloading the file, then Sandip's suggestion will likely fix the issue. But, you should also check to make sure it's not a server side issue. If it is a server side issue, then there will be an error in the Method Server log at the same time that you try to download the file. Check the MS log, and let us know if you see any errors around the time of the download failure.

Thanks Chris and Sandip,

Finally I have the method server log file & I am not able to understand the issue out of this. Could you please help on this.

The file size is very less around 110KB.This issue happened only during particular dates 20th & 21 may-2014 and for some files.

The Released ECN task had about 500 drawings attached to it.Out of this about 90 files corrupted and not opening in Pro-E. They are all with one iteration.

I have attached the files for your reference.

Thanks,

Ganaraja

LoriSood
22-Sapphire II
(To:ganarajaV)

Ganaraja, there is a lot of data in these logs it would be helpful to know a timeframe for when the retrieval failure occurred along with the username used to perform the retrieval.

Were these family table objects failing retrieval? Are there any additional messages in the Event Manager within Creo?

I ask because I see the following in the log:

Mon 5/19/14 08:25:51: SimpleTaskDispatcher89: java.lang.NullPointerException

Mon 5/19/14 08:25:51: SimpleTaskDispatcher89: ERROR : com.ptc.windchill.uwgm.proesrv.rrc.RRCFamilyTableHelper - RRCFamilyTableHelper.processNeutralData :: Cannot retrieve family table neutral data

Mon 5/19/14 08:25:51: SimpleTaskDispatcher89: com.ptc.windchill.uwgm.common.conflict.UwgmErrorException

Mon 5/19/14 08:25:51: SimpleTaskDispatcher89: at com.ptc.windchill.uwgm.proesrv.util.J03NeutralDataHelper.createValue_J03(J03NeutralDataHelper.java:294)

Mon 5/19/14 08:25:51: SimpleTaskDispatcher89: at com.ptc.windchill.uwgm.proesrv.util.J03NeutralDataHelper.createEpmInstanceNeutralDataJ03(J03NeutralDataHelper.java:215)

Mon 5/19/14 08:25:51: SimpleTaskDispatcher89: at com.ptc.windchill.uwgm.proesrv.util.J03NeutralDataHelper.createEpmInstanceNeutralData(J03NeutralDataHelper.java:173)

Mon 5/19/14 08:25:51: SimpleTaskDispatcher89: at com.ptc.windchill.uwgm.proesrv.rrc.RRCFamilyTableHelper.processNeutralData(RRCFamilyTableHelper.java:921)

....

This type of message relates to retrieving family tables, and can cause retrieval failure, but I'm not sure if this is the data you are having trouble with.

Thanks Lori, The drawings were released in Windchill system on 5/20/14 & 5/21/14. Some of the drawings released during these dates having issue while opening (not opening at all).There is no issue while opening the models & their family table files related to these drawings and they are opening fine in Pro-E. Attached PowerPoint file will give more details.Let me kow if these help in understanding the issue.

Thanks again for your help.

Ganaraja

Were these drawings uploaded to the master site or to a replica site? I'm seeing a lot of downloads failing with "Connection Timed out" errors. The stack traces for these errors show that these are files that were uploaded to a replica site. So, it looks like there are some communication issues between the master and replica sites.

Chris,

The drawings were uploaded to replica site and then to master site.

Whether this communication issue is because of large number of tasks linked to particular ECN and all are released on same day?

Or is there any other reason for the communication issue?

Is there any way to recover the drawing data? Now we are recreating the drawings as new..

How we can avoid this type of issue in future ECN release?

Thanks,

Ganaraja

Were these drawings ever synced back to the master after being uploaded to the replica site? If the replica site is seeing communication issues, then they may still be just on the replica site. When you try downloading the drawings do you see any errors in the MS logs on the replica sites? If not, then it might be a network level communication issue.

In terms of recovering the drawing data, if you're just looking to get the physical file for the drawing, then that's definitly possible. You can get the file name and path by either querying the DB, or by using the -checkBusinessObject flag on the WContentVerify utility. Then, you can just access the file from the filesystem.

GregOlson
15-Moonstone
(To:ganarajaV)

I see this error and my head starts to hurt.....:com.ptc.windchill.uwgm.proesrv.rrc.RRCFamilyTableHelper - RRCFamilyTableHelper.processNeutralData :: Cannot retrieve family table neutral data

We have not been able to open many large assy files due to this error...PTC is working on it, but it's been almost 2 months now with not being able access certain data.

You guys may be seeing the same issues as us.

LoriSood
22-Sapphire II
(To:GregOlson)

Greg, I assume you've been given the FTHealer tool, right? If so, are there issues with running it?

GregOlson
15-Moonstone
(To:LoriSood)

We are way past the healer...they did find an SPR that we are going to try. Hopefully it fixes the issue.

GregOlson
15-Moonstone
(To:ganarajaV)

Open a case with PTC and inquire about SPR 2165479, this fixed our issue of not being able to open certain cad documents.

Top Tags