Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Visit the PTCooler (the community lounge) to get to know your fellow community members and check out some of Dale's Friday Humor posts! X

Error in Creating user in windchill.


Error in Creating user in windchill.


I created some 3-4 users in windchill by using following procedure:

  • Windchill Administrator Login> Site> Utilities.
  • Principal Administrator> New User> Created User Profile> Click OK.

But when I tried to add the users in Product teams, those users were not available in search list. Although these entities are present in Windchill Directory Server Control Pannel.

So I deleted those users & once again tried to create them, but now I am getti an error "Username is not Unique".

I am unable to find the cause of both 1) Why users were not available in search list? 2) Why user is not getiing created again?


Ensure you provide some email address for the users to be listed for the searches. Also, did you deleted the users from both Windchill and Directory server.


Hi Syed,

I already did that. But no use. Please suggest me any alternative solution.



What organization do the users belong to? The product team search will only search for users that are part of the product's org.

And the "Username is not Unique" error would occur if the original users still existed in the DB. As Syed asked above, did you delete the users from both Windchill and the Directory server? If the users were only deleted from the directory server, then they still exist in the DB. Use the principal administrator to find and delete the users. Then you should be able to recreate them.


Have you been able to successfully create users and add them to the product team? Let us know if you're still having any trouble with your users.

Hi Chris,

I am still struggling with the same issue. I checked the Windchill Database after deleting those users. they were not present in the DB. After many attempts I could create the users. But the problem was, while adding the users to particular project teams, I could search the users only with Site Administrator Login. But is it a best practice to add the users with Site Administrator Login?

After that when I logged in with Library Administrator, I could find the users, which were not visible previously with the same login.

I am unable to find out the reason behind that.



When creating new user in windchill I am not able to set attributes. Please find the Image. help me to resolve the issue.




I had the same issue. It tortured me a whole week. It happened after I installed CPS12.
The issue turned out to be related to Internet Explorer set to run as "Microsoft Edge" by default.  Well, Windchill is not compatible with Edge. So change that hidden setting to Explorer and the problem is fixed.
1/ In IE, click on the setting wheel to display the Help Menu.
2/ Click on "F12 Developer Tools"
3/ Click on the "Emulation" tab

4/ Change the "Document mode" drop down to the highest number listed instead of Edge.
5/ Shutdown and restart Windchill to go back to Create New User.