cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

We are happy to announce the new Windchill Customization board! Learn more.

PTC Solution Installer stays blocked

NT_10644494
7-Bedrock

PTC Solution Installer stays blocked

Hello, I downloaded the PTC Solution Installer for Windchill 13. I'm running the installer on Linux CentOS 9 Stream + Java 17, for somewhat reason, the installer gets blocked on the first step: 

"Please wait, PTCSolnInstaller is being configured for your system. This may take a moment"

Stays like that until I close it. 

When I go to the /tmp directory I see that the installer creates a install.dir folder. Inside the temp.lax file I see a message:

"The installer either could not find a Java VM, or the Java VM on this system is too old. The installer requires Java 1.1.5 or later. It can be downloaded from -java.sun.com/products/jdk/1.1/jre/".

The strange thing is I have Java already installed. Any idea why it cannot find the JVM or it's something else?

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

@RandyJones 

@avillanueva 

The problem was (In my case) that I was using CentOS 9 stream. Tried with new machine with CentOS 8 installed and It worked. 

View solution in original post

10 REPLIES 10

Ensure it can find your install of Java:

JAVA_HOME=/pdmlink/ptc/Java;export JAVA_HOME
PATH=$JAVA_HOME/bin:$PATH;export PATH

Set the environment variable before running to where ever its installed.

@avillanueva 

 

Thanks for your response. Still the same error

changed JAVA_HOME to the absolute path which readlink -f $(which java) gives me, also the PATH variable

then changed LAX_VM to /usr/bin/java, but still the same message in the installation directory which is being created in the /tmp folder.

 

I'm not sure if it can be from how I install Java, because I just do "sudo yum install java-17-openjdk*" and many folders are being generated in /usr/lib/jvm/ . The full path which I'm using for JAVA_HOME is pointing to java-17-openjdk-17.0.6.0.10-3.el9.x86_64. For the PATH I set $JAVA_HOME/bin.

Also make sure the environment you are running the installer can see java and which version it is:

which java

java -version

 

which java is giving me /usr/bin/java, but for JAVA_HOME i give the absolute path which i get from readlink -f $(which java)
java -version is just saying Openjdk Red_Hat-17.0.6.0.10-3.el9.
I explained more in the first response of the topic

PTC does not officially support Openjdk. Does not mean it won't work - I haven't tried it myself. They do support Amazon Corretto which is what I use. Simply download Amazon Corretto 17.0.7 .gz format and extract it and set your path to that. Note Amazon Corretto 17.0.8 will not work: Amazon Corretto 11.0.20 and 17.0.8 warnings 

 

The following is what I do for Windchill 12.1.2 java:

[randy@lin02 Windchill]$ pwd
/opt/ptc/Windchill
[randy@lin02 Windchill]$ ls -ld Java* amazon*
drwxr-xr-x. 9 root root    16 Jan 10  2023 amazon-corretto-11.0.18.10.1-linux-x64
drwxr-xr-x. 9 root root    16 Apr 13 17:31 amazon-corretto-11.0.19.7.1-linux-x64
drwxr-xr-x. 7 1001 geoclue 14 Jan 13  2023 amazon-corretto-8.362.08.1-linux-x64
drwxr-xr-x. 7 1001 geoclue 14 Apr 17 17:46 amazon-corretto-8.372.07.1-linux-x64
lrwxrwxrwx. 1 root root    37 May  3 18:51 Java -> amazon-corretto-11.0.19.7.1-linux-x64
lrwxrwxrwx. 1 root root    36 May  3 18:51 Java8 -> amazon-corretto-8.372.07.1-linux-x64
[randy@lin02 Windchill]$

 Then set your path to include /opt/ptc/Windchill/Java at the front of it. Using the Java symlink makes it trivial to switch java versions.

 

One other trick I do to work around /tmp directory permission/size limitation surprises is to remove/create a /opt/ptc/Windchill/tmp_install directory every time before running the installer:

\rm -r /opt/ptc/Windchill/tmp_install
mkdir /opt/ptc/Windchill/tmp_install
chmod 777 /opt/ptc/Windchill/tmp_install
export IATEMPDIR=/opt/ptc/Windchill/tmp_install

/software/ptc/wc/12.1/12.1.2/stage.cps.12.1.2.1/ptc_solution_installer_12.1.2.1/setup

 

Hello, @RandyJones 

 

I downloaded the amazon JDK but still no success. What really bothers me is that, when I give wrong path to LAX_VM environment variable I get a message from the console that Java VM is not provided by the LAX_VM (so when I give the correct one it finds it). I'm not sure if it something from my machine. I even created a tmp_install folder as you showed. It stills gives me the same error. I contacted the PTC eSupport and they told me run the setup using the GNOME GUI, but for somewhat reason when I try to run it via "Run as Program" the terminal just flashes and nothing happens.

I have no idea what "Run as Program" is supposed to do. However you shouldn't need to do that you simply need to have your DISPLAY set. Which if you are on the console in the Gnome gui it should be set to the console by default. Try running some other program that starts a window and make sure it starts up eg xterm. This is always my goto to make sure the DISPLAY is set to an appropriate value. This is also required for Windchill to install it. Once installed you change the servermanager and methodserver startup command properties to not need xterm. However at this time there is no way to do that during the initial install that I am aware of. So I would start by running xterm (as the root user) from the command line and make sure it launches an xterm window:

xterm

BenLoosli
23-Emerald II
(To:NT_10644494)

You also need LAX_VM pointing to your Java install.

@RandyJones 

@avillanueva 

The problem was (In my case) that I was using CentOS 9 stream. Tried with new machine with CentOS 8 installed and It worked. 


@NT_10644494 wrote:

@RandyJones 

@avillanueva 

The problem was (In my case) that I was using CentOS 9 stream. Tried with new machine with CentOS 8 installed and It worked. 


Interesting. I would expect CentOS 9 to also work especially since PTC supports RHEL 9.0 for Windchill 13.

Top Tags