cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Rehost Info*Engine Adapter Setting

SOLVED
BrianToussaint
Tanzanite

Rehost Info*Engine Adapter Setting

I am a little confused with the rehosting guide on the adapter. On page 122 under target.adapter.name, it says "The adapter on the target system takes its name from name of the adapter on the source system. Specify the source system name in this rehosting property."

So if my adapter name is the following: com.<company_network>.<source_server>.Windchill, will my target.adapter.name.1=com.<company_network>.<source_server>.Windchill or do I put in the target server name? If I leave the source name, when/how does that change?

Their directions seem backwards to me with what everything else tells me to do in other sections for target.

Thank you,

Brian

Tags (1)
1 ACCEPTED SOLUTION
Polls

Windchill Customers

What browser do you most commonly use? (Chrome, Firefox, Edge Chromium, Internet Explorer 11, Safari, Other)


Accepted Solutions

Re: Rehost Info*Engine Adapter Setting

Not sure why it's working, but I do have the source adapter names listed for the names, but the properties changed to match the target. However after rehost the adapters all have their names changed to match the target system.

View solution in original post

6 REPLIES 6

Re: Rehost Info*Engine Adapter Setting

Not sure why it's working, but I do have the source adapter names listed for the names, but the properties changed to match the target. However after rehost the adapters all have their names changed to match the target system.

View solution in original post

Re: Rehost Info*Engine Adapter Setting

Brian,

Did you observe the same behavior? It seems like the adapters get copied from one system to another with their previous name. I think InfoEngine might handle renaming them and then IEAdapter handles changing their properties. There does seem to be some weirdness between what is documented and how the IEAdapter task actually works. It says to only list things you want to change, but I'm having issues if I don't list everything. I'm still trying to figure out how to get the Active Directory adapter to copy over correctly. Did you get it to work?

Re: Rehost Info*Engine Adapter Setting

Tom,

Yes I saw the same thing. It just gets confusing when they expect the target server name for everything else that is named target. It seems that should have been named source. Everything seemed to change correctly. However I still cannot login via our corporate LDAP.

Re: Rehost Info*Engine Adapter Setting

Brian,

I have managed to get everything related to the corporate LDAP adapter to properly rehost except for the password. After repeating this process many times (virtual machines with snapshots are wonderful!), I was able to determine several things:

  1. ALL adapter properties must be included in the rehost.properties file. If you leave some out, the rehost tool will mangle them. Some properties get their values changed and others get truncated. By listing ALL the properties and values, everything stays intact - even if nothing is changing.
  2. The LDAP adapter's properties are stored in the configuration node of the Windchill Directory Server. Once you know where they are it's very easy to copy and paste them from production to test and also to copy these same lines to the rehost.properties file.
  3. The corporate LDAP connector's password is stored in the Windchill "mapcredentials.admin.adapters" property, not in Windchill DS. The rehost tool resets this password to the same one entered for the administrative and enterprise LDAP adapters. At this point I have not been able to figure out how to get the rehost tool to accept a different password for the corporate LDAP adapter. (I have a case open with PTC on this.) My current solution for now is to recreate the property from a Windchill shell after rehosting prior to startup. Below is the syntax I use for this.

xconfmanager -s "mapcredentials.admin.adapters=com.tm.Ldap^cn=Manager^password_goes_here"

xconfmanager --add "mapcredentials.admin.adapters=com.tm.EnterpriseLdap^cn=Manager^password_goes_here"

xconfmanager --add "mapcredentials.admin.adapters=com.tm.ActiveDirectory^cn=Windchill,ou=Users,dc=tm,dc=com^password_goes_here"

xconfmanager -p

Re: Rehost Info*Engine Adapter Setting

Tom,

Sorry, I have been on vacation the last couple of days and the tech support guy got with me late on the day before taking vacation so I haven't had time to post here. The support guy pointed me with those same settings. He also pointed me to the settings on the JNDI Adapter. When you edit the adapter, it is wrong in the Provider Url, as it has set it to the target machine instead of keeping it with the correct LDAP server. Make sure to change this to the same as on your production server. Also make sure that the Search Base is the same. You can just copy and past both of these. Once we did all of these things it finally connects. He said that they know about this issue but he didn't know when it will be fixed.

5-13-2015 10-47-33 AM.jpg

Re: Rehost Info*Engine Adapter Setting

Brian Toussaint,

Just wanted to close the loop on this.  Rehost Tool 2.0 incorrectly changes the passwords on additional adapters.  See the following article and SPR.

CS186640

https://support.ptc.com/appserver/cs/view/spr.jsp?n=2883864

Announcements
Learn more about how we are using our browser poll here


Polls

Windchill Customers

What browser do you most commonly use? (Chrome, Firefox, Edge Chromium, Internet Explorer 11, Safari, Other)